LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > MEPIS
User Name
Password
MEPIS This forum is for the discussion of MEPIS Linux.

Notices

Reply
 
Search this Thread
Old 05-22-2005, 10:43 PM   #1
tones111
LQ Newbie
 
Registered: May 2005
Posts: 2

Rep: Reputation: 0
Unhappy fstab troubles


I recently installed Mepis 3.3.1 and have been having troubles setting up permissions on my hard drive partitions. Here's my fstab...

# Static entries below, do not use 'users' option in this area
/dev/hdc1 / reiserfs defaults,noatime,notail 0 0
/dev/hdc2 swap swap sw,pri=1 0 0
none /proc proc defaults 0 0
none /proc/bus/usb usbfs devmode=0666 0 0
none /dev/pts devpts mode=0622 0 0
none /sys sysfs defaults 0 0
/dev/hdc5 /home reiserfs defaults,noatime,notail 0 0
/dev/hdc6 /mnt/hdc6 reiserfs noauto,user,rw,exec,noatime,notail 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,users,dev,ro 0 0

Ideally I would like any user to be able to mount /dev/hdc6 as rw, but I've fiddled with fstab for a while and haven't been able to write to hdc6 from a normal account. Is something amis in my fstab? Any suggestions? Thanks in advance.
 
Old 05-22-2005, 11:02 PM   #2
funkydan2
Member
 
Registered: Mar 2004
Location: Brisbane, Australia
Distribution: VectorLinux; Ubuntu
Posts: 135

Rep: Reputation: 15
Yep - you need to make sure that 'normal users' are in a group that allows writing to /mnt/hdc6.

The 'easiest' way to do this would be to make the permissions on this directory as drwxrwxrwx - so as root run 'chmod 777 /mnt/hdc6' and now everyone will be able to write to that directory.

Daniel
 
Old 05-22-2005, 11:41 PM   #3
mos
Member
 
Registered: May 2005
Location: Orlando, Fl
Distribution: ArchLinux (Can use any distro though)
Posts: 231

Rep: Reputation: 30
actually your fstab entry is wrong, its users not user
 
Old 05-23-2005, 08:20 PM   #4
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
No, actually "user" is just fine. I've been using it in my fstab for years.

From the Unix man pages:

Common for all types of file system are the options ``noauto'' (do not mount when "mount -a" is given, e.g., at boot time), ``user'' (allow a user to mount), and ``owner'' (allow
device owner to mount), and ``_netdev'' (device requires network to be
available). The ``owner'' and ``_netdev'' options are Linux-specific.
For more details, see mount(8).

Last edited by masonm; 05-23-2005 at 08:24 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 06:15 AM
Troubles disabling autofs / What keeps editing /etc/fstab?? powermonkey Fedora 0 04-30-2005 12:32 PM
Fstab troubles with kaudiocreator onelung02 Linux - Hardware 0 11-26-2004 05:48 PM
(version 5.1 chapter 08 fstab) vs (man fstab) rgiggs Linux From Scratch 2 06-03-2004 05:55 PM
troubles with fstab after partitioning hobylinux Linux - Hardware 6 09-05-2003 05:40 PM


All times are GMT -5. The time now is 07:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration