LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > MEPIS
User Name
Password
MEPIS This forum is for the discussion of MEPIS Linux.

Notices



Reply
 
Search this Thread
Old 01-02-2007, 09:21 PM   #1
davidleroux1
Member
 
Registered: Oct 2004
Location: columbus oh
Distribution: mepis
Posts: 109

Rep: Reputation: 15
ati x550 and fgrlx of course


I have used mandrake for a few years but new to mepis

I downloaded mepis 6.0-4 amd64 beta1 just the other day
installed ok

I used synaptic to download fglrx
went ok

tried to use synaptic to download kernel modules
but it said was not needed cause it was already in the kernel
(great!)


so I went to the mepis xconfig and selected
fglrx(official 3d)
reboot

now

my xorg.conf has this

Section "Device"
Identifier "Card0"
Driver "fglrx"
BoardName "unknown"

and I also have this

root@1[david]# fglrxinfo

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X550 Generic
OpenGL version string: 2.0.5814 (8.25.18)


but I get this error when I log in


Composite extension not found
You must use XOrg ? 6.8 for translucency and shadows to work.
Additionally, you need to add a new section to your X config file:
Section "Extensions"
Option "Composite" "Enable"
EndSection

so
where do I put the section "Extensions"
and what else do I need. to get this driver working

not sure how to check Xorg 6.8 but I think
came with the cd
 
Old 01-03-2007, 03:24 AM   #2
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,893

Rep: Reputation: 68
I guess this section can be put after "Modules" section. I have it there, X11R7.1, Beryl works...

Also, are you sure you need fglrx? Just in case, periodically it turns out that dri drivers work better. Periodically - that not...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ati x550, ubuntu, and widescreen macgregor98 Ubuntu 0 10-31-2006 11:34 PM
Problem installing ATI Sapphire Radeon x550 alcaphone Fedora 2 07-29-2006 01:10 PM
Cannot start XOrg with a ATI Radeon x550 vratojr Linux - Hardware 2 11-22-2005 07:40 AM
Mandriva 10.1 + ATI 9000 Pro + fgrlx + TV Out williamp0044 Mandriva 2 05-23-2005 01:54 AM
modprobe fgrlx - FAILED :( szymon Linux - Hardware 4 07-21-2003 07:25 PM


All times are GMT -5. The time now is 03:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration