LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > MEPIS
User Name
Password
MEPIS This forum is for the discussion of MEPIS Linux.

Notices

Reply
 
Search this Thread
Old 02-17-2009, 03:37 AM   #1
rich_c
Member
 
Registered: Apr 2008
Location: UK
Distribution: Mepis; Maemo; openSUSE
Posts: 384
Blog Entries: 74

Rep: Reputation: 81
***Warning to Mepis 7 users.***


Some Mepis users (Those who have been keeping their install up to date but not allowing updates to overwrite sources.list predominantly.) may find that since Debian 5(Lenny) went to stable, they suddenly have hundreds of available updates showing. Don't install the updates you will break your system, probably fatally! Before you do anything, read this and have a look at the Mepislovers forum announcements.

This also applies to anyone who has a M7 CD and wants to install to HD since Feb 14th. In this case, there are two suggestions. Firstly, install Mepis 8 RC3 instead. It is the final release in all but name, practically. Alternatively, if you must install M7 make sure your sources.list has all references to stable replaced with oldstable or etch.
 
Old 02-17-2009, 04:49 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Because M7 is linked to "stable" instead of "etch" oops.
Good heads-up.
 
Old 02-17-2009, 05:21 AM   #3
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Stickied to make it (hopefully) more visible.
 
Old 02-18-2009, 03:42 AM   #4
rich_c
Member
 
Registered: Apr 2008
Location: UK
Distribution: Mepis; Maemo; openSUSE
Posts: 384
Blog Entries: 74

Original Poster
Rep: Reputation: 81
If this warning comes too late and you have hosed your system, Adrian at Mepislovers has posted some steps you can take to get you going again. You will end up with 'Mepis 7.5' though. That being Mepis 7 upgraded to Lenny. From there, it ought to be fairly simple to upgrade all the way to Mepis 8...
 
Old 02-18-2009, 05:16 AM   #5
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
FWIW, I'm running the official 32-bit M7 on this machine &
Code:
grep 'stable' /etc/apt/sources.list
produces nothing. It's all already referencing etch & I think it came that way.

My 64-bit box which runs 7.073uce 64-bit, is down right now so I can't check it at the moment.

I don't know if it would be helpful or harmful to write a sed one-liner to do the replacements.
 
Old 02-18-2009, 06:05 AM   #6
rich_c
Member
 
Registered: Apr 2008
Location: UK
Distribution: Mepis; Maemo; openSUSE
Posts: 384
Blog Entries: 74

Original Poster
Rep: Reputation: 81
There was an update in the middle of last year that, if changes were accepted by the user, would have changed sources.list to point to etch rather than stable. I guess you didn't opt to keep your existing config when prompted.

As far as a script to replace as above, it might be an idea but on the other hand, getting people to do the changes in Synaptic is fairly straightforward and hopefully will encourage them to be a bit more aware of how Mepis hangs together...
 
Old 02-19-2009, 07:57 AM   #7
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
Just to be clear on my situation --
Quote:
Originally Posted by archtoad6 View Post
It's all already referencing etch & I think it came that way.
-- I didn't have to change anything. I guess I did accept the referenced change.


Only one problem w/ Synaptic: I don't use it. From the beginning, I have used KPackage instead. IIRC, it was the default when I started using MEPIS, & I see no reason to switch.

There are about 3 reasons for this:
  • I am thoroughly used to it, & the Synaptic interface is enough different that I see no benefit in changing.
  • Early on, Synaptic was "unusable" for me & my eyesight: I could not (edit: originally left the "not" out) read the gray on black, approx. 5 1/2 point display of the apt-get CLI results. KPackage, OTOH, gave me black on real white & an approx. 6 point display -- just the crucial difference for my old eyes. In some way I have never forgiven the Synaptic developers for being insensitive to the needs of people whose eyes aren't as good as theirs.
  • Most important, much as I love Debian & APT, KDE is primary to me. Therefore, I want my package manager to do KDE across distros, rather than do Debian/APT across desktop environments.
<rant />

Last edited by archtoad6; 09-19-2009 at 06:28 AM. Reason: add crucial missing "not", in red
 
Old 02-19-2009, 09:27 AM   #8
rich_c
Member
 
Registered: Apr 2008
Location: UK
Distribution: Mepis; Maemo; openSUSE
Posts: 384
Blog Entries: 74

Original Poster
Rep: Reputation: 81
Good points!

I guess you already know this but for those who don't, you can edit your sources.list using KPackage by the look of it. Click on Settings, then configure KPackage, then hit the Location of Packages button. I'm guessing from there you can make your changes, click apply and job is done!
 
Old 02-22-2009, 07:21 AM   #9
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
After you click the Location of Packages button, you will then see the lines of your sources.list displayed, each w/ a "Use" checkbox next to it. Checking the box removes the 1st '#' from the beginning of the line, uncommenting it if there is only one '#' at the beginning of the line. It does not distinguish between actual comments & source lines that have been inactivated by commenting them out.

I have attached 2 views of my own modified MEPIS 7 sources.list, the single '#' comments are stock, the '# #' ones are my modifications. Note the clarity of the view using less -- every character in the file is displayed. OTOH, the KPackage view does not distinguish between actual source source lines & comments. Woe unto you if you accidentally "Use" one of those comments.


The solution, if there are any Debian, APT, KDE, or KPackage developers out there reading this, is to allow ';' as an additional comment character; as Samba does for its smb.conf file:
Quote:
Any line beginning with a semicolon (“;”) or a hash (“#”) character is ignored, as are lines containing only whitespace.
-- smb.conf man page
This would allow distros & package mangagers to have a convention that '#' indicates a real comment, while ';' would mark a disabled source line. This seems to be the convention (not a rule, just a convention) in smb.conf & some other config files I have read.

I would retain:
Quote:
The rest of the line can be marked as a comment by using a #.
-- sources.list man page
Attached Images
File Type: png sources.list-KPackage.png (50.0 KB, 16 views)
File Type: png sources.list-less.png (72.0 KB, 9 views)
 
Old 08-10-2011, 05:34 PM   #10
newbiesforever
Senior Member
 
Registered: Apr 2006
Location: Glendale, AZ
Distribution: Distro-homeless. Lost.
Posts: 1,875

Rep: Reputation: 62
Since MEPIS 7 is now quite old, perhaps this sticky should be taken down?
 
Old 08-11-2011, 04:03 AM   #11
rich_c
Member
 
Registered: Apr 2008
Location: UK
Distribution: Mepis; Maemo; openSUSE
Posts: 384
Blog Entries: 74

Original Poster
Rep: Reputation: 81
Yup, the underlying 'problem' isn't relevant anymore.
 
Old 08-11-2011, 04:04 AM   #12
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Just refreshed this and saw the requests. Would have been better to have reported this - we don't always read every thread...
 
Old 08-11-2011, 01:57 PM   #13
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
What do you mean by "taken down"?
 
Old 08-11-2011, 02:16 PM   #14
newbiesforever
Senior Member
 
Registered: Apr 2006
Location: Glendale, AZ
Distribution: Distro-homeless. Lost.
Posts: 1,875

Rep: Reputation: 62
Well, I understand that no posts are ever deleted, and even if they were, I don't propose deleting this thread--it's not worthless like a duplicate post or a joke posted in non-Nix general. How about removing the thread's sticky status and letting it be eventually buried by newer threads?

Last edited by newbiesforever; 08-11-2011 at 02:17 PM.
 
Old 08-11-2011, 02:39 PM   #15
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
There are only 2 stickies for this sub-forum, so I don't think it's doing any harm -- I vote to leave it be. Of course the mods of this forum may disagree. ...
 
  


Reply

Tags
debian, etch, lenny, mepis, stable, update, upgrade


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Warning to Internet Explorer users LXer Syndicated Linux News 0 12-15-2008 09:12 PM
Dovecot Not warning users that password will expire psychobyte Linux - Networking 0 08-01-2006 03:38 PM
Networking Problem in Mepis...Help from Mepis 3.4.3 users..Please depam Linux - Software 2 03-25-2006 10:12 AM
Warning --for Windows Laptop Users And Fc4 1kyle Fedora 14 09-28-2005 09:51 AM
Problem with the creation of new users on my MEPIS system. duffmckagan MEPIS 2 06-11-2005 08:46 PM


All times are GMT -5. The time now is 01:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration