LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 09-30-2003, 01:17 PM   #1
Campitor
Member
 
Registered: Mar 2003
Distribution: Fedora Core 1
Posts: 34

Rep: Reputation: 15
Unhappy xscreensaver on KDE 3.1


I installed Mandrake 9.1 and the KDE environment. I didnt install gnome, but I really like the xscreensaver, so I installed those too. When I use the control panel, though, I cannot find the xscreensavers. Additionally, I cannot lock my computer with the xscreensavers, it goes into the very boring screensaver installed by KDE. How can I get KDE to use xscreensavers? Do I have to tchange the windowmanager in Mandrake Config? I am afraid this will freeze my computer. What I'm doing now is: I shut down the KDE screensaver and run xscreensaver-demo froma konsole...but everytime I lock the computer, the bloody thing goes back on.

thx.
 
Old 10-01-2003, 02:32 AM   #2
LiquidZoo
Member
 
Registered: Sep 2003
Location: Utah, USA
Distribution: Mandrake 9.1
Posts: 66

Rep: Reputation: 15
Ok, first of all, disable the KDE screensaver in the KDE control Center. Make sure you have all of the xscreensaver files installed:

xscreensaver
xscreensaver-command
xscreensaver-demo
xscreensaver-getimage
xscreensaver-getimage-file
xscreensaver-getimage-video
xscreensaver.kss (not sure bout this one)

Then you should be able to run xscreensaver from a terminal and get the config to your liking. There is an option in there somewhere to password protect it (meaning you have to enter a password to go back to your desktop)
 
Old 10-02-2003, 03:01 AM   #3
zarathustra674
Member
 
Registered: Jan 2003
Location: Bible Belt Appalachian Mnts of Western VA/Eastern KY ah hell i don't care, I'm from Grundy. Woo Hoo A megatropolis.
Distribution: Mint KDE w/ a ton of PPA's and Repo's., Might be switching back to Mageia or PCLOS.
Posts: 98

Rep: Reputation: 15
Hey, If you google for mandrake kde and xscreensaver, you should come up with a relevant mandrake related site that tells you how to set up xscreensaver to start when kde does. I dont remember exactly but its basically a little script. If i find my saved copy of the instructions I'll post em.
 
Old 10-02-2003, 12:47 PM   #4
Campitor
Member
 
Registered: Mar 2003
Distribution: Fedora Core 1
Posts: 34

Original Poster
Rep: Reputation: 15
I googled the answer to the problem and found this:
add the following command:

"Xscreensaver --no-splash &"

to .xinitrc or .xsession.

I havent tried it, `cause I`m at work and here I run RH8, but I'll tryit when I get home. Nonetheless, since I am a very big Newbie, I don't know if this is gonna do it. I thought it had to do with some moficication of the control-center script.

Campitor.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kde and xscreensaver not getting along Neruocomp Linux - Software 0 01-03-2005 10:10 PM
xscreensaver in KDE Shafted Linux - Software 0 11-29-2004 07:55 PM
xscreensaver in KDE uses wrong screen size EdoardoC Mandriva 4 03-23-2004 09:15 AM
xscreensaver and KDE Claus Linux - Software 1 09-10-2003 08:47 PM
problem with xscreensaver in MDK 9.1 KDE 3.1.0 Skadam420 Linux - Software 2 07-11-2003 11:24 PM


All times are GMT -5. The time now is 12:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration