LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-26-2004, 03:45 PM   #1
estatik
Member
 
Registered: Oct 2003
Location: CA / NY
Distribution: Mandrake 9.1, 9.2, 10.1, Cooker
Posts: 145

Rep: Reputation: 15
xorg-X11-6.8.1-1 + Mesa-6.1-1


I had installed and tested xorg-X11 + dependencies (current version is 6.7.0-2) from the cooker repository, and much to my surprise, my fps on 3D-acceleration had been dramatically reduced. From ~3200fps to ~900fps in glxgears, and on the average of 100fps-125fps to 20-30fps in torcs/cube/trigger/etc. (all graphic intensive games).

Well, I came upon a repository from another forum, which had a newer version of xorg-X11 + dependencies (Mesa, etc. included) and decided to test them out. I installed the packages last night and so far, everything is working (fps is back up) and I haven't run into any issues.

If anyone is interested, here's the command to add the source:
Code:
 # urpmi.addmedia svetljo http:// ftp.sh.cvut.cz/MIRRORS/Mandrake/people/svetljo/mandrake/probably_broken/RPMS/ with synthesis.hdlist.cz
*(I had to leave a space between the "http://" and "ftp.sh..." so it wouldn't show up as a link. And don't let the "/probably_broken/" you out. From what I have read from other's posts, no one is having problems with these packages.)

And update your current libxorg*, xorg-X11*, Mesa* and libMesa* packages.

Last edited by estatik; 09-26-2004 at 03:50 PM.
 
Old 10-07-2004, 08:33 AM   #2
DanielEKFA
LQ Newbie
 
Registered: Oct 2004
Posts: 12

Rep: Reputation: 0
Thumbs up

I f***ing love you man! I have spent so much time debugging my Intel integrated card to get DRI enabled, I compiled 14 different kernels but nothing worked! Now the baby works like a charm! OH YEAH! Thank you so very much!
 
Old 10-07-2004, 10:43 PM   #3
estatik
Member
 
Registered: Oct 2003
Location: CA / NY
Distribution: Mandrake 9.1, 9.2, 10.1, Cooker
Posts: 145

Original Poster
Rep: Reputation: 15
Cool, that it helped your situation. But svetljo gets all the credit...I was just the "messenger".

BTW, just out of curiosity, which versions of xorg/kernel were you using before the upgrade?
 
Old 10-08-2004, 01:51 AM   #4
DanielEKFA
LQ Newbie
 
Registered: Oct 2004
Posts: 12

Rep: Reputation: 0
I like messengers!

I use(d) my own compiled 2.6.8.1 kernels, but in troubleshooting I installed and tested pretty much every kernel on the main, contrib, and cooker sites If I remember correctly, the Xorg I ran before was 6.1.something? It's the one that's on cooker now anyway

Cheers,
Daniel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple versions of xorg-x11-Mesa-libGLU Ian D Linux - Software 0 10-18-2005 02:14 PM
how do i remove xorg-x11-Mesa-libGL-6.8.1-12? trscookie Linux - Games 2 04-25-2005 06:12 AM
xorg-x11-Mesa-libGL RPM token2004 Linux - Newbie 1 04-07-2005 06:46 AM
nvidia 66.29 driver-xorg-x11-Mesa-libGL conflict yellowtail Linux - Software 3 02-28-2005 08:34 PM
xorg-x11-libs required by xorg-x11-devel darknails Fedora 1 01-13-2005 02:34 PM


All times are GMT -5. The time now is 05:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration