LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 08-22-2004, 10:06 AM   #1
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Rep: Reputation: 34
X server.. died somehow


I have this problem with my X server. Some background information first: I'm using Mdk10 2.6.3-15mdk kernel on a Dell Inspiron 5100 laptop; ATI Radeon 7500 mobile. I installed the prism54 driver for my NetGear Wireless PC Card for my laptop (model WG511 2.4Ghz 54Mbps b/g); it has become eth1. I believe it recompiled my kernel.

Afterwards my computer acted abnormally, for example konqueror (as a file browser) wouldn't load, unless you loaded it as the webbrowser from the start menu first, and then tried opening a folder. Second, in addition to that wireless ethernet card, I also have a standard ethernet card which is eth0. I noticed very quickly that upon booting (everytime), it would take a long time to initialize eth0 and eth1 (eth0 starts long because I do not use a cable to connect to the router anymore), both come up as status [FAILED]. So I went into the Mandrake Control Centre and disabled the booting of the 'network' service at start up. This worked, but if I killed KDE (halting the Xserver) to go back into text mode, and then typed 'startx', it failed because it couldn't establish a connection at ":0.0". I went su and noticed that the prompt didn't have a name for my computer as it normally does:

[alex@localhost Documents]$ su
Password:
[root@ Documents]#

I reboot, change the network booting settings (e.g. i can set eth0 and/or eth1 to boot at start up, as well as the 'network' service). I chose eth0 to NOT boot; network and eth1 TO boot, etc. Finally it seemed to have fixed itself, then upon my booting the computer TODAY, i couldn't even start the GUI once....


i wrote down the error:

"> Using last definition for conflicting fields
>Warning: Symbol for key <AC10> redefined
"

^^that is a long list with other things for <AC10>, then:

"Errors from xkbcomp are not fatal to the Xserver
Could not init font path element unix/:-1, removing from list!

Fatal server error:
could not open default font 'fixed'

When reporting a problem related to a server crash, please send the full server output, not just the last two messages. This can be found in the log file '/var/log/XFree86.0.log'. Please report problems to xfree86@xfree86.org

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remanining"

This problem has stumped me completely, and I am usually very ambitious to solve problems on my own using this forum (other people have the same problem usually) and google.. If ANYBODY has ANY clue what is going on here, I would happy to hear it. (I thought about changing back to the default kernel - as it was before prism54 changed it). If there are any logs that would help, let me know, too. Thanks in advance.
 
Old 08-22-2004, 10:31 AM   #2
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
don't know about all the network stuff, but it sounds kind of strange. (btw, it most definitely did not recompile your kernel. you would have to do that yourself -- which might not be a bad idea.)

X needs the fixed font to start, and it's telling you it can't find it. make sure your font paths are in your xorg.conf file (/usr/X11R6/lib/X11/fonts/misc and 100/75dpi paths), also add the paths to /etc/fonts/local.conf or ~/.fonts.conf if you have them, and then run # fc-cache -fv to update your font cache.

it looks like your keymappings are screwed up, also. maybe X got corrupted somehow from installing the prism drivers? i don't know, but i think the idea to boot to the working kernel is a good one, and then see if you can get into X from there. if not, you might be looking at a pretty major overhaul -- of X at least. it appears that things might have gotten really messed up that shouldn't have from installing network drivers.
 
Old 08-23-2004, 03:53 PM   #3
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Original Poster
Rep: Reputation: 34
I only have that one kernel to boot (except for the nonfb and 267something) and I couldn't find an xorg.conf file (I typed '# find / -name 'xorg.conf' and nothing came up). I found many .gz'd files in the /usr/X11R6/lib/X11/fonts/misc/ and in the /usr/X11R6/lib/X11/fonts/100dpi folder, and i grep'd for 'fixed' (I don't know if the font it wants would be listed there or if it had the string 'fixed' in it...) but didn't see anything. I have both an /etc/fonts/local.conf and a ~/.fonts.conf

I posted all the files that i changed (new and old versions) and the output of the fc-cache -fv command and the XFree86 log file here:

http://amerr1.tripod.com/xserver/index.html

where is the xorg.conf file located? And.. did I add the paths correctly (because it seems to have registered with that command, as the output lists it)?

Thanks,
alex
 
Old 08-23-2004, 04:14 PM   #4
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
the x configuration file is in /etc/X11/xorg.conf You might want to check and post that.
 
Old 08-23-2004, 04:29 PM   #5
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Original Poster
Rep: Reputation: 34
this may sound strange but i don't have an 'xorg.conf' file in the /etc/X11/ directory (I did ls -al and nothing with that name showed up)

could that be why it's not starting the Xserver?! this is really weird....
 
Old 08-23-2004, 04:36 PM   #6
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
Quote:
Originally posted by student04
this may sound strange but i don't have an 'xorg.conf' file in the /etc/X11/ directory (I did ls -al and nothing with that name showed up)

could that be why it's not starting the Xserver?! this is really weird....
well if you have XFree86 it'll be XF86Config.
 
Old 08-23-2004, 08:32 PM   #7
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Original Poster
Rep: Reputation: 34
ah right.. that i have (XF86Config-4) and i posted it on that webpage (see above link). For that file I am not sure what to do..

I can see the FontPath "unix/:-1" there, which was in the error message.. startx still doesn't work *sigh*. Where and how do I add the two paths you mentioned to the XF86Config-4 file? Do i just type -- FontPath "/path/to/font/" ?

Thanks,
alex
 
Old 08-23-2004, 09:42 PM   #8
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
comment out that unix line. that is for some other font server, Xfs, i think. add at least the following lines directly underneath that (and before the EndSection), replacing the path with the path to your fonts if necessary (check /usr/lib/X11 for font directories if they're not in /usr/X11R6/lib/X11):
Code:
FontPath        "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath        "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath        "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath        "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath        "/usr/X11R6/lib/X11/fonts/Type1"
FontPath        "/usr/X11R6/lib/X11/fonts/Speedo"
(etc. -- add whatever directories you have.)

then run # fc-cache -fv just to make sure they're cached, and restart X to see if it works.
 
Old 08-24-2004, 02:03 AM   #9
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Original Poster
Rep: Reputation: 34
I modified the XF86Config-4 file (backed it up, of course) and posted it on the site. I'm happy to say it loaded the full blue screen and an "X" for the mouse... but nothing further. I have updated the #fc-cache -fv output and the XF86Config.0.log. Well.. I think this is progress so far - unless I'm wrong..?

The only error I can see in the log file is the loading of the keymap (I cannot find it not being able to load the font 'fixed', but that file is big, so I could have over-looked). Hmm.. will fixing the keymap allow it to continue loading (whatever keymap might be)?

BTW when I Ctrl+Alt+Backspaced to exit out of the blue screen i saw messages (mainly in the log file) with:

"
AUDIT: Mon Aug blabla 2004: 2824 X: client 1 rejected from localhost
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
"

..repeated, then

"
giving up
xinit: No such file or directory (errno2): unable to connect to Xserver
xinit: No such process (errno3): server error
$
"

I don't know if those are of any importance, but I put them there anyway.

Thanks,
alex
 
Old 08-24-2004, 11:17 AM   #10
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
a couple of things i noticed were missing from your config file that i've seen in most others. try adding the following stuff as described. i'll have more time later today to take a closer look, but try adding these at least, maybe it will help. if not, i'll try to check in later.

btw, *posting errors is good.* that thing about not finding xinit seems like a major problem, but maybe it will turn out not to be. as i said i don't have time to check it out right now. so for now:

add this to Section "Module" (the one that starts with the Load "dbe" line):

Code:
SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
EndSubSection
add this to the same section where you added the fonts:

Code:
RgbPath    "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"

the Rbg thing might just be for LCD monitors or fine tuning the antialiasing or something, and i've seen the modules line both commented out and not, but at least it's a start. in the meantime, keep !

another idea is that you might want to backup your config file and run xf86config (as root). that will run you throught the configuration and write a new config file that hopefully will be more usable.

p.s. you are using KDE, right? when you say "blue screen with the mouse," i assume you mean you are getting a blue background and not using some windows-speak for a locked up screen, etc.? do you get any menu when you right click the mouse?
 
Old 08-24-2004, 01:15 PM   #11
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Original Poster
Rep: Reputation: 34
Yes, I am using KDE; the blue screen is actually a blue screen - the one I normally see when start up, and the mouse is just that X that i can move around, but nothing works when i click any of the buttons (no menus or anything).. it just sits there.

wellllllllll I changed the config file, updated it on my site, as well as the log. As I was still in root, I just typed "startx" after editing the file, and KDE actually started! (but in root) I fiddled around a bit to see if it actually did work, and I saw that some window's titlebars (around the three buttons on the upper right) had squares around the without the color of the rest of the titlebar (red). They were white, but if i moved them around they went away/came back, etc.

Anyway, I logged out of the X session, and then out of su'ing. I typed "startx" and the same thing happened as before - blue screen and mouse is an X, no menus.

The message I saw on the screen after logging out of root's X session was:

"
>
>Warning: Symbol map for key <AC05> redefined
> Using last definition for conflicting fields
"
and that <AC05> goes to AC10, then LFSH, AB01-AB10, BKSL, LCTL, SPCF

"
Errors from xkbcomp are not fatal to the X server
Could not init fontpath element /usr/X11R6/lib/X11/fonts/Speed, removing from list!

waiting for X server to shut down
[root@localhost X11]#
"

And the message i saw on the screen after Alt+Ctrl+Backspacing of user alex's session was basically the same as last time... :

The same as root above (except waiting for Xserver to shut down), then the AUDITs as i wrote in the previous post, and finally those annoying errnos:

"
giving up

xinit: No such file or directory (errno2): unable to connect to Xserver

xinit: No such process (errno3): server error
"

I'm going to try the xf86config and see if i can compare my config file to a friend's (not actually USE it, but see what's the same/diffferent, as he uses mandrake 10 also, on a desktop computer)

-alex
 
Old 08-24-2004, 02:21 PM   #12
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
i'm not really familiar with mandrake package management, but is there any way to remove XFree and reinstall it, through mandrake tools or urmpi or whatever? with the apparent permissions problems, rendering problems, and xinit problems, that might actually be the best course of action at this point, to hopefully "wipe the slate clean" and get a fresh version of X (installing that driver must have really wacked something). then you can run xf86config and also make a custom config file (btw, it's "Speedo" with an o at the end, which is why you're getting that one error ). and as it says, the keyboard error is not fatal, so don't worry about that until you get X actually working.
 
Old 08-24-2004, 02:22 PM   #13
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Original Poster
Rep: Reputation: 34
So I tried the "xf86config" command, and did my best to configure it (I went back to the original was-working config file for the HorizSync and VertRefresh, because I had no clue what to put). It made the file, and I looked it over - the things you told me to add were in it this time. "startx" gave the same results: errno's for user "alex" and boot up fine with root (except for the mouse not responding immediatly in the beginning, but that's because it probably has the wrong one dedected - that's not the issue here, though). I also posted the new config file and log file. I'll see what else there is to do.. maybe trying XFdrake? since that's what created the file in the first place... *sigh*...

Thanks so far,
alex
 
Old 08-24-2004, 02:23 PM   #14
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Original Poster
Rep: Reputation: 34
haha you posted 1 minute before i posted mine..
 
Old 08-24-2004, 02:26 PM   #15
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Original Poster
Rep: Reputation: 34
ok i'll take a look at it and see if i can package-remove it and then install.. hmm maybe i really shouldn't have touched the prism54 drivers... but wireless in linux is so cool...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo X-Server died EmberWhite Linux - Software 3 02-22-2005 05:01 PM
kde died! drum2jc Linux - Software 12 01-17-2005 07:31 PM
TightVNC Server died after overnight netkepala Linux - Networking 2 02-26-2004 09:21 PM
CDROM died! don_dimo Linux - General 6 11-13-2003 01:35 PM
Server Unexpectedly died (was i hacked?) gabadoo Linux - General 2 03-13-2002 01:33 AM


All times are GMT -5. The time now is 07:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration