LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 03-16-2005, 05:39 PM   #1
The Patbon
Member
 
Registered: Nov 2004
Posts: 35

Rep: Reputation: 15
WPA on wireless network


I have a working NETGEAR wg511 card (prism drivers). I got it to work with WEP, but I would like it to work with WPA so my home network will work with the other computers that get messed up with WEP.


How do I get WPA-PSK working?
 
Old 03-16-2005, 08:27 PM   #2
guitarhero14
Member
 
Registered: Jul 2003
Distribution: Suse 10.1
Posts: 38

Rep: Reputation: 15
I am working on the exact same thing. There is a program, wpa_supplicant but when I try to run the .conf file it gives me an error of:

Invalid configuration line: ctrl_interface=/var/run/wpa_supplicant

please help


EDIT: I have an WMP54G card.
 
Old 03-16-2005, 08:28 PM   #3
The Patbon
Member
 
Registered: Nov 2004
Posts: 35

Original Poster
Rep: Reputation: 15
yo yo, where can I get that program
 
Old 03-16-2005, 08:32 PM   #4
guitarhero14
Member
 
Registered: Jul 2003
Distribution: Suse 10.1
Posts: 38

Rep: Reputation: 15
Here

With a tutorial, which doesnt work for me.
 
Old 03-16-2005, 08:34 PM   #5
The Patbon
Member
 
Registered: Nov 2004
Posts: 35

Original Poster
Rep: Reputation: 15
All right, I've had ndiswrapper before so maybe if I figure it out I can help you
 
Old 03-16-2005, 08:35 PM   #6
guitarhero14
Member
 
Registered: Jul 2003
Distribution: Suse 10.1
Posts: 38

Rep: Reputation: 15
I sure hope so, I'll be check back here often. I have been trying all day to get WPA to work. Good luck!
 
Old 03-16-2005, 09:00 PM   #7
guitarhero14
Member
 
Registered: Jul 2003
Distribution: Suse 10.1
Posts: 38

Rep: Reputation: 15
New problem:

I ran

wpa_supplicant -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf -dd

NOT under root, I didnt get the previous error but now i get this:


Initializing interface (2) 'wlan0'
ioctl[SIOCSIWMODE]: Operation not permitted
Could not configure driver to use managed mode
SIOCSIFFLAGS: Permission denied
Could not set interface 'wlan0' UP
socket(PF_PACKET, SOCK_RAW): Operation not permitted
SIOCSIFFLAGS: Permission denied
rmdir[ctrl_interface]: no such file or directory


This is making me mad
 
Old 03-16-2005, 09:48 PM   #8
The Patbon
Member
 
Registered: Nov 2004
Posts: 35

Original Poster
Rep: Reputation: 15
most of that means you aren't root
 
Old 03-16-2005, 09:53 PM   #9
guitarhero14
Member
 
Registered: Jul 2003
Distribution: Suse 10.1
Posts: 38

Rep: Reputation: 15
but when I am root I cant even load the .conf file.

I think I have solved my problem, I will check back when I know for sure.

how are you doing so far?
 
Old 03-16-2005, 10:28 PM   #10
guitarhero14
Member
 
Registered: Jul 2003
Distribution: Suse 10.1
Posts: 38

Rep: Reputation: 15
Once again another problem:

I ran:
wpa_supplicant -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf

and I get:

Associated with (mac address)

and it loops this over and over. Any suggestions?

Last edited by guitarhero14; 03-16-2005 at 10:32 PM.
 
Old 03-16-2005, 10:55 PM   #11
The Patbon
Member
 
Registered: Nov 2004
Posts: 35

Original Poster
Rep: Reputation: 15
Yeah, I don't know, I'm going to try this again tomorrow plugged in with an ethernet cable so I don't have to keep coming on windows to check the internet.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless with WPA MartenH Linux - Wireless Networking 4 08-18-2006 02:45 AM
Wireless w/ WPA in 9.2 Spyder-One Suse/Novell 0 01-23-2005 08:04 AM
Configuring WPA-secured wireless network dori Slackware 1 10-07-2004 06:30 AM
Wireless-G and WPA encryption ?? lawadm1 Linux - Wireless Networking 1 06-19-2004 05:03 PM
WPA Wireless Config merana Linux - Wireless Networking 4 03-26-2004 01:03 PM


All times are GMT -5. The time now is 12:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration