LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 01-12-2006, 04:49 PM   #1
GregSP
LQ Newbie
 
Registered: Dec 2003
Location: Greece
Distribution: Mandrake9.2 ??
Posts: 4

Rep: Reputation: 0
Why I cannot change my keyboard layout?


I have installed Mandriva 2006 recently and although I selected the Greek kbd layout, the layout remains US. The xorg.conf file is Ok, the /etc/sysconfig/keyboard file is OK. In /var/log/messages it says that the iso-8859-7 was successfully loaded, the alt_shift_toggle was also loaded, but I cannot write in Greek. The Scroll led that should be on, when the Greek layout is selected, is usually off but not always. Does anybody knows something about it? It is the first Mandrake release that causes this problem.

Last edited by GregSP; 01-12-2006 at 04:57 PM.
 
Old 01-12-2006, 04:58 PM   #2
Penguin of Wonder
Senior Member
 
Registered: Sep 2005
Location: West Virginia
Distribution: Gentoo
Posts: 1,249

Rep: Reputation: 45
Look in your xorg.conf file. Mine looks like this:


Code:
Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection
I'm guessing, since i'm not greek, your's should be similar except say greek where mine us.
 
Old 01-12-2006, 06:12 PM   #3
GregSP
LQ Newbie
 
Registered: Dec 2003
Location: Greece
Distribution: Mandrake9.2 ??
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for your reply. My xorg.conf file is correct and the /etc/sysconfig/keyboard file is also correct. However I still cannot change the kbd layout. Is there some other file I should check?

Last edited by GregSP; 01-12-2006 at 06:13 PM.
 
Old 01-14-2006, 05:48 PM   #4
eka
Member
 
Registered: Jul 2005
Location: Bulgaria Plovdiv
Distribution: Mandriva 2006
Posts: 104

Rep: Reputation: 15
Go to: Start-->System-->Configuration--->KDE--->(something like Accessibility) and then you will see something about keyboard but not country and language.Sorry it is difficult to me to translate from BG to EN
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change keyboard layout in console danielfisica Slackware 9 06-10-2014 09:22 AM
XFCE: how to change the keyboard layout? athanatos Slackware 18 09-17-2008 01:37 AM
how can I change tty keyboard layout? fmardones Linux - Software 0 01-15-2005 08:09 PM
kde: change keyboard layout kpachopoulos Linux - Newbie 3 09-29-2004 03:01 PM
How do i change the keyboard layout? ArmedCoder Linux - Hardware 0 11-20-2003 06:25 PM


All times are GMT -5. The time now is 03:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration