Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.


  Search this Thread
Old 08-18-2008, 12:46 PM   #1
LQ Newbie
Registered: May 2008
Location: Hawaii
Distribution: Ubuntu, debian, xandros
Posts: 24

Rep: Reputation: 0
Exclamation Volume is always being turned down automatically

Hey guys. I'm new to linux and installed mandriva 2008 Spring on my Dell Inspirion 1100 laptop. All is well except that the volume is always being turned down automatically almost as if a key was stuck but all the keys are working properly. So how do I get it to stop so the "Volume" window will go away and i can actually use my desktop?

Old 08-19-2008, 07:36 AM   #2
Senior Member
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 208Reputation: 208Reputation: 208
Startup your KDE Control Centre, then go to Kde Components--> Session Manager, select Start with empty session, apply, logout then log back in again. If all is well you can change your setting back to Restore previous session.
Old 08-20-2008, 11:46 AM   #3
Senior Member
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
Additionally, if you want KDE to load with the same starting configuration regardless of what was running the last time you shut down, choose the Restore manually saved session option in the session manager, load any KDE software you want to be loaded at startup then run the Save session item in K-menu to manually save your session. If you use the kickoff style menu this item is in the leave tab.

Old 08-24-2008, 09:58 PM   #4
Registered: Sep 2003
Location: New Hampshire USA
Distribution: Mandriva 2006 & 2007 Power Pack Club
Posts: 178

Rep: Reputation: 30
I am having the same exact problem and it is extremely annoying. I thought the laptop I bought on ebay was broken. It happens "right out of the box" so to speak. Take a clean install and the second you are fully logged in the on screen display comes up for the volume and the progress bar it uses to show the volume level dives straight for zero.

You then use the actual volume buttons above the keyboard or the function key and the buttons for volume, on my Latitude D600 it is the page up and down keys, it will bring it up but the second you let of the button it bottoms out back at zero. If you go and right click on the Kmix system tray icon and change the master channel to say the CD volume slider it will do it to it.

I googled this and searched several forums thoroughly including this one,and after several hours of trying to figure out what is what I came to the conclusion that it is an issue with KDE itself whether it is vanilla from or through the customizations Mandriva made to it. I don't have the problem when in WinXP or another desktop environment in Linux.

My temporary fix so I can actually see what I have for windows open and to not have any volume slider being zeroed was the following:

This is not a fix, fix. It is just a work around. It disables the volume multimedia buttons and the ones available using the function key.

1. Open: KDE Control Center

2. Select: KDE Components

3. Select: Service Manager

4. Disable: KMilo

It stinks loosing some of the OS dependant function keys on the keyboard but the system is definitely usable now. Please if anyone can post an actual fix to this I know the poster of this thread and myself would be more then thankful. I know I would be.


mandriva2008, volume

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora LVM volume group & Physical Volume resize problem gabeyg Fedora 1 05-14-2008 12:26 PM
Volume Control: Intel 82801DB-ICH4 (Alsa mixer) won't save volume levels. cayspekko Linux - Newbie 2 01-31-2008 01:17 AM
Keyboard volume knob configuration-cannot change volume. Ariox Ubuntu 1 03-22-2007 03:06 PM
When amaroK jumps to next track, volume automatically increases (kmix) eBopBob SUSE / openSUSE 0 05-28-2006 09:51 AM
gnome's volume applet automatically fades out wza Linux - Software 0 06-19-2004 03:48 AM

All times are GMT -5. The time now is 01:20 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration