LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 05-28-2004, 02:24 AM   #1
rgiggs
Member
 
Registered: Apr 2004
Location: berkeley, ca
Distribution: slk10, winxp
Posts: 313

Rep: Reputation: 30
use mtab as fstab?hi


hi,
as root, i accidentally overwrote fstab, so i just copied mtab to fstab, restarted, and the system seems to be running fine. any comments on using mtab as fstab?
also, i expected root to have noglobber set. now that i find out it isn't set, how can i make it that root always has noglobber?
thanks.
 
Old 05-28-2004, 09:07 AM   #2
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
1. mtab contains the mounted fs, so any fs that wasn't mounted (e.g. /mnt/cdrom) may have lost it's configuration. Also if you use automount, it will write in mtab too, so you'll have some lines in fstab that shouldn't be there.

2. not sure what noglob is, but I suggest to put a 'alias cp="cp -i"' and 'alias mv="mv -i"' in /root/.bashrc
You can place there any command to be exec when opening a terminal
 
Old 05-28-2004, 12:29 PM   #3
rgiggs
Member
 
Registered: Apr 2004
Location: berkeley, ca
Distribution: slk10, winxp
Posts: 313

Original Poster
Rep: Reputation: 30
hi,
i have those aliases. noglobber prevents redirecting to an existing file. for example, this was how i screwed up fstab: cat > /etc/fstab. i meant to do cat >> /etc/fstab. with noglobber, the command would've failed. to force it, must do >!. i guess i'll just try 'set noglobber' and see what happens.
thanks.
 
Old 05-28-2004, 12:33 PM   #4
rgiggs
Member
 
Registered: Apr 2004
Location: berkeley, ca
Distribution: slk10, winxp
Posts: 313

Original Poster
Rep: Reputation: 30
hmm,
i think it is noclobber.
anyway.
 
Old 05-29-2004, 05:07 AM   #5
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
Thank you for making me discover this useful option.
I googled for it and foud this: http://www.jsanten.demon.nl/linux/sh...ng/index1.html

"To activate noclobber you use set -C"
 
Old 06-08-2004, 12:47 PM   #6
rgiggs
Member
 
Registered: Apr 2004
Location: berkeley, ca
Distribution: slk10, winxp
Posts: 313

Original Poster
Rep: Reputation: 30
welcome,
but also thanks for finding the information. i forgot about it all together.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 06:15 AM
How to edit mtab/fstab g-string 3 Linux - Distributions 4 02-03-2006 04:27 PM
mtab and fstab problems Henster Linux - General 4 08-31-2004 05:38 AM
/etc/fstab or /etc/mtab praveenv Linux - Newbie 1 08-17-2004 04:03 AM
what is the difference between /etc/fstab and /etc/mtab ? Xavius Linux - Newbie 2 03-27-2004 08:15 AM


All times are GMT -5. The time now is 07:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration