LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   USB hard disk read only (http://www.linuxquestions.org/questions/mandriva-30/usb-hard-disk-read-only-385680/)

neranjana 11-22-2005 10:30 PM

USB hard disk read only
 
Hi

I have an external usb hard disk. I used it with Mandrake 10.0. I could read and write into it. Now I installed Mandriva 2006 Powerpack and the disk gets mounted automatically and seems a lot faster than Mandrake 10.0 but I can't write to the disk nor can I delete anything from it. I checked the controlcenter and it is not mounted as readonly and I checked the fstab and when the usb hard disk is connected the fstab file is as follows.

/dev/hda3 / ext3 noatime 1 1
/dev/hda4 /home ext3 noatime 1 2
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/hda1 /mnt/windows vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda2 swap swap defaults 0 0
/dev/sda1 /mnt/removable vfat pamconsole,exec,noauto,codepage=850,iocharset=iso8859-1,managed 0 0

When the hard disk is removed, the fstab file is as follows.

/dev/hda3 / ext3 noatime 1 1
/dev/hda4 /home ext3 noatime 1 2
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/hda1 /mnt/windows vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda2 swap swap defaults 0 0

Why does Mandriva 2006 has a problem which Mandrake 10.0 did not have?
Does anybody know how to fix this problem?

Thanks

Neranjana

bioalchemist 11-22-2005 10:49 PM

I'm pretty sure if you add "rw" to the appropriate line in fstab, you'll be home free:

/dev/sda1 /mnt/removable vfat pamconsole,exec,noauto,codepage=850,iocharset=iso8859-1,managed 0 0

make it this: /dev/sda1 /mnt/removable vfat pamconsole,exec,noauto,codepage=850,iocharset=iso8859-1,managed,rw 0 0



for the record, here's mine:

/dev/sdb1 /mnt/external auto umask=0,iocharset=iso8859-1,codepage=850,rw,users 0 0

hope this helps!

neranjana 11-22-2005 11:45 PM

Hi
Thanks for the reply. But it didn't work. The line corresponding to the drive is automatically added to the fstab when the device is connected and the next time it is connected the rw is gone.

Any other tip?

Thanks

Neranjana

neranjana 11-23-2005 03:58 AM

When I checked the /var/log/messages file the following was found

Nov 23 15:50:48 neranjana kernel: usb 3-2: new high speed USB device using ehci_hcd and address 15
Nov 23 15:50:48 neranjana kernel: scsi12 : SCSI emulation for USB Mass Storage devices
Nov 23 15:50:48 neranjana udev[13857]: run_program: exec of program failed
Nov 23 15:50:53 neranjana kernel: Vendor: SAMSUNG Model: MP0603H Rev: UD10
Nov 23 15:50:53 neranjana kernel: Type: Direct-Access ANSI SCSI revision: 00
Nov 23 15:50:53 neranjana kernel: SCSI device sda: 117304992 512-byte hdwr sectors (60060 MB)
Nov 23 15:50:53 neranjana kernel: sda: assuming drive cache: write through
Nov 23 15:50:53 neranjana kernel: SCSI device sda: 117304992 512-byte hdwr sectors (60060 MB)
Nov 23 15:50:53 neranjana kernel: sda: assuming drive cache: write through
Nov 23 15:50:53 neranjana kernel: /dev/scsi/host12/bus0/target0/lun0: p1
Nov 23 15:50:53 neranjana kernel: Attached scsi disk sda at scsi12, channel 0, id 0, lun 0
Nov 23 15:50:53 neranjana kernel: Attached scsi generic sg0 at scsi12, channel 0, id 0, lun 0, type 0
Nov 23 15:50:53 neranjana pam_console.dev[13894]: Restoring console permissions for /dev/sda /dev/discs/disc1/disc /dev/scsi/host12/bus0/target0/lun0/disc
Nov 23 15:50:53 neranjana pam_console.dev[13905]: Restoring console permissions for /dev/sg0 /dev/scsi/host12/bus0/target0/lun0/generic
Nov 23 15:50:53 neranjana pam_console.dev[13928]: Restoring console permissions for /dev/sda1 /dev/discs/disc1/part1 /dev/scsi/host12/bus0/target0/lun0/part1
Nov 23 15:50:54 neranjana fstab-sync[13936]: added mount point /mnt/removable for /dev/sda1
Nov 23 15:52:44 neranjana kernel: FAT: Filesystem panic (dev sda1)
Nov 23 15:52:44 neranjana kernel: invalid access to FAT (entry 0x00000001)
Nov 23 15:52:44 neranjana kernel: File system has been set read-only

Is this something wrong with my disk or with Mandriva 2006? The same disk works fine on windows, Mandrake 10.0. And flash disks also work fine on this Mandriva 2006. Any suggestions?

Thanks

Neranjana

sam.pedraglio 11-23-2005 04:29 AM

he line is automatically added to your fstab because of the presence of the option
managed

remove it the first time you connect the drive and it will stay there forever, ready for the next plug-in.

neranjana 11-23-2005 05:22 AM

Yes. You are right. When I removed managed, the line stayed there. But still even if I add rw in the fstab, the device is mounted readonly. The log shows the error

Nov 23 17:19:35 neranjana kernel: FAT: Filesystem panic (dev sda1)
Nov 23 17:19:35 neranjana kernel: invalid access to FAT (entry 0x00000001)
Nov 23 17:19:35 neranjana kernel: File system has been set read-only

Could this be a problem with the disk, Mandriva or something else? It works on Mandrake 10.0.

Thanks

Neranjana

neranjana 11-23-2005 05:25 AM

Another thing, the size of the disk is 60 GB and there is only one partition. Windows can't even format this partition because windows does not support FAT partitions larger than 40 GB. I used Mandrake 10.0 to format this. Could it be that Mandriva also does not support FAT partitions larger than 40GB now? It did in previous versions.

Thanks

Neranjana

sam.pedraglio 11-24-2005 03:48 AM

I'm using a big external HD too (2 partitions of 60GB once) but, unfortunately I'm not able to check it within 2-3days, my laptop is under doctor attentions.
I'll check it when I'll have it back.
Sorry.


All times are GMT -5. The time now is 09:40 PM.