LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 05-19-2007, 06:33 PM   #1
rob2006
LQ Newbie
 
Registered: Jul 2006
Distribution: mandriva 2007 spring version
Posts: 16

Rep: Reputation: 0
USB device not mounted


Hello need help and advice on how to fix usb key drive not mounted
I get this error message


"Unable to mount the selected volume.:
mount: can't find /dev/sda1 in /etc/fstab or /etc/mtab"

Could you please steer me in the right direction to fix this fault

cheers rob2006
 
Old 05-19-2007, 07:46 PM   #2
arckane
Member
 
Registered: Sep 2005
Location: UK
Distribution: Gentoo/Debian/Ubuntu
Posts: 306

Rep: Reputation: 38
You need to add a mount point (/mnt/usbkey for example) in to /etc/fstab. My USB mount point is:

/dev/sdb1 /mnt/usb auto defaults 0 0
 
Old 05-20-2007, 04:02 PM   #3
jkerr82508
Member
 
Registered: Dec 2006
Location: Fife, Scotland
Posts: 249

Rep: Reputation: 66
In my experience, certainly with 2007.0 and 2007.1, you don't need an entry in fstab. Just plug in the drive and click on the desktop "Devices" icon (or maybe the default name is "Media"). After a short delay the key drive will be shown. Click on the icon and the drive is mounted (probably as /media/removable) and opened in konqueror. Before removing the drive, it's a good idea to unmount it by right-clicking on its icon and selecting "Safely remove".

Jim
 
Old 05-20-2007, 04:58 PM   #4
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
rob2006, where are you receiving this error?

As mentioned, Mandriva should auto/super-mount the device for you, no need to mess with fstab unlike maybe in arckane's Gentoo distro choice.

Try using KDE's Konqueror file browser to view system:/media or media:/
 
Old 05-25-2007, 07:12 AM   #5
DiBosco
Member
 
Registered: Nov 2001
Location: Manchester, UK
Distribution: Mandriva, Mandriva, Mandriva. (Three different releases depending on the computer)
Posts: 710

Rep: Reputation: 35
Actually, I have this problem on 2007.1. It was working fine on 2007.0, but now - after an upgrade to 2007.1 - I have to manually mount each time. I've even tried putting an entry in fstab to no avail (it just gives me bad block errors). I do think there's something odd going on with 2007.1.
 
Old 05-25-2007, 02:25 PM   #6
jkerr82508
Member
 
Registered: Dec 2006
Location: Fife, Scotland
Posts: 249

Rep: Reputation: 66
Make sure you're running the latest kernel. There was an update which resolved a number of usb related problems.

Jim
 
Old 05-25-2007, 02:57 PM   #7
DiBosco
Member
 
Registered: Nov 2001
Location: Manchester, UK
Distribution: Mandriva, Mandriva, Mandriva. (Three different releases depending on the computer)
Posts: 710

Rep: Reputation: 35
It's the same Kernel as I was running on 2007.0 though...
 
Old 05-26-2007, 12:18 AM   #8
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
Flash drives work fine here with MDK 2007.1 (Spring) running kernel-2.6.17-14mdv (I just tested). I'd suggest you make sure your system is completely updated (there have been quite a few patches in recent weeks) and try the current kernel.

For any one who may be interested, the Mandriva Online Update tool no longer requires a Club membership. It checks the Updates repository I configured my system to use periodically and if there are any updates, the icon turns red with a '!'. I click the icon and Mandriva Update is started.

HTH,
 
Old 05-26-2007, 02:20 AM   #9
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You might try using fsck to check if the filesystem on the pendrive is OK. If it was unplugged before the cache was written, it may be damaged.

Some things to try:
restart the dbus daemon
restart the hal daemon

Umount any usb drives and then unload & reload the ehci_hcd or uhci_hcd kernel modules.

Monitor the kernel messages when inserting the pen drive:
sudo tail -f /var/log/messages
This may alert you to problems.

Examine the udev info.
udevinfo -n env -n /dev/sda1
This will tell you things like the filesystem, the label and the UUID of the filesystem.
For example:
Code:
:~> sudo tail -f /var/log/messages
root's password:
May 26 01:50:45 hpamd64 sudo: jschiwal : TTY=pts/2 ; PWD=/home/jschiwal ; USER=root ; COMMAND=/usr/bin/tail -f /var/log/messages
May 26 01:50:52 hpamd64 kernel: usb 3-1: new high speed USB device using ehci_hcd and address 5
May 26 01:50:52 hpamd64 kernel: usb 3-1: new device found, idVendor=0781, idProduct=5150
May 26 01:50:52 hpamd64 kernel: usb 3-1: new device strings: Mfr=1, Product=2, SerialNumber=3
May 26 01:50:52 hpamd64 kernel: usb 3-1: Product: Cruzer Mini
May 26 01:50:52 hpamd64 kernel: usb 3-1: Manufacturer: SanDisk Corporation
M
...

May 26 01:50:53 hpamd64 kernel: sdc: assuming drive cache: write through
May 26 01:50:53 hpamd64 kernel:  sdc: sdc1
May 26 01:50:53 hpamd64 kernel: sd 4:0:0:0: Attached scsi removable disk sdc
Now I know the device node for the partition is /dev/sdc1.
Code:
~> udevinfo -q env -n /dev/sdc1
ID_VENDOR=SanDisk
ID_MODEL=Cruzer_Mini
ID_REVISION=0.1
ID_SERIAL=SanDisk_Cruzer_Mini_SNDK4F87642EAA601103
ID_TYPE=disk
ID_BUS=usb
ID_PATH=pci-0000:00:02.2-usb-0:1:1.0-scsi-0:0:0:0
ID_FS_USAGE=filesystem
ID_FS_TYPE=vfat
ID_FS_VERSION=FAT16
ID_FS_UUID=3B69-1AFD
ID_FS_LABEL=CRUZER512
ID_FS_LABEL_SAFE=CRUZER512
It would be better using LABEL=CRUZER512 or UUID=3B69-1AFD as the device in the /etc/fstab entry. This would allow me to mount the device even if it is assigned to a different device node, such as /dev/sdb1.
If I wanted to manually mount it,
Code:
LABEL=CRUZER512 /media/CRUZER512 vfat noatime,noauto,users,gid=users,fmask=0113,dmask=0002,utf8=true 

or
LABEL=CRUZER512   /media/CRUZER512 vfat noatime,noauto,user,uid=1000,gid=users,fmask=0137,dmask=0027,utf8=true
The first fstab entry example allows any normal user to enter "mount /media/CRUZER512" to mount it. It isn't necessary to use sudo.

The second example gives me exclusive write access to the device when mounted. And only root and myself can mount it on this system.

Last edited by jschiwal; 05-26-2007 at 02:23 AM.
 
Old 06-12-2007, 08:59 AM   #10
DiBosco
Member
 
Registered: Nov 2001
Location: Manchester, UK
Distribution: Mandriva, Mandriva, Mandriva. (Three different releases depending on the computer)
Posts: 710

Rep: Reputation: 35
Finally got some time to look at this again...

If I plug in my Palm in Lifedrive mode (so that it looks like a USB drive) with its SD card in I get this:

[root@HP510 robertw]# udevinfo -q env -n /dev/sdb1
ID_VENDOR=Unknown
ID_MODEL=palmOne_Handheld
ID_REVISION=1.0
ID_SERIAL=Unknown_palmOne_Handheld_PVG0M895V1BU
ID_TYPE=disk
ID_BUS=usb
ID_PATH=pci-0000:00:1d.7-usb-0:1:1.0-scsi-0:0:0:1
ID_FS_USAGE=filesystem
ID_FS_TYPE=vfat
ID_FS_VERSION=FAT16
ID_FS_UUID=918B-52C9
ID_FS_LABEL=
ID_FS_LABEL_SAFE=
[root@HP510 robertw]#

This make Konqueror bring up a window but gives me bad block errors and tells me to do just what you suggested:

[root@HP510 robertw]# tail -f /var/log/messages
Jun 12 14:45:16 HP510 kernel: sdb: Write Protect is off
Jun 12 14:45:16 HP510 kernel: sdb: assuming drive cache: write through
Jun 12 14:45:16 HP510 kernel: SCSI device sdb: 3935232 512-byte hdwr sectors (2015 MB)
Jun 12 14:45:16 HP510 kernel: sdb: Write Protect is off
Jun 12 14:45:16 HP510 kernel: sdb: assuming drive cache: write through
Jun 12 14:45:16 HP510 kernel: sdb: sdb1
Jun 12 14:45:16 HP510 kernel: sd 0:0:0:1: Attached scsi removable disk sdb
Jun 12 14:45:17 HP510 kernel: sd 0:0:0:0: Attached scsi generic sg0 type 0
Jun 12 14:45:17 HP510 kernel: sd 0:0:0:1: Attached scsi generic sg1 type 0
Jun 12 14:45:24 HP510 kernel: FAT: Unrecognized mount option "mask=0" or missing value


If I plug it in without its SD card (it still has a 4GB HDD on board) I get this:

[root@HP510 robertw]# udevinfo -q env -n /dev/sda1
ID_VENDOR=palmOne,
ID_MODEL=File_storage
ID_REVISION=1.0
ID_SERIAL=palmOne,_File_storage_PVG0M895V1BU
ID_TYPE=disk
ID_BUS=usb
ID_PATH=pci-0000:00:1d.7-usb-0:1:1.0-scsi-0:0:0:0
[root@HP510 robertw]#


I can manually mount both SD card and the Lifedrive HDD just fine. Would be nice for it to happen automatically though.

Cheers!
 
  


Reply

Tags
mount, usb boot


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB drive not working properly, read only device? (USB key storage device) Arodef Linux - Hardware 14 01-01-2010 07:32 AM
USB storage device mounted and regonized in Suse but files not recognized Sarge. tuffstuff Linux - Newbie 6 02-11-2007 11:19 PM
How to force kernel to use a USB 2.0-compatible device (ehci_hcd) as a USB 1.1 device eze Linux - Hardware 0 05-16-2006 05:24 AM
usb device no longer auto mounted by kde popup oily_rags Suse/Novell 5 03-24-2006 06:38 AM
Mounted Device names Rodzilla Linux - Newbie 7 09-25-2003 10:39 AM


All times are GMT -5. The time now is 10:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration