LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 01-07-2006, 05:39 AM   #1
Bengan
Member
 
Registered: Dec 2005
Location: Sweden
Distribution: Mandriva 2006
Posts: 30
Blog Entries: 3

Rep: Reputation: 15
Upgrade of KDE 3.4 to 3.5 failed - startkde problem


Running Mandriva 2006, I set urpmi.addmedia to SoS to upgrade my KDE 2.4 to 3.5. I read somewhere that I would not have to de-install the old version, so I used the RPM manager to install the package from SoS. I rebooted the system. I got as far as to the login stage, but not further. It kept asking for my name and password. I rebooted into the failsafe mode and logged in as root. I ran "startkde" and got the following complaints:

"
75 kstartupconfig command not found
77 xmessage command not found
79 /root/kde/share/config/startupconfig: no such file or directory
"

In the /usr/bin/startupkde file it says on lines 75 - 81:

"
75 kstartupconfig
76 if test $? -ne 0; then
77 xmessage -geometry 500x100 "Could not start kstartupconfig. Check your installation."
78 fi
79 .$kdehome/share/config/startupconfig
80
81 # XCursor mouse theme needs to be applied here to work even for kded or ksmserver
"

How do I get access to any of the KDE installations? I do not know if I have still got the 3.4 files.
 
Old 01-07-2006, 06:32 AM   #2
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Smile I followed this path.

I did read this here somewhere earlier today....(Search for my username and kde 3.5)

and used urpmi to get the rest of the files, there was quite a few of them. Took a couple of hours.

But after, urpmi kdebase,
urpmi kdeutils kdeaddons
urpmi kdebase-kdm-config-file (already installed)
urpmi kdm

I did, urpmi --auto-select

Which had heaps of other files from sos as well.

The system is running fine at the moment, even though one of the update sites was unraechable, I'll get them later.

Looks good, no real problems, so far.

Good luck!
 
Old 01-07-2006, 11:36 AM   #3
Bengan
Member
 
Registered: Dec 2005
Location: Sweden
Distribution: Mandriva 2006
Posts: 30
Blog Entries: 3

Original Poster
Rep: Reputation: 15
Where did you get your files from? I used SoS, but, apparently, there were dependencies missing. I am now left with Gnome at the moment.
 
Old 01-07-2006, 05:09 PM   #4
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
google easy-urpmi for config. pages.

Follow the directions there and make sure you have marked sites for updates & main to fix up the dependencies.

in the console type urpmi --auto-select

Last edited by GlennsPref; 01-07-2006 at 05:12 PM.
 
Old 01-09-2006, 03:54 AM   #5
Bengan
Member
 
Registered: Dec 2005
Location: Sweden
Distribution: Mandriva 2006
Posts: 30
Blog Entries: 3

Original Poster
Rep: Reputation: 15
Okay, thanks. I did in the end manage to install 3.5, but it seemed buggy to me, so I went back to old 3.4, shich is on my installation CDs. However, I'd like to upgrade kmail. Any hints?
 
Old 01-09-2006, 04:34 AM   #6
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
I agree, I'm getting core dumps and newb stuff(info panels) I can't turn off, yet!

Firewall is not loading correctly either, but I'm not sure if that has anything to do with kde.

Thank you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE fedora - login defaults to startx and not startkde Riddick Fedora 5 04-30-2005 12:55 PM
path problem - startkde :command not found batfastad Linux - Newbie 7 11-18-2004 07:12 PM
Failed Dependency: KDE 3.2.3 Upgrade MatthewASmith79 Linux - Newbie 1 06-13-2004 08:15 PM
NIS startkde problem microsmart Fedora 1 05-09-2004 06:39 AM
kde upgrade problem bramba Linux - Software 0 04-22-2004 01:15 AM


All times are GMT -5. The time now is 12:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration