LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 10-23-2006, 06:07 AM   #1
gaaln
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Rep: Reputation: 0
unable to uninstall java


hi,

i have some problems with java and i'm trying to reinstall it but i don't manage to uninstall it first (i already noticed some problems with the classpath, but i'm not very aware..)
got the following error:

> urpme java-1.4.2-gcj-compat

[.....]
/var/tmp/rpm-tmp.74666: line 1: /usr/bin/rebuild-gcj-db: Aucun fichier ou répertoire de ce type
error: %postun(ant-jsch-1.6.5-7mdk.i586) scriptlet failed, exit status 127
/var/tmp/rpm-tmp.74666: line 13: /usr/bin/rebuild-security-providers: Aucun fichier ou répertoire de ce type
error: %postun(java-1.4.2-gcj-compat-1.4.2.0-40.16mdk.i586) scriptlet failed, exit status 127

any help ?

thank's :-)
 
Old 10-23-2006, 06:10 AM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try using
Code:
#rpm -e --noscripts java-1.4.2-gcj-compat
It seems like one of the deinstallation scripts is not running properly.
 
Old 10-23-2006, 06:34 AM   #3
gaaln
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Original Poster
Rep: Reputation: 0
ok, thanks

i uninstalled by hand almost all the dependencies but on the latest packages it seems to be cross dependencies (??)

> rpm -e --noscripts java-1.4.2-gcj-compat

erreur: Dépendances requises:
java >= 0:1.4 est nécessaire pour (déjà installé) jessie-1.0.0-6mdk.noarch
java-gcj-compat >= 0:1.0.33 est nécessaire pour (déjà installé) eclipse-ecj-3.1.0-8mdk.i586


and:

> rpm -e --noscripts eclipse-ecj

erreur: Dépendances requises:
ecj est nécessaire pour (déjà installé) java-1.4.2-gcj-compat-1.4.2.0-40.16mdk.i586
 
Old 10-23-2006, 10:41 AM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try,
Code:
#rpm -e --nodeps jessie eclipse-ecj
#rpm -e --noscripts java-1.4.2-gcj-compat
 
Old 10-24-2006, 05:01 AM   #5
gaaln
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Original Poster
Rep: Reputation: 0
that's what i did, indeed.. thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to UNinstall Antivir, SUSE 9.2 Mic Q Suse/Novell 2 05-16-2006 02:25 AM
Unable to uninstall and reinstall RPM jarkvarma Linux - Newbie 3 02-17-2005 06:42 PM
java uninstall twcinpa Linux - General 9 12-19-2003 02:20 PM
cannot uninstall java bnujos Linux - General 3 06-25-2003 11:36 AM
Unable to uninstall proftpd Rodcl Linux - Software 1 08-31-2002 03:20 AM


All times are GMT -5. The time now is 10:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration