LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-02-2004, 04:34 AM   #1
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian sid, aptosid, Linux Mint, MacOS X
Posts: 847

Rep: Reputation: 30
Unable to get full internet access : only Google works !!


Hi everyone,

I've got Mandrake 10.0 OE on an Asus pc with 512Mo ddr.
It's a Linux only box. I've also got a Dell running on winXP.
Both machines are linked to the net through an Olitec SX 500 adsl Modem router.
Well, everything is fine for the Dell, but, though I can connect with the Asus -eth0 is ok at boot-, all I can get to work is Google; I can't reach other sites..
Ok, it seems I've got a DNS problem but how to get it solved?
I got a message from another forum telling me I have to put the IP addresses of the DNS servers in the proper resolveconf file.
Er, how to do that please ?? Can any one feels like helping me in that ?
Any idea would be appreciated. Thanks
 
Old 10-02-2004, 04:58 AM   #2
Boby
Member
 
Registered: Feb 2004
Location: Sighisoara/Cluj-Napoca (Romania)
Distribution: CentOS 4, Fedora Core 6
Posts: 781

Rep: Reputation: 31
You can check the nameserver by typing this:
Code:
host ns1.yourISP.com
host ns2.yourISP.com
I have entered and received this to check my nameservers [rdsnet.ro is my ISP]:

Code:
[boby@localhost boby]$ host ns1.rdsnet.ro
ns1.rdsnet.ro has address 193.231.236.17
[boby@localhost boby]$ host ns2.rdsnet.ro
ns2.rdsnet.ro has address 193.231.236.10
Then enter this in /etc/resolv.conf but change the IP's to whatever your's are:
Code:
nameserver 193.231.236.17
nameserver 193.231.236.10
Good luck!
Boby

Last edited by Boby; 10-02-2004 at 06:59 AM.
 
Old 10-02-2004, 06:32 AM   #3
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian sid, aptosid, Linux Mint, MacOS X
Posts: 847

Original Poster
Rep: Reputation: 30
Thanks very much , Boby !
Unfortunately, this has not worked much.
I couldn't get the IP for the nameserver 1 or 2 of my ISP (aol.com, i.e.), just that which seems strange : 127.0.0.1.
There was an IP, anyway, which is one provided by my router, so I swapped it with the 127etc.., but to no avail.
Perhaps I should change the ISP ?
If you've got another idea ?..
 
Old 10-03-2004, 06:54 AM   #4
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
DNS

Quote:
Originally posted by samael26
Thanks very much , Boby !
Unfortunately, this has not worked much.
I couldn't get the IP for the nameserver 1 or 2 of my ISP (aol.com, i.e.), just that which seems strange : 127.0.0.1.
There was an IP, anyway, which is one provided by my router, so I swapped it with the 127etc.., but to no avail.
Perhaps I should change the ISP ?
If you've got another idea ?..

cat /etc/resolv.conf

for a good clue as to what may be happening.
 
Old 10-03-2004, 12:01 PM   #5
nafan
Member
 
Registered: May 2004
Location: /dev/bed
Distribution: Mandriva 2009.0 Powerpack
Posts: 172

Rep: Reputation: 30
Does your router box provide a dhcp service for your network? If it does then your Windows machine is getting it's network information from the router regarding what dns servers to use, or your router is forwarding requests to your isp's dns servers. If you can, use the mandrake control centre to change the network connection so that it uses DHCP to get it's ip address instead of being assigned manually.

When you reboot or restart the network service your pc should ask the router what ip address and what dns servers it should use.
 
Old 10-03-2004, 04:19 PM   #6
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian sid, aptosid, Linux Mint, MacOS X
Posts: 847

Original Poster
Rep: Reputation: 30
Hi,
Thanks for taking interest in my problem.
I have tried this several times but to no avail..
I really wonder whether it's a problem of configuration, of kernel, of the router itself(though it works well with Windows), or of ISP.
I must say I'm quite lost.
Thanks anyway..
 
Old 10-03-2004, 11:12 PM   #7
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Quote:
Originally posted by samael26
Hi,
Thanks for taking interest in my problem.
I have tried this several times but to no avail..
I really wonder whether it's a problem of configuration, of kernel, of the router itself(though it works well with Windows), or of ISP.
I must say I'm quite lost.
Thanks anyway..
Again

cat /etc/resolv.conf

This you a REAL clue as to what is happening.

I'll bet that the resolver is not getting pointed to a valid DNS.

This may be due to (as the previous poster alluded to) bad settings or no DHCP information arriving to the system.

Also post the output of

ifconfig

and

route -n
 
Old 10-04-2004, 06:25 AM   #8
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian sid, aptosid, Linux Mint, MacOS X
Posts: 847

Original Poster
Rep: Reputation: 30
Hi opjose,

Here are the results of my searches :

1. cat/etc/resolv.conf gives

nameserver 192.168.0.250 (IP address of the router)

2. ifconfig gives

eth0 Lien encap : Ethernet HWaddr 00:0e:A6:AB:3F:B8
UP BROADCAST MULTICAST MTU:1500 Metric : 1
RX packets : 0 errors : 0 dropped : 0 overruns : 0 Frame : 0
TX packets :0 errors :0 dropped :0 overruns :0 carrier :0
collisions :0 lg file transmission : 1000
RX bytes :0 (0.0 b) TW bytes :0 (0.0 b)
Interruption : 18 Adresse de base :0xec00


lo Lien encap : Boucle locale
Inet add : 127.0.0.1 Masque : 255.0.0.0
UP LOOPBACK RUNNING MTU: 16436 Metric:1
RX packets : 1958 errors:0 dropped :0 overruns:0 frame:0
TX packets : 1958 errors:0 dropped :0 overruns:0 carrier:0
collisions : 0 lg file transmission : 0
RX bytes : 236304 (230.7 kb) TX bytes : 236304 (230.7 kb)

3. route -n gives : nothing at all just :
Destination Gateway Genmask .... with no indication whatsoever below.

If I enter netstat : I get "connected" on each line..

Hope you could try to figure out a solution.. Thanks again
 
Old 10-04-2004, 07:30 AM   #9
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Yup, your network interface is not "UP" nor has it queried the DHCP server.

try


ifup eth0

at the prompt and then run the same commands again.

-JMS
 
Old 10-04-2004, 12:25 PM   #10
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian sid, aptosid, Linux Mint, MacOS X
Posts: 847

Original Poster
Rep: Reputation: 30
Thanks a lot,

It didn't work, though. I already tried this command a few days ago.
For the moment I' stay stuck with Google and that's all..

THanks for your answers anyway.
 
Old 10-04-2004, 06:54 PM   #11
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
The google response might be cached locally as your TCP/IP configuration is not functional.

That is your interface is still "down" for all intents and purposes.

Try setting up the IP addresses manually and then after you've done this post the output of ipconfig.
 
Old 10-05-2004, 01:40 PM   #12
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian sid, aptosid, Linux Mint, MacOS X
Posts: 847

Original Poster
Rep: Reputation: 30
I can't set up the IP addresses 'manually' because my ISP only provides DHCP, so each connexion sees a new address on which I can't have any action...
Thanks anyway
 
Old 10-05-2004, 06:04 PM   #13
craigvanham
LQ Newbie
 
Registered: Mar 2004
Location: Saskatchewan
Posts: 10

Rep: Reputation: 0
If your behind a router you can still set your ip manually and not be affected by isp dhcp server. Like the relpy in the last post your interface device is still down.

Steps
1. set your IP address manually (in the same range as your router) in the ifcfg-eth0 in /etc/sysconfig/network-scripts
gateway - being your router
nameservers - you can use any nameserver on the net. ( if you want use 142.165.21.5, and 142.165.5.2)
2. see if you can ping your router
3. post the results
 
Old 10-06-2004, 02:20 AM   #14
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Ah, the magic point of information!

So your ISP serves up IP's via DHCP.

What is probably happening is that your machine is getting allocated an IP either by MACHINE NAME or that the cable modem does not recognize the request from Linux since it's previously already doled out an IP address to a prior install or to Windows.

Do this.

1) Make sure that the interface connected to the cable modem is set up to get it's address via DHCP.

2) Shut down Linux. REMOVE the power cord from your computer and press the power button with it disconnected to remove any residual current on capacitors.

3) TURN OFF your cable/dsl modem and also remove power for at least 1 minute.

4) Make sure that your cable modem is connected directly to your Linux boxes ethernet port correctly.

5) Turn on your cable modem and permit it to stabilize.

6) Once the modem is done with it's girations, bring up Linux directly. Don't start Windows, etc.

Then once it's up run IPCONFIG again and see if you've obtained a new IP.

IF NOT, again cycle the cable modem, this time with the Linux box up.

Then type

service network restart

and run IPCONFIG again to see if you've received an IP.

If it still fails, you may need to name your Linux box EXACTLY the same way as it was or might have been named previously under Windows, etc.

Some ISP's only dole out IP's to machines with recorded or specific names.
 
Old 10-06-2004, 10:38 AM   #15
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian sid, aptosid, Linux Mint, MacOS X
Posts: 847

Original Poster
Rep: Reputation: 30
Hi,

Thanks for your advice.
first :
I know it's really a problem of eth 0 configuration because when I look at the advanced settings in my router, the tests show that everything is OK, EXCEPT the test on pppoE, so I can only get a connexion by pppoALLC (don't know what that means exactly..)
Every other kind of connexion available fails.

Second :
I know I've got DHCP because each time I tried a new way of connexion, the address changed when I got back to pppoAsomething.
Strangely enough at each boot, the eth 0 reports OK, so there must be some kind of code to add or something having to be set on "1" instead of "0", perhaps. Problem is in what file ?

third :
I don't have dual boot but two boxes : one Windows-only and the other Linux-only. Erm, I don't know what name has been given to my Windows machine and don't know where to find such a name..
I'll try to have a look in this ifconfig eth0, as craigvanham suggested..
This really begins to get on my nerves..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Granting users full internet access!? adham1sa Linux - Networking 3 12-22-2004 06:08 AM
Unable to access internet TBomb Linux - Networking 4 08-11-2004 10:29 AM
Unable to Access the Internet - not sure why zensufi Linux - Hardware 9 07-20-2004 06:14 PM
Unable to access my ssh server and ftp server from the Internet, but smtp works foxone Linux - Networking 1 05-28-2004 05:17 PM
eth0 works but not with google.com and web server is slow to access ecarlsonlinux Linux - Networking 8 03-04-2004 03:27 PM


All times are GMT -5. The time now is 10:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration