LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 05-28-2005, 04:45 PM   #1
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Rep: Reputation: 30
turn off doesn't really turn and power off


Hello?

I'm using PowerPack 10.1. When I do system "turn off",
this doesn't really turn my system off and power off as
in other distros.

The only options given to me are "reboot" and "halt".

If I, then, do "halt", the very last message I see during
this "halting" is "power down". But again, this doesn't
really turn and power off my system.

So, how can I actually "turn and power off" my system
in PowerPack 10.1?

Thanks.
 
Old 05-28-2005, 05:10 PM   #2
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
press the power button

Probably some problesm with APM or ACPI (the power managment systems). Find out which you have and recompile the kernel accordingly.

Or press the power button at the end.
 
Old 05-28-2005, 05:11 PM   #3
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian
Posts: 848

Rep: Reputation: 30
Hi,
acpi is not enabled, that's why you can't power off for good.
Go into MCC--> System --> Boot parameters (I think, in English) --> tick the acpi box (first option I think)
Then , just shutdown, this time it will power off totally.

cheers

no need to recompile, as previous poster said
 
Old 05-28-2005, 10:08 PM   #4
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi marghorp and samael26,

Thanks for your interests. Because the turn off actually
doesn't power off, I actually use the power button on
the system to completely power off.

samael26, I turned on the acpi option (MCC, Boot, Boot
parameters), but this has no effect.

Since this isn't that much of an issue, I'll just manually
power off the system. But, I'll appreciate if someone
has any idea on this without actually recompiling.

Thanks.
 
Old 05-29-2005, 02:17 AM   #5
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian
Posts: 848

Rep: Reputation: 30
Hi,
Check into your BIOS whether it supports ACPI or not. This may just be the issue here.
In case the option is not enabled, just do it. Turning manually off is going to get on
your nerves pretty fast..
 
Old 05-29-2005, 05:56 AM   #6
floppywhopper
Member
 
Registered: Aug 2004
Location: Albany, Western Australia
Distribution: Mageia 2, SME Server 8
Posts: 617
Blog Entries: 2

Rep: Reputation: 54
What kind of mobo are you running on

floppy
 
Old 05-29-2005, 02:19 PM   #7
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi samael26 and floppywhopper,

Thanks for your consistent interests in this issue.

Looking at the POST messages, the system BIOS
says it's ACPI compliant BIOS.

And, I'm running Celeron 1.7GHz on Asrock P4AL-800.

Regards,
 
Old 05-29-2005, 02:55 PM   #8
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian
Posts: 848

Rep: Reputation: 30
Okay, but did you go into the BIOS to change your settings if necessary
i.e. enable ACPI, If it isn't ? When you boot , depending on your configuration,
you should be able to enter into BIOS setup by hitting one of the F keys (F2 on
my computer).

Hope that helps
cheers
 
Old 05-29-2005, 03:27 PM   #9
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi samael26,

Thanks again for your help.

I looked every "corners" in the CMOS settings, but
there was no place where I explicitly enable/disable
the ACPI setting.

I believe this ACPI compliancy is automatically detected
by the system BIOS during boot.

My BIOS is very first version for the board's model, and
I'll look the manufacturer's website if they have recent
BIOS available. Perhaps, the later BIOS might have
an option to enable/disable the ACPI setting among
others explicitly.

Regards,
 
Old 05-29-2005, 05:30 PM   #10
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi samael26,

Well, I ended up updating the BIOS even though
SuSE 9.3 Pro and FC3 were properly turning off
and powering off the system but Mandrake PowerPack 10.1.

This didn't help either. I could be wrong, but I think
this is just Mandrake PowerPack thing.

If anyone's familiar on powering off completely
when turning off system on Mandrake PowerPack 10.1,
I'll appreciate their sharing info with me.

Thanks.
 
Old 05-30-2005, 02:49 AM   #11
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 46
you have to make sure that apm is on

type lsmod to see if its loaded or not

if its not then type modprobe apm then try now to shutdown

to make it permanent then in mandrake control center just choose it and choose 'on boot'
 
Old 05-30-2005, 03:22 PM   #12
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi heema,

Thanks for your insight.

Well, I just found out that the "apmd", "acpi" and
"acpid" modules weren't installed. And, I had "acpi=ht"
boot option all along.

But enabling the "ACPI" option at the Control Center>
Boot>Boot Parameters didn't bring up any issue of missing
the ACPI modules thus far. Strange.

Anyway, I installed the above modules and left the "acpi=ht"
boot option out. Now, the power off works normally.

However, the overall boot process and the responsive
time are comparably and terrbly much, much slower than
with the "acpi=ht" boot option present.

Also, I'm getting "shell session exited with status 1"
message whenever I tried to exit the console window from
the "su" mode after having executed "modprobe" command.

Why? I don't know.

Now, I guess I could just manually power off the system
and keep the "acpi=ht" boot option for normal system
performance. But, it would be nice if there's a way
to automatically power off the system when selecting
the turn off system option and have the usual system
performance as well.

Regards,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Wont turn off automatically marigb Linux - Hardware 5 11-16-2005 08:08 PM
How to turn off Xserver in the gui and turn it off in the command line geminiviper Linux - Newbie 8 08-20-2004 08:05 AM
Can not turn off power with Slackware 10 caovankhanhvn Linux - Laptop and Netbook 6 08-13-2004 07:49 PM
Mandrake 9.2 does not turn off power at shutdown dancro Mandriva 12 03-19-2004 06:41 AM
Turn on power through network? trees Linux - Networking 6 01-21-2004 01:25 AM


All times are GMT -5. The time now is 08:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration