LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 01-24-2004, 05:18 AM   #1
bibilit
Member
 
Registered: Nov 2002
Location: Montrouge / FRANCE
Distribution: MANDRAKE 9.2/ DSL / smalllinux / Ubuntu 5.1
Posts: 202

Rep: Reputation: 30
trying to fix sound onboard system


Hi,

Still have not found any solution to my sound problem !!

The onboard via 8233 a sound system is mute except for cd ( i can have sound from kscd ) the bell is ok too, but anything else is not.

Alsa came with mdk 9.2 and i changed modules to match my soundcard requirements ( via82xx ).

Soundcard is detected, i have no strange messages and i even have a loud sound from the speackers at boot.

Every mixer is 100 %.

I chmod /dev/dsp .... and add myself to the audio group.

I use Kde and disabled arts ,as this one was not happy and send me error messages.

I cannot play any wav sound with Totem or Xmms ( and yes, files are associated !! )

Can anybody with the same problem ( if somebody solved the problem it will be great !! ) give me a reply.
 
Old 01-26-2004, 08:57 AM   #2
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
One thing comes to mind:

XMMS or Totem may still be trying to output sound to arts, which you've disabled. Check the output preferences for them, and change them to OSS/ALSA (whichever you're using).

Might help.... might have already done that...

Are you getting any error messages at all? Check dmesg?

--Rounan
 
Old 01-29-2004, 01:56 AM   #3
bibilit
Member
 
Registered: Nov 2002
Location: Montrouge / FRANCE
Distribution: MANDRAKE 9.2/ DSL / smalllinux / Ubuntu 5.1
Posts: 202

Original Poster
Rep: Reputation: 30
Thanks Rounan for the reply,

I only have OSS as output, cannot select anything else !!

I suppose Alsa can emulate Oss, so i also suppose sound should be there... but maybe i'm wrong.

No strange messages dmesg ok too.
 
Old 01-29-2004, 09:03 AM   #4
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
Check mixer channels, make sure they're not muted?
Sorry man, I'm at a loss. If there aren't any error messages, outputs are OK, and still no sound.... no idea.
 
Old 01-31-2004, 10:03 AM   #5
bibilit
Member
 
Registered: Nov 2002
Location: Montrouge / FRANCE
Distribution: MANDRAKE 9.2/ DSL / smalllinux / Ubuntu 5.1
Posts: 202

Original Poster
Rep: Reputation: 30
Thanks Rounan for your reply,

Taking the problem back to the root, i discovered a problem.

Alsa ask to chmod /dev/dsp /dev/mixer ... etc

I discovered that those were only links to /dev/sound/dsp ... /dev/sound/mixer and so on !!!


So i tried to chmod the above to 777 to be sure, the thing works but if i log in and out... things get back to the previous information!!!

Can i store chmod information and how ?? ( i use Mdk 9.2 and i used mdk control panel to change things but i discovered this was not changing much ). I have used command line to chmod with the above result.

Also do you know if i should change group ( from users to audio maybe ?? )

Thanks
 
Old 01-31-2004, 10:07 AM   #6
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
Yeah, something must be resetting permissions at reboot, likely an alsa script.

The permissions should be rw for group audio, though, so if you do:
adduser (you) audio

it should give you access all the time.

And to clarify: you're not "changing" group - one user can be a member of multiple permission groups at the same time. you're just adding yourself to the audio group as well.

--Rounan
 
Old 02-01-2004, 05:30 AM   #7
bibilit
Member
 
Registered: Nov 2002
Location: Montrouge / FRANCE
Distribution: MANDRAKE 9.2/ DSL / smalllinux / Ubuntu 5.1
Posts: 202

Original Poster
Rep: Reputation: 30
thanks again for all the information.

I know about permissions, the only think is not clear enough is :

If i use" ls" command for /dev/sound/dsp i have the following information ( more or less )

crw------- 1 myself audio ...

The thing is ... should i change audio to users, or keep it as it is?

Any idea where that script can be ( i have had a look but cannot find it )

Also, even when chmoding the sound was not there anyway ( the idea is should i have permissions right away after chmoding, or after a log in/ log out ? in that case as permissions are back to rw only for owner i cannot have sound anyway ? )

Thanks again
 
Old 02-01-2004, 06:23 AM   #8
sharkee
Member
 
Registered: Jul 2003
Location: Australia
Distribution: Kubuntu 5.10 Ubuntu Dapper
Posts: 220

Rep: Reputation: 30
You may be able to keep your settings by doing the chmod in etc/rcd/rclocal .this may run the chmod script after everything else initialises . Ihave not tried this with chmod but it works for my joystick . best of luck

Regards sharkee
 
Old 02-01-2004, 11:30 AM   #9
bibilit
Member
 
Registered: Nov 2002
Location: Montrouge / FRANCE
Distribution: MANDRAKE 9.2/ DSL / smalllinux / Ubuntu 5.1
Posts: 202

Original Poster
Rep: Reputation: 30
Thanks both of you !

i changed modules and now everything works ( don't ask how i did it )
 
Old 02-07-2004, 07:47 AM   #10
bravofoxtrotuk
LQ Newbie
 
Registered: Feb 2004
Location: Leeds, UK
Distribution: Mandrake 9.2
Posts: 1

Rep: Reputation: 0
Hi,

I'm a complete newbie (Linux installed a week ago), and had exactly the same problem with my system which is VIA8233. I had CD playing, and the line input worked. All inputs were set to max and un-muted.

As the CD, line, and speakers worked, I figured that this meant the sound card and its driver were sort of OK, but it wouldn't play anything from xmms, and although I had enabled all sounds, they didn't work either.

I tried playing a wav file in xmms (I used startup.wav) and set it to 'repeat'. At first it wouldn't even play the file until I fiddled about with the device it used which was 'PCM'. Then it was playing but still no output. I then realised that in my troubleshooting I now had 3 mixers installed - alsamix, aumix, and KMix. As I am using KDE I decided to keep KMix and get rid of the other 2. After a restart (sorry - old Windoze habits die hard), it all came up and worked OK. Arts still seems to be starting and is also OK.

I didn't need to fiddle with any permissions etc, and don't understand what went on yet, but I'm still learning!

Hope this may help others.
 
Old 03-03-2004, 04:47 AM   #11
svalovic
Member
 
Registered: Mar 2004
Location: Slovakia
Distribution: debian lenny, squeeze, Ubuntu Netbook Remix, Puppy
Posts: 32

Rep: Reputation: 16
hello, I have the same problem with via8233, I'm not a total newbie, but I have never configured a sound card, so it is a problem for me.

Bravofoxtoruk, I will try your advise. What do you mean with the PCM device? What should I set there?

bibilit, how did you changed the modules?

Is there some generous way how to configure via8233 sound codecs? Does someone in Mandrake team know about this problem?

Thanks
 
Old 03-09-2004, 03:40 AM   #12
bibilit
Member
 
Registered: Nov 2002
Location: Montrouge / FRANCE
Distribution: MANDRAKE 9.2/ DSL / smalllinux / Ubuntu 5.1
Posts: 202

Original Poster
Rep: Reputation: 30
Hi,

Sorry to keep you waiting, quite busy!!

Try first MDK control center and try to change from via module (via-82xx), to oss one (82cxxx) don't quite sure but similar.

Log out and in and try again.

You probably will have to change modules.conf file ( /etc/modules.conf ) to get things working.

I explain recently how i did it in another thread ( seek for bibilit on this forum ) i hope you will get your answers.
 
Old 03-10-2004, 08:19 AM   #13
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
Something I came across while researching a totally unrelated topic:
Apparently, support for the VIA8233 was working in kernel 2.4.16, then "disappeared" until 2.4.20, when it came back.
Check your kernel versions with:
uname -r

I'd suggest upgrading to the latest 2.4 kernel, or the 2.6 series if you feel ambitious.

--Rounan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Poor sound quality on ALC850 onboard sound (FC3) c_ryan Linux - Hardware 3 05-20-2005 03:58 AM
midi / synth sound with SIS7012 aka Intel i8x0 onboard sound card does not work wahwah Linux - Hardware 1 11-10-2003 05:25 PM
A7N8X + Mandrake 9.1 + onboard sound card = No SOUND st_purple Linux - Hardware 3 11-07-2003 08:30 AM
Will this system work on linux? (included: sata, msi gf 5600 tv-in, onboard sound,..) =X= Linux - Hardware 5 09-01-2003 01:56 PM
Sound blaster Live config with onboard sound card HChan Linux - Hardware 1 04-30-2003 01:47 AM


All times are GMT -5. The time now is 03:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration