LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 09-27-2004, 10:55 PM   #1
xxvm1
Member
 
Registered: Jul 2004
Distribution: WinXP Pro, Mandrake 10
Posts: 88

Rep: Reputation: 15
Thumbs down Timeout on server, Connection was to internet.com at port 80


Some websites work, some website won't. I don't see any pattern to it. Many sites like ebuyer.co.uk, virginmobile.com and teamtalk.com will work without any problems. However many sites like yahoo.com, google.com and linuxquestions.org amongst others provide the following error:

An error occurred while loading www.yahoo.com

Timeout on server
Connection was to yahoo.com at port 80

I thought maybe my Konqueror browser didn't have the latest plugins to be compatible with some sites, so i installed Mozilla's latest browser to see if it made a difference. Same problems with all the same sites.
It shouldn't be a network card problem as if it was no sites would work, as opposed to half.
I have a D-Link DSL-504T modem/router which claims to have a firewall onboard so is it possible this is the cause? Or is there a more common answer to this problem?
 
Old 09-28-2004, 01:17 PM   #2
bardinjw
Member
 
Registered: Apr 2003
Location: boston
Distribution: ubuntu debian redhat fedora
Posts: 108

Rep: Reputation: 15
can you get any sort of response from those servers?

try:
$ ping www.yahoo.com

if that doesn't work try:

$ ping 216.239.57.99
(thats one of googles servers)

if only the last one works you're having dns issues
 
Old 09-28-2004, 06:14 PM   #3
xxvm1
Member
 
Registered: Jul 2004
Distribution: WinXP Pro, Mandrake 10
Posts: 88

Original Poster
Rep: Reputation: 15
RE: bardinjw

I tried pinging www.yahoo as you suggested:

PING www.yahoo.com (66.94.230.48) 56(84) bytes of data.
64 bytes from www.yahoo.com (66.94.230.48): icmp_seq=1 ttl=51 time=163 ms
64 bytes from p17.www.scd.yahoo.com (66.94.230.48): icmp_seq=2 ttl=51 time=164 ms
64 bytes from p17.www.scd.yahoo.com (66.94.230.48): icmp_seq=3 ttl=51 time=163 ms
64 bytes from p17.www.scd.yahoo.com (66.94.230.48): icmp_seq=4 ttl=51 time=164 ms
64 bytes from p17.www.scd.yahoo.com (66.94.230.48): icmp_seq=5 ttl=51 time=162 ms

That went on for an infinite amount of lines.

And pinging 216.239.57.99 (google server) aswell:

PING 216.239.57.99 (216.239.57.99) 56(84) bytes of data.
64 bytes from 216.239.57.99: icmp_seq=1 ttl=240 time=162 ms
64 bytes from 216.239.57.99: icmp_seq=2 ttl=240 time=163 ms
64 bytes from 216.239.57.99: icmp_seq=3 ttl=240 time=162 ms
64 bytes from 216.239.57.99: icmp_seq=4 ttl=240 time=163 ms
64 bytes from 216.239.57.99: icmp_seq=5 ttl=240 time=162 ms

Also went on for an infinite number of lines.

What does this mean ?
 
Old 09-29-2004, 12:10 AM   #4
Toonses82
Member
 
Registered: Sep 2004
Location: Olympia, WA, USA
Distribution: Linux Mint 16 Cinnamon
Posts: 117

Rep: Reputation: 15
I am having the same problem. I run a dual boot machine (Mdk10.0 & WINXP). Windows has no problem with the internet. I ran Mdk9.2 before I got 10.0. That also did not have any problem with the internet. It has something to do with Mandrake 10.0.

There are a lot of people with this same problem. Does anyone know if Mandrake has made a patch or something for this?
 
Old 09-29-2004, 11:39 AM   #5
bardinjw
Member
 
Registered: Apr 2003
Location: boston
Distribution: ubuntu debian redhat fedora
Posts: 108

Rep: Reputation: 15
well, your connected allright.

i've had some luck speeding things up by disabling ipv6

first try just disabling it in mozilla. (i don't have mozilla on this pc, but i think it's the same in firefox)
type in the address "about:config"
type "ipv6" in the filter
change the line:
"network.dns.disableIPv6" to TRUE
and restart browser.



you can also disable IPv6 in kernel 2.6 by adding:

alias net-pf-10 off

to the end of your /etc/modprobe.conf file

i've had this happen in other distros too, so i don't think it's a mandrake thing.

Last edited by bardinjw; 09-29-2004 at 11:44 AM.
 
Old 09-29-2004, 12:22 PM   #6
xxvm1
Member
 
Registered: Jul 2004
Distribution: WinXP Pro, Mandrake 10
Posts: 88

Original Poster
Rep: Reputation: 15
So if you ran Mandrake 9.2 before and it was fine, it must be a problem with Mandrake 10. I'm glad it's not a problem with my Nvidia integrated ethernet card, which i'm sure is fully supported. And my D-Link DSL-504T four port ethernet ADSL modem/router and firewall.

I'm going to reinstall my Mandrake 9.2 because i really need the internet to work properly for my webmail. Or maybe i'll try the new SuSe.

Unless anyone has an idea if there is a patch for this problem on Mandrake 10 ?
 
Old 09-29-2004, 12:41 PM   #7
xxvm1
Member
 
Registered: Jul 2004
Distribution: WinXP Pro, Mandrake 10
Posts: 88

Original Poster
Rep: Reputation: 15
RE: bardinjw

I edited /etc/modprobe.conf as root by opening a console and ran:

$ kdesu kwrite /etc/modprobe.conf

And i made the following additions as advised by people on here:

alias net-pf-10 off
alias ipv6 off

This still did not help my Konqueror browser find yahoo.com, google.com, linuxquestions.org and many other sites.
 
Old 09-29-2004, 02:08 PM   #8
bardinjw
Member
 
Registered: Apr 2003
Location: boston
Distribution: ubuntu debian redhat fedora
Posts: 108

Rep: Reputation: 15
you need to reboot after you edit modprobe.conf
i've been told you can't unload ipv6 from the kernel.

if those don't help, sorry

anyone else have any ideas?
 
Old 09-29-2004, 02:13 PM   #9
nafan
Member
 
Registered: May 2004
Location: /dev/bed
Distribution: Mandriva 2009.0 Powerpack
Posts: 172

Rep: Reputation: 30
I had a problem where any time I tried to connect to a server on the internet it only succeeded on the second attempt. I found that when the ipsec service wasn't started everything worked fine.

It might be the problem, but it might not. Try disabling ipsec using the mandrake control centre (System | Services) and see what happens.
 
Old 10-12-2004, 04:39 AM   #10
asmar
LQ Newbie
 
Registered: Oct 2004
Location: To the best place in the world...Greece
Distribution: Debian, SuSE, CentOS, Solaris, Ubuntu
Posts: 25

Rep: Reputation: 15
Same problem here....
I spent so many hours trying to figure how it works and finally it doesn't work!

On Debian Sarge sometimes is working and sometimes not. On Red Hat ES3 seems to work.

Any suggestions?

I tried all the above without success.

Thanks
 
Old 10-12-2004, 07:16 AM   #11
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
If you are using KDE check the configuration for Konqueror.

There is a page where you can set the timeout values for web access, DNS, etc.

I ran into this same problem, which drove me nuts.

It seems that one of the updates set all the values down to 2 ms!!!!!

Hitting the "DEFAULTS" button fixed this IMMEDIATELY.

And yeah, same thing here, even things like Google wouldn't come up at times.

Or else I'd have to keep refreshing before I could get a page to come up.

Check it out, it worked for me!
 
Old 10-12-2004, 07:43 AM   #12
akjs1
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Rep: Reputation: 0
Hi, I had the same problem with a D-link 604 router.

I fixed it by firstly making sure that my DNS addresses were the same as that supplied by my ISP, they will be posted somewhere on their technicial page.

Also, make sure to do the following as already mentioned.

Edit /etc/modprobe.conf as root by opening a console and ran:

Make the following additions

alias net-pf-10 off
alias ipv6 off

I am a TOTAL beginner but looking through these forums really is the best way to get help.

Hope it solves it for you!!
 
Old 10-12-2004, 10:30 PM   #13
wonderingsoul
LQ Newbie
 
Registered: Oct 2004
Location: Denver
Distribution: SuSE
Posts: 2

Rep: Reputation: 0
Quote:
Originally posted by bardinjw

i've had some luck speeding things up by disabling ipv6

first try just disabling it in mozilla. (i don't have mozilla on this pc, but i think it's the same in firefox)
type in the address "about:config"
type "ipv6" in the filter
change the line:
"network.dns.disableIPv6" to TRUE
and restart browser.
<SNIP>
i've had this happen in other distros too, so i don't think it's a mandrake thing.
YES! I am so glad I found this forum. This little trick did it for me in SUSE 9.0. I thought the problem was due to my wireless card, but this simple change did the trick.
 
Old 10-22-2004, 04:15 PM   #14
jahsoul
LQ Newbie
 
Registered: Oct 2004
Posts: 1

Rep: Reputation: 0
Mandrake 10

I changed the file modprobe.conf like Someone posted here and it worked thanks m8, i was starting to desperate with madrake 10, i used to have the 9.1 version and it worked well so imagine the frustration when getting a newer version and getting everything screwed up hehe.

Last edited by jahsoul; 10-22-2004 at 04:17 PM.
 
Old 03-20-2008, 10:32 PM   #15
redryder82
LQ Newbie
 
Registered: Mar 2008
Posts: 6

Rep: Reputation: 0
First off I need you to know that I am a noob, so you might have to talk to me like a toddler. I've been fighting with this same problem for a while now and I think I'm getting close. I disabled ipv6 in mozilla by going to about:config and now its workingin mozilla only. When I try to do the same thing in Konqueror I am redirected to about:konqueror. Also I tried to add those lines to the /etc/modprobe.conf file but i'm not sure how to do it as root.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] OpenBSD/courier server connection timeout gypsy_rabbi *BSD 1 12-02-2005 12:28 AM
DHCP Server Client no connection to Internet westverg Linux - Networking 3 02-28-2005 08:08 AM
Showing CLIENT<-server->INTERNET connection from server. druuna Linux - Networking 2 05-03-2004 02:33 PM
Timeout errors on port 80 when trying to access internet in Fedora Core 2 Test 2 Jeffmrg Fedora 7 04-19-2004 03:36 PM
Internet connection timeout in Mandrake9.1 ybc Linux - Networking 0 12-19-2003 03:57 PM


All times are GMT -5. The time now is 11:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration