LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 12-20-2010, 12:25 PM   #1
pablo27
LQ Newbie
 
Registered: Oct 2009
Posts: 27

Rep: Reputation: 0
start menu. applications menu,desktop


I am trying out Mandriva on another machine and have come across a strange problem. It just updated last night and before update i had no start/applications icon or menu. After update the same problem. First time I've ever had this happen with a disto of any kind? Have icons for Firefox, Dolphin, terminal in taskbar but now applications are available. Is it my plasma settings or what is going on?? Need you input as I'm stumped at this point. Thanks in advance.
 
Old 12-20-2010, 05:17 PM   #2
jkerr82508
Member
 
Registered: Dec 2006
Location: Fife, Scotland
Posts: 250

Rep: Reputation: 66
To reset desktop to default configuration, in a terminal as user:

Code:
kquitapp plasma-desktop
rm -fv ~/.kde4/share/config/plasm*
plasma-desktop &
In some earlier versions of KDE:
Code:
kquitapp plasma
rm -fv ~/.kde4/share/config/plasm*
plasma &
Jim
 
Old 12-20-2010, 06:18 PM   #3
pablo27
LQ Newbie
 
Registered: Oct 2009
Posts: 27

Original Poster
Rep: Reputation: 0
Konsole msgs

[paul@localhost ~]$ plasma-desktop &
Thanks Jim for the really fast reply, This solution did work except I got the following msg on my terminal and when I closed the terminal the first time the screen went blank. I reopen a terminal and tried again with this msg:

[1] 30050
[paul@localhost ~]$ QDBusObjectPath: invalid path ""
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
Object::connect: No such slot SystemTray::PlasmoidProtocol::cleanupTask(plasma::Applet *, const QString &)
QGraphicsLinearLayout::removeAt: invalid index 0
Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
Couldn't find node overlay. Skipping rendering.
plasma-desktop(30051)/kdecore (KLibrary) kde4Factory: The library "/usr/lib/kde4/solid_hal_power.so" does not offer a qt_plugin_instance function.


Not sure what to do now? Thanks again
 
Old 12-20-2010, 06:30 PM   #4
jkerr82508
Member
 
Registered: Dec 2006
Location: Fife, Scotland
Posts: 250

Rep: Reputation: 66
Just run the command:
Code:
rm -fv ~/.kde4/share/config/plasm*
Then logout and log back in or re-boot.

Are you sure that you had a clean install to begin with? Did you verify the iso and the burn?

Jim
 
1 members found this post helpful.
Old 12-20-2010, 06:54 PM   #5
pablo27
LQ Newbie
 
Registered: Oct 2009
Posts: 27

Original Poster
Rep: Reputation: 0
Ok did as you said and seems to be ok now. This was an upgrade via web, the original iso was checked when I installed it initially. I really appreciate the quick and positive response but if it isn't too much more trouble (so I could learn something from this) what did I do with these commands and how did this happen? I know that is asking a lot or... if you could point me to some articles that would help. I don't want to just use Linux I want very much to learn Linux. Thanks so very much.
 
Old 12-20-2010, 07:39 PM   #6
jkerr82508
Member
 
Registered: Dec 2006
Location: Fife, Scotland
Posts: 250

Rep: Reputation: 66
For some reason your plasma-desktop configuration became corrupted, perhaps as a result of the upgrade. The three commands respectively stop plasma-desktop, delete its configuration files and restart plasma-desktop. Logging out and back in also stops and restarts plasma-desktop. When plasma-desktop starts, if its configuration files do not exist they are re-created in their default format.

I'm not sure where you'd find documentation on this. You could start with the KDE web site:

http://kde.org/

Jim
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to add e menu entry to KDE start menu over CLI browny_amiga Linux - General 7 02-08-2009 03:05 PM
Applications menu / Desktop shortcut markf@no-exit-studio Linux - Newbie 4 10-15-2008 03:30 PM
How to change GNOME main menu icon(Applications menu) deepclutch Linux - Software 7 06-25-2007 01:31 PM
Start Applications Menu - Missing things invalid Linux - Software 2 03-03-2005 02:19 PM
KDE applications menu replaced by Gnome style menu denh0 Mandriva 2 11-24-2003 12:14 AM


All times are GMT -5. The time now is 12:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration