LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   Slow name resolving _and_ slow konsole launch (http://www.linuxquestions.org/questions/mandriva-30/slow-name-resolving-_and_-slow-konsole-launch-296247/)

dangerbaby 03-01-2005 08:08 AM

Slow name resolving _and_ slow konsole launch
 
Hi all:

I am a first-time Mandrake user, and it is serving me pretty well overall. This weekend, however, my ISP upgraded their system and has caused me some difficulty. Calls to tech support result in the usual 'we only support windows.' Here's the situation: I use a cable modem to connect my Mandrake 10.1 Community box to the internet. Everything was going swimmingly until the ISP upgrade, which caused problems with name resolving and slow launch times on the desktop.

The slow name resolve is illustrated by a fast response time to pinging an IP and a several second lag when I ping the domain name. My ISP uses DHCP and re-writes the resolv.conf after each connect. The provided DNS are not the problem, however, as I experience the same lag if I substitute in known good servers. Also I have added the lines 'alias ipv6 off' and 'alias net-pf-10 off' to the modprobe.conf, rebooted, and saw no change. The only thing that looks a bit unusual to me is a Mask of 255.255.240.0--now this may be just fine, in which case I am demonstrating my ignorance.

I can understand the slow name resolve issue, but the slow application launch is confusing to me. The best example is konsole (the KDE terminal). If I am not connected to the network, the konsole launches in 1 sec. Now, after the ISP upgrade and when I am connected to the network, launching konsole takes about 15 sec. I obviusly don't have the depth of understanding that would lead to an explanation of this.

I have scoured the internet and Linuxquestions and Mandrakeusers to no avail. I would really appreciate guidance if anyone has ideas.

Cheers,
Brad

opjose 03-01-2005 08:27 AM

Re: Application launch

Mandrake defaults to PIO mode for all drives.

This is abysmally slow.

You need to enable DMA mode by uncommenting the lines which are commented out in /etc/sysconfig/harddisks and then rebooting.

Re: DNS

post the contents of

/etc/resolv.conf

and the output of

ifconfig

dangerbaby 03-01-2005 01:21 PM

thanks, opjose, I will get that output for you when I arrive home from work tonight.

Brad

dangerbaby 03-01-2005 06:21 PM

As requested, the output of ifconfig:
eth0 Link encap:Ethernet HWaddr 00:30:BD:06:54:BF
inet addr:206.255.101.222 Bcast:206.255.111.255 Mask:255.255.240.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:18107969 errors:26 dropped:306 overruns:1 frame:0
TX packets:531484 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2036144113 (1941.8 Mb) TX bytes:45467146 (43.3 Mb)
Interrupt:3 Base address:0xec00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:471 errors:0 dropped:0 overruns:0 frame:0
TX packets:471 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:30400 (29.6 Kb) TX bytes:30400 (29.6 Kb)


and the contents of /etc/resolv.conf
search cablerocket.net
nameserver 206.255.249.9
nameserver 204.174.16.4

opjose 03-01-2005 08:48 PM

I assume you've turned off IPX and IPV6 and then rebooted your system.

If not do so to effect the changes.

Next test name resolution...

e.g.

nslookup

> set all


You'll get something like this back...

Default server: 192.168.0.2
Address: 192.168.0.2#53
Default server: 64.81.111.2
Address: 64.81.111.2#53

Set options:
novc nodebug nod2
search recurse
timeout = 0 retry = 3 port = 53
querytype = A class = IN
srchlist = netrslts.com
>

Note the default server. This is the DNS to which your machine is trying first before falling through to your ISP's.

Now perform a search

> www.linuxquestions.org
Server: 192.168.0.2
Address: 192.168.0.2#53

Non-authoritative answer:
Name: www.linuxquestions.org
Address: 64.179.4.149
>

How is the response?

Now set the DNS queries to your ISP's servers one at a time and try them.

> server 64.81.111.2
Default server: 64.81.111.2
Address: 64.81.111.2#53
>

Again perform a search. Is the response immediate?

> www.linuxquestions.org
Server: 64.81.111.2
Address: 64.81.111.2#53

Non-authoritative answer:
Name: www.linuxquestions.org
Address: 64.179.4.149
>

Turn on debugging to see more info...

> set debug
> www.linuxquestions.org
Server: 64.81.111.2
Address: 64.81.111.2#53

Non-authoritative answer:
Name: www.linuxquestions.org
Address: 64.179.4.149
>set recurse on
>
> www.linuxquestions.org
Server: 64.81.111.2
Address: 64.81.111.2#53

------------
QUESTIONS:
www.linuxquestions.org, type = A, class = IN
ANSWERS:
-> www.linuxquestions.org
internet address = 64.179.4.149
AUTHORITY RECORDS:
ADDITIONAL RECORDS:
------------
Non-authoritative answer:
Name: www.linuxquestions.org
Address: 64.179.4.149
>

Are you getting INSTANT responses (try different lookups each time as once you've done a query the last response is probably sitting in the cache...).

Also try tracerouting your ISP's servers and pinging them.

I often have problems with Comcast's overworked, and buggy DNS servers in our area, which at times give slow resolution or timeouts.

I end up using another ISP's servers (in this case Speakeasy.net) so I merely place the Speakeasy server at the top of my /etc/resolv.conf file or specify this server in the interface configuration (see /etc/sysconfig/network-scripts/ifcfg-XXX ) so I don't have to type it in each time.

Not all ISP's will honor internet side queries, but you can try the above server which does. It's pretty fast for me.

Also consider installing a local caching nameserver (urpmi caching-nameserver) then edit the config file to add the above IP as a forwarder. That is, your machine will forward requests to the above site when it doesn't already know the answer. Each time it gets back an answer, it is held in it's cache, resulting in VERY VERY quick responses to domains you have already visited.

dangerbaby 03-02-2005 09:22 AM

Thanks again, opjose, for your help. I will try your suggestions tonight.

>I assume you've turned off IPX and IPV6 and then rebooted your system

I have added the lines 'alias ipv6 off' in modprobe.conf, which I guess disables IPV6. I am unsure, however, how to turn off the IPX.

Cheers,
Brad

dangerbaby 03-03-2005 05:42 AM

opjose, you set me out on the right track here. I was able to determine that the primary DNS handed out by the ISP was bum, and it had to time out and see the secondary before resolving any names. I am truly grateful for you help.

Cheers,
Brad

opjose 03-03-2005 06:11 AM

Excellent!

Glad to see it worked out.


All times are GMT -5. The time now is 09:57 AM.