LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 05-11-2004, 08:54 AM   #1
tsw
Member
 
Registered: May 2004
Location: Colorado
Distribution: Mandrake 10 power-pack
Posts: 74

Rep: Reputation: 15
shell text fonts are larger than normal???


I am not even really sure how to ask this question, but here I go.

I few days ago I booted my computer, IBM ThinkPad X21, and noticed that the fonts on the GRUB screen were like, two points larger than they had been. As the system installed I saw that same enlarged fonts during bootstraping. My system loaded just fine. However, I switched to a shell and there again the fonts were all whacked. They went from a '10' to a '12'. This is very strange.

I do not remember making any changes that would have affected this. I do not know even where to look to change them back. I checked in my BIOS settings and there was nothing there to control the size of these fonts. I hope I am making sense. I am running mdk10 on stated computer.

Can anyone direct me to the right file or script that would have this information? This is not a critical issue, however, I would like to discover how the change occured, if possible. At the least I would like to fix this error.

Thanks in advance for any tips...

tsw
 
Old 05-11-2004, 10:09 AM   #2
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Rep: Reputation: 30
A good place to start would p'bly be your XF86Config file and this doc: The Linux Font DeUglification HOWTO.

An exerpt is here:
Code:
If you start X from the console command prompt, type:

$ startx -- -dpi 100 -depth 16 # v4.x syntax 

Or these options can be stored in ~/.xserverrc. See the startx and xinit man pages for more on this. 

If you use xdm (or friends such as gdm) for graphical logins, you'll want to edit your
 /usr/X11/lib/X11/xdm/Xservers file (or possibly /etc/X11/xdm/Xservers) which will have the 
command line for the Xserver in it. Mine has the line:

:0 local /usr/X11R6/bin/X -dpi 100 -gamma 1.6 

You want to specify a value that is compatible with your monitor's output.

More information is in the X, Xserver, xdm, xinit, and startx man pages.
This won't change your font settings when X isn't running, but I'm not sure where those are specified. If you spend a lot of time there, I'll do some more digging.

Note: don't just try these commands before checking your config files to make sure they won't make your monitor implode. Incorrect settings can do bad things

Cool,
Laura

Last edited by rose_bud4201; 05-11-2004 at 10:12 AM.
 
Old 05-11-2004, 01:32 PM   #3
kamstrup
Member
 
Registered: Aug 2003
Location: Aarhus, Denmark
Distribution: Slackware, Ubuntu
Posts: 122

Rep: Reputation: 15
Are you talkin about a console in X or a plain bash without X? What system are you using since you are running Grub?

Even if you are not running X there's still a thing called "resolution". Your new system probably just told grub to use a lower resolution than you are used to. I know how to change this in lilo...

greetings,
kamstrup
 
Old 05-11-2004, 03:03 PM   #4
tsw
Member
 
Registered: May 2004
Location: Colorado
Distribution: Mandrake 10 power-pack
Posts: 74

Original Poster
Rep: Reputation: 15
Yes, I am talking about plain "bash" without X. I running mdk10 official. You are totally correct, the problem is RESOLUTION. How do we change it in bash?

I'll start looking through those files and docs that Laura laid on me. Thank you both for the responses.

tsw

Last edited by tsw; 05-11-2004 at 03:18 PM.
 
Old 05-11-2004, 03:47 PM   #5
kamstrup
Member
 
Registered: Aug 2003
Location: Aarhus, Denmark
Distribution: Slackware, Ubuntu
Posts: 122

Rep: Reputation: 15
If you are using lilo, you just have to edit /etc/lilo.conf to use another higher res mode and reinstall lilo to the mbr. I guess you can do something similar in grub.

The stuff Laura pointed to looks like X-related stuff which isn't exactly what you are looking fore...

brb,
kamstrup
 
Old 05-11-2004, 04:17 PM   #6
kamstrup
Member
 
Registered: Aug 2003
Location: Aarhus, Denmark
Distribution: Slackware, Ubuntu
Posts: 122

Rep: Reputation: 15
The relevant config file for grub should be /boot/grub/grub.conf -- I guess (I honestly don't know). You can find a little info+examples here:

http://susefaq.sourceforge.net/howto/multi_os_grub.html

I also found a list of available vga modes for the console here:

http://home.nyc.rr.com/computertaijutsu/grub.html

It reads:

# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769

hope this will help you,
kamstrup
 
Old 05-11-2004, 10:41 PM   #7
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Rep: Reputation: 30
This thread is talking about almost the same problem you're having - maybe it'll help?
http://www.linuxquestions.org/questi...079#post928079

cool,
Laura
 
Old 05-12-2004, 04:41 PM   #8
tsw
Member
 
Registered: May 2004
Location: Colorado
Distribution: Mandrake 10 power-pack
Posts: 74

Original Poster
Rep: Reputation: 15
All right, sometimes I am just a big idiot. Now, I don't claim to know what I am doing but this one was just dumb. I went back through my BIOS set up, looked through everything, line by line. The problem was there after all. Specifically the "HVcontrol". This horizontial/vertical setting was enabled, thus the shell fonts were enlarged. Of course they were. D'oh! I disabled it and voila that nice, pretty, small font size returned. I must have hit that control when I was in there changing the power settings for my laptop. Linux rocks!

Thanks everyone for traking down that information for me. I did a lot of reading and know a hell of a lot more that I did yesterday. Hopefully, one day I can return the favor.

TSW

tsw
 
Old 05-12-2004, 08:01 PM   #9
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Rep: Reputation: 30
Glad you fixed it (and you just taught me something, too)!

Laura
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Difference between normal shell and login shell Manish Linux - General 7 11-14-2012 09:30 AM
How to find and change a specific text in a text file by using shell script Bassam Programming 1 07-18-2005 08:15 PM
make OpenBSD's text console larger? gani *BSD 4 09-21-2004 12:44 AM
Ugly fonts when logged in as normal user Abdul Linux - Software 2 03-09-2004 02:46 AM
Changing from text to GUI in normal user mode rcmadhu Linux - Newbie 1 11-30-2003 04:05 PM


All times are GMT -5. The time now is 01:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration