LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices



Reply
 
Search this Thread
Old 10-25-2004, 05:30 AM   #1
imagineaxion
Member
 
Registered: Sep 2004
Location: Epsom, Surrey
Distribution: Ubuntu & Mac OS X
Posts: 141

Rep: Reputation: 16
setting a default browser


how do i setup firefox as my default browser?

i have installed it through rpmdrake and when it loaded it kept asking me every time if i want to make it my default browser so i said yes every time, so it obviosly wasn't setting it to the default i then got sick of this and unchecked the button that said 'check every time'
and now i have NO default browser so when a program wants to pop something up or connect i get and error

how do i set mandrake to use firefox?

i'm using mandrake 10 by the way

thanks graham
 
Old 10-25-2004, 05:37 PM   #2
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
I believe that this setting is for Gnome not KDE.

KDE uses Konqueror as it's browser.
 
Old 10-26-2004, 05:23 PM   #3
juxx
LQ Newbie
 
Registered: Oct 2004
Location: Italy
Distribution: Mandrake 10.0
Posts: 1

Rep: Reputation: 0
I tryied setting Firefox as default app for HTML files in

System -> config -> KDE -> Components -> File Associations

It seems work, but in KMail I get file on my disk and I'm browsing 'file:///xxxx'

I'm still searching.
 
Old 10-26-2004, 05:30 PM   #4
imagineaxion
Member
 
Registered: Sep 2004
Location: Epsom, Surrey
Distribution: Ubuntu & Mac OS X
Posts: 141

Original Poster
Rep: Reputation: 16
thanks juxx
 
Old 11-26-2004, 08:05 AM   #5
properler
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
It seems there is two ways to cover kde and the rest.

The first is covered by a previous post.
System -> config -> KDE -> Components -> File Associations
It is so useful that I haved added it as a button in the panel.
Add -> Applications Button -> System -> config -> KDE -> Components -> File Associations

The second should cover components embedded in kde application

System -> config -> KDE -> Components -> Component Chooser

--
stef

Last edited by properler; 11-26-2004 at 08:17 AM.
 
Old 11-30-2004, 01:48 PM   #6
doctorwebbox
Member
 
Registered: Jun 2003
Location: Rotherham, South Yorkshire, England
Distribution: Debian
Posts: 117

Rep: Reputation: 15
I can't get this to work

I have got mozilla-firefox as my default browser in KDE -> Components -> Component Chooser and it is the default handler for .html files but if I click on a link in thunderbird it still always opens them in galeon.

Any ideas?
 
Old 11-30-2004, 02:05 PM   #7
ralvez
Member
 
Registered: Oct 2003
Location: Canada
Distribution: ArchLinux && Slackware 10.1
Posts: 298

Rep: Reputation: 30
doctorwebbox, the answer to your question is to set the order of the application that deals with your html files.
Here is how it is done:
1. Open Konqueror
2. Select "Settings"
3. Click "Configure Konqueror"
4. Select "File Assoc."
5. Select "Text"
6. Click on "HTML"
the panel will open and you will see all the applications that handle html documents. Make sure that Firefox is on the top and it will be used by default to open HTML documents.

Hope this helps.

R
 
Old 11-30-2004, 02:29 PM   #8
doctorwebbox
Member
 
Registered: Jun 2003
Location: Rotherham, South Yorkshire, England
Distribution: Debian
Posts: 117

Rep: Reputation: 15
Already done

I've already done that. It will use firefox to follow links in konqueror but not in thunderbird and other applications.
 
Old 11-30-2004, 03:02 PM   #9
rokka
Member
 
Registered: Feb 2004
Location: .se
Distribution: Ubuntu, debian
Posts: 124

Rep: Reputation: 15
Re: Already done

Quote:
Originally posted by doctorwebbox
I've already done that. It will use firefox to follow links in konqueror but not in thunderbird and other applications.
Oh but that's a known issue with thunderbird. There is a solution here:http://www.mozilla.org/projects/thun...linuxurls.html
 
Old 12-01-2004, 09:26 AM   #10
shea1roh
Member
 
Registered: Jul 2003
Location: Grand Meadow MN
Distribution: Mandrake 2010.2 & Fedora 14
Posts: 99

Rep: Reputation: 17
I am having the same problem. I have setup firefox under the file associations & made sure that it is the top of the list. I use kontact for email & when I click on a link in a message, it trys to kick off firefox, sometimes I get an error message that it can't find the file & lists the url, other times it just gives up.
 
Old 12-13-2004, 10:09 AM   #11
jakedakat
LQ Newbie
 
Registered: Dec 2004
Posts: 1

Rep: Reputation: 0
I was having the same problem w/Evolution and Thunderbird. I had firefox set to load html files but it still wouldnt open it. I use KDE, but what I had to do was change my prefered browser under Gnome also. So you might wanna try changing it under the Gnome Control panel. Hope that helps.

Rob
 
Old 12-31-2004, 04:09 AM   #12
pmusselman
LQ Newbie
 
Registered: Dec 2004
Posts: 1

Rep: Reputation: 0
Talking Setting default browser for Mozilla in KDE

Go to K -> Preferences -> KDE Components -> File Associations.
Select text -> html in the MIME type tree.
Select "Add..." under "Application Preference Order".
Select Mozilla or type in the path to Mozilla's script file (for example, "/usr/lib/mozilla/mozilla").
 
Old 01-07-2005, 01:16 AM   #13
mike2005
LQ Newbie
 
Registered: Jan 2005
Posts: 1

Rep: Reputation: 0
I'm a definite Linux newbie, just installed Mandrake 10.1 a few days ago, but I figured out how to do this in Gnome if anyone's interested:

1. Go to System -> Config -> Gnome -> Advanced -> Preferred Applications, and set Firefox in there as Default Web Browser (may need to do it as a Custom Web Browser)

2. Go to System -> Config ->Gnome -> Advanced -> File Types and Programs, and set Firefox as the default program under Internet Services/World wide web (and under Documents/World Wide Web/HTML page, if necessary)

Those two steps should cover you, at least it worked for me. Good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting default browser (and other defaults?) ToothlessRebel Linux - Newbie 2 07-22-2004 07:20 PM
setting default browser? tombomb300 Linux - Software 1 10-19-2003 08:14 PM
Setting Mozilla as Default Browser Witch-King Linux - Software 21 06-11-2003 12:44 AM
Setting a default browser freezinbutt Linux - Newbie 14 03-30-2002 02:17 AM
Default browser setting... Chijtska Linux - Networking 0 01-31-2002 08:38 PM


All times are GMT -5. The time now is 07:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration