LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 02-08-2005, 06:55 PM   #1
rksprst
Member
 
Registered: Jan 2004
Distribution: OS X 10.4
Posts: 172
Blog Entries: 1

Rep: Reputation: 30
help with scanner


hi,

so i installed xsane

this is what i get when i do scanimage -L
Code:
[root@toshiba-user alex]# scanimage -L
device `artec_eplus48u:libusb:001:003' is a Artec E+ 48U USB flatbed scanner
but when i try to run xsane, i get the following error:
http://virusorcancer.com/error.jpg

anyone know what is causing it?

thanks

Last edited by rksprst; 02-08-2005 at 09:50 PM.
 
Old 02-10-2005, 03:34 AM   #2
rksprst
Member
 
Registered: Jan 2004
Distribution: OS X 10.4
Posts: 172
Blog Entries: 1

Original Poster
Rep: Reputation: 30
anyone? plzzz
 
Old 02-10-2005, 04:50 AM   #3
bunnadik
Member
 
Registered: Jan 2005
Location: Ívik, Sweden
Distribution: MDK 10.1
Posts: 450

Rep: Reputation: 30
Try 'cat /proc/bus/usb/devices' and look for your scanner.
My Epson info is
Quote:
T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
D: Ver= 1.00 Cls=ff(vend.) Sub=00 Prot=ff MxPS= 8 #Cfgs= 1
P: Vendor=04b8 ProdID=010c Rev= 0.01
S: Manufacturer=EPSON
S: Product=Perfection640
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 2mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E: Ad=81(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
Look at the T: entry and notice the Dev#= number
Using that do a 'ls -la /proc/bus/usb/001/DEVNUMBER' (in my case ls -la /proc/bus/usb/001/002)
and see who's the owner. chown that to your user and it should work.

There probably is a "proper" way of doing this (and I have no problem in 10.1 OE) but you could
add a chmod entry to /etc/rc.local to make it work in the future.

- Peder
 
Old 02-10-2005, 05:23 PM   #4
rksprst
Member
 
Registered: Jan 2004
Distribution: OS X 10.4
Posts: 172
Blog Entries: 1

Original Poster
Rep: Reputation: 30
I changed the permissions, but it still didn't work..

hmm..maybe its better in the hardware forum? i guess more hardware then mandrake question..
so can a mod plz move the questions there, thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xsane don't detected canon N1220U scanner rosariowong Slackware 6 09-28-2004 11:16 AM
Xsane and scanner mdk Mandriva 0 09-21-2004 02:42 AM
Why does xsane scanner ask me which device harry_fine Linux - Hardware 0 09-03-2004 08:35 AM
Scanner/xsane/vuescan nothing wants to work kak Linux - Hardware 8 08-28-2004 04:10 PM
sane/xsane can't find usb scanner walterbyrd Linux - Hardware 0 07-24-2004 10:39 AM


All times are GMT -5. The time now is 03:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration