LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 10-19-2004, 11:25 PM   #31
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30

Quote:
Originally posted by opjose
You don't have network Hotplugging turned on for the eth0 nic do you?
I don't even know what that is.
 
Old 10-19-2004, 11:27 PM   #32
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
I think I'm starting to understand. Here's what I tried from a previous post:

find . -exec grep -l 127.0.0.1 {}\;
find: missing argument to `-exec'
 
Old 10-19-2004, 11:28 PM   #33
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by darthtux
Your router gets it's IP and DNS information dynamically from your ISP unless you payed for a static IP.

Two of us have already stated, your going to have to go and search through your startup scripts and find out where it is setting the 127.0.0.1.
Yes, my router gets its IP onformation from the WAN side dynamically. I am giving my internal PCs the INTERNAL IP address of the router as the DNS servers.
 
Old 10-19-2004, 11:37 PM   #34
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
Quote:
Originally posted by Snump
I think I'm starting to understand. Here's what I tried from a previous post:

find . -exec grep -l 127.0.0.1 {}\;
find: missing argument to `-exec'
You need a space between the brackets and the slash.
 
Old 10-20-2004, 12:01 AM   #35
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by darthtux
You need a space between the brackets and the slash.
I'll continue this tomorrow. Thanks for the help, I appreciate it.
 
Old 10-20-2004, 03:16 AM   #36
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
I am studying DNS and so I installed bind on my box. Now I have
nameserver 127.0.0.1
in my /etc/resolv.conf

I'm using Debian and found the cause in my startup script for bind. So that is where you need to look. Somewhere in /etc/init.d or on of the /etc/rc?.d directories. I am not sure where Mandrake keeps them.

Running bind as a caching server has speeded up my internet surfing. I can tell the differnce in speed from the first time I visit a site and subsequent visits.
 
Old 10-20-2004, 03:19 AM   #37
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
This had me thinking...

The only reason I could think of why the Nvidia/X installer would be so dependant upon /etc/resolv.conf, would be if your machine otherwise did not know it's own name!

That is you didn't NAME the nic interfaces and/or correctly specify the hostname and domain.

Try setting /etc/resolv.conf as you had it before with the working IP's for surfing.

Then ping "localhost", "ping MyHostname" and "ping MyHostname.fulldomain.com".

All should respond to the ping, usually with the latter two returning the IP of the NIC.

If NOT you will need to edit /etc/hosts and try again until the ping works.

This will probably fix the problem with X dying after you change /etc/resolv.conf.

Last edited by opjose; 10-20-2004 at 03:24 AM.
 
Old 10-20-2004, 03:22 AM   #38
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Hey Darth... have you tried squid on top of that?

Great stuff!

It's easy to set up but the ACL stuff can be confusing if you are not used to it.

WEBMIN simplfies this.
 
Old 10-20-2004, 03:52 AM   #39
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
opjose, looks like you have started me on another project I think I will try to do it by hand. I like to get down and dirty with the configs If you know of any sites besides the squid home page that might come in handy, please post them.

BTW, my caching server is woking great. First query is 94 msec. The subsequent ones are 7msec. What an improvement!
 
Old 10-20-2004, 04:09 AM   #40
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
The SQUID conf file is pretty self documenting.

The only thing to watch out for is that by default it prohibits access from all hosts until you set the acl allow-hosts entry and restart squid.
 
Old 10-20-2004, 06:01 PM   #41
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Ok... here's what I get

find . -exec grep -l 127.0.0.1 {} \;
./sysconfig/network-scripts/ifcfg-lo
./sysconfig/networking/ifcfg-lo
./hosts
./rc.d/init.d/cups
./rc.d/rc0.d/K60cups
./rc.d/rc1.d/K60cups
./rc.d/rc2.d/S60cups
./rc.d/rc3.d/S60cups
./rc.d/rc4.d/S60cups
./rc.d/rc5.d/S60cups
./rc.d/rc6.d/K60cups
./alternatives/xinetd
./alternatives/smbclient
./alternatives/nmblookup
./alternatives/cups_smb
./alternatives/mount.smb
./alternatives/smbget
./alternatives/smbmount
./alternatives/mount.smbfs
./alternatives/smbspool
./xinetd.d/fam
./netprofile/profiles/default/files/etc/hosts
./cups/cupsd.conf
./postfix/main.cf.dist
./postfix/master.cf
./samba/lmhosts
./resolv.conf
./resolv.conf~
./resolv.backup
 
Old 10-20-2004, 06:05 PM   #42
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by opjose
This had me thinking...

The only reason I could think of why the Nvidia/X installer would be so dependant upon /etc/resolv.conf, would be if your machine otherwise did not know it's own name!

That is you didn't NAME the nic interfaces and/or correctly specify the hostname and domain.

Try setting /etc/resolv.conf as you had it before with the working IP's for surfing.

Then ping "localhost", "ping MyHostname" and "ping MyHostname.fulldomain.com".

All should respond to the ping, usually with the latter two returning the IP of the NIC.

If NOT you will need to edit /etc/hosts and try again until the ping works.

This will probably fix the problem with X dying after you change /etc/resolv.conf.
OK, I forget where exactly I have to enter that information....
 
Old 10-20-2004, 09:36 PM   #43
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
This gets better and better. I reformatted. Just for the heck ofit. WhenI go into my network settings like I did previously, X refuses to start. I changed nothing. I looked inthere to make sure it was not resetting again on boot, and boom. I reboot and it says X can't start. Arg.
 
Old 10-21-2004, 03:34 AM   #44
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Prior to your reformat it seems that you had some entries in netprofiles which might have been setting things back.

Anyway start up in non-fb mode which will get you a TEXT startup.

Login as root.

Now change /etc/resolv.conf to what you had when it was working and type "X".

See if you get a graphical screen (ALT-BACKSPACE gets you back out...)

If you do then do as I mentioned in the prior post.

I still believe that one problem you are having is that the machine does not know who it is.

If you cannot get the graphical screen try running XorgConfig or whatever it is called and try different video card and monitor settings (test each one!) until you get something that works.
 
Old 10-21-2004, 06:47 PM   #45
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by opjose
Prior to your reformat it seems that you had some entries in netprofiles which might have been setting things back.

Anyway start up in non-fb mode which will get you a TEXT startup.

Login as root.

Now change /etc/resolv.conf to what you had when it was working and type "X".

See if you get a graphical screen (ALT-BACKSPACE gets you back out...)

If you do then do as I mentioned in the prior post.

I still believe that one problem you are having is that the machine does not know who it is.

If you cannot get the graphical screen try running XorgConfig or whatever it is called and try different video card and monitor settings (test each one!) until you get something that works.
It appears I have discovered a bug.

After a completely clear reformat, installing no servers at all, when I boot into Gnome of KDE for the first time, that 127 DNS entry is there. I disabled that hotplugging thing, and it still does it.
Change it once, reboot and its back. I tried changing it everywhere, through various ways, and Its still there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
resolv.conf albundy Linux - Software 5 12-14-2004 03:12 PM
resolv.conf jmdlcar Slackware 9 05-15-2004 11:44 AM
resolv.conf ricemark20 Linux - Networking 12 11-11-2003 04:08 PM
resolv.conf dnsbum Linux - Networking 1 10-21-2003 12:00 PM
resolv.conf Culbert Linux - Networking 8 03-20-2003 04:11 PM


All times are GMT -5. The time now is 08:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration