LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 10-19-2004, 10:14 PM   #16
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30

I had to reinstall my nvidia driver. I don't know why. I set up eth0 with the correct dns server. Rebooted, and boom. its back to the 127 (incorrect address).
MCC. How exactly do I get into that? I'm sorry for being dense, but this is rather frusterating. I'm not used to not being able to figure things out the first time around.
 
Old 10-19-2004, 10:15 PM   #17
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
MCC is the Mandrake Control Center

You said you "set up eth0"

what did you use to do this?

 
Old 10-19-2004, 10:20 PM   #18
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by opjose
MCC is the Mandrake Control Center

You said you "set up eth0"

what did you use to do this?
I just realized what you meant. Yes, I used MCC.

I went to MCC -> Hardware -> hardware -> ethernet card -> run config tool
I chose LAN connection, then is asks for Net Device my choices are eth0: Realtek, and manual choice.
I chose eth0. Then I chose manual configuration, kepy my IP setting and then I see my incorrect dns settings. I changed it and had the X server blow up on me.
 
Old 10-19-2004, 10:27 PM   #19
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Now I'm back to where I was before. I changed the dns servers and X doesn't start. What is the command to configure X?
 
Old 10-19-2004, 10:33 PM   #20
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Check the files in /etc/netprofile/profiles/default and /etc/sysconfig/network-scripts

Look for any occurance of 127.0.0.1 which may be used to set up /etc/resolv.conf

You can do this recursively by:

cd /etc/sysconfig

find . -exec grep -l 127.0.0.1 {}\;

which will list files with matches in all subdirectories.


Worst case, and I know this is not a GREAT solution you can do this.

1) Modify resolv.conf and make sure it works.

2) Copy resolv.conf to a backup.

as root

cp /etc/resolv.conf /etc/resolv.conf.sav

3) Now edit /etc/rc.d/rc.local and add this line to it at the end.

cp -f /etc/resolv/conf.sav /etc/resolv.conf
 
Old 10-19-2004, 10:35 PM   #21
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by opjose
Check the files in /etc/netprofile/profiles/default and /etc/sysconfig/network-scripts

Look for any occurance of 127.0.0.1 which may be used to set up /etc/resolv.conf

You can do this recursively by:

cd /etc/sysconfig

find . -exec grep -l 127.0.0.1 {}\;

which will list files with matches in all subdirectories.


Worst case, and I know this is not a GREAT solution you can do this.

1) Modify resolv.conf and make sure it works.

2) Copy resolv.conf to a backup.

as root

cp /etc/resolv.conf /etc/resolv.conf.sav

3) Now edit /etc/rc.d/rc.local and add this line to it at the end.

cp -f /etc/resolv/conf.sav /etc/resolv.conf

Should I reinstall my video driver and try this, or go ahead with reconfigureing X?

How do I set up X again?
 
Old 10-19-2004, 10:39 PM   #22
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
If X is not working, go ahead and re-install the drivers to get X up again.

BTW: after you re-install the driver RPM's see if any changes have been made to /etc/resolv.conf


THIS SHOULD READ:

----------------------------------------

2) Copy resolv.conf to a backup.

as root

cp /etc/resolv.conf /etc/resolv.conf.sav

3) Now edit /etc/rc.d/rc.local and add this line to it at the end.

cp -f /etc/resolv.conf.sav /etc/resolv.conf


Note the slashes and periods.
 
Old 10-19-2004, 10:52 PM   #23
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by opjose
If X is not working, go ahead and re-install the drivers to get X up again.

BTW: after you re-install the driver RPM's see if any changes have been made to /etc/resolv.conf


THIS SHOULD READ:

----------------------------------------

2) Copy resolv.conf to a backup.

as root

cp /etc/resolv.conf /etc/resolv.conf.sav

3) Now edit /etc/rc.d/rc.local and add this line to it at the end.

cp -f /etc/resolv.conf.sav /etc/resolv.conf


Note the slashes and periods.
Hmm. To me that solution is a band-aid. Is there another way to do it? What if my ISP changes DNS servers and I have to change it? then I have to edit that crazy sav file.

After I install the nvidia driver its back to the 127 address. What I would like to do, is switch the DNS servers correctly, and knowing that X wont' start, reconfigure it such that it will. Is that porribls?
 
Old 10-19-2004, 10:59 PM   #24
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
Quote:
Originally posted by Snump
Hmm. To me that solution is a band-aid. Is there another way to do it? What if my ISP changes DNS servers and I have to change it? then I have to edit that crazy sav file.

After I install the nvidia driver its back to the 127 address. What I would like to do, is switch the DNS servers correctly, and knowing that X wont' start, reconfigure it such that it will. Is that porribls?
According to your first post, your not using your ISP's DNS servers. Your using the IP of your router which is dynamically getting the nameserver info from your ISP.
 
Old 10-19-2004, 11:01 PM   #25
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Quote:
Originally posted by Snump
Hmm. To me that solution is a band-aid. Is there another way to do it? What if my ISP changes DNS servers and I have to change it? then I have to edit that crazy sav file.

After I install the nvidia driver its back to the 127 address. What I would like to do, is switch the DNS servers correctly, and knowing that X wont' start, reconfigure it such that it will. Is that porribls?
Aren't you setting a STATIC IP for your eth0 interface?

I thought this is what you were doing all along.

Anytime you have a static IP you need to manually set the ISP's DNS servers.

These are automatically set only if you are using DHCP and are DIRECTLY connected to the cable modem/dsl line.


What is a bit troubling is that the driver itself is reverting /etc/resolv.conf back to the 127.0.0.1 setting.

Are you using the .RPM file which came with the distro, or did you download a new driver from Nvidia?
 
Old 10-19-2004, 11:09 PM   #26
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Quote:
Originally posted by darthtux
According to your first post, your not using your ISP's DNS servers. Your using the IP of your router which is dynamically getting the nameserver info from your ISP.
Exactly.

However somehow his resolv.conf file's first entry keeps getting changed back to the local host.

Since any attempts to browse the net cause the search to start via a non existant local server, he gets a slow response/timeout before it moves on to quering the router, which also appears to be slow at forwarding the resolution requests.

Once he changes /etc/resolv.conf to point to the ISP's DNS, everything is fine.

So, either he fixes his router to have the router dole out the ISP's DNS (but this does not overcome the 127.0.0.1 issue), he installs BIND locally with the namecaching server RPM's, so that his local 127.0.01 CAN answer queries, or he finds what is modifying resolv.conf by tracking down the startup scripts.

Given what he has been through, installing the bind RPM's and the namecaching server RPM's is probably the easiest solution.
 
Old 10-19-2004, 11:10 PM   #27
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by opjose
Aren't you setting a STATIC IP for your eth0 interface?

I thought this is what you were doing all along.

Anytime you have a static IP you need to manually set the ISP's DNS servers.

These are automatically set only if you are using DHCP and are DIRECTLY connected to the cable modem/dsl line.


What is a bit troubling is that the driver itself is reverting /etc/resolv.conf back to the 127.0.0.1 setting.

Are you using the .RPM file which came with the distro, or did you download a new driver from Nvidia?
OK, my router can double as a DNS server. On the windows machines I have my router set as the DNS server and they're all working perfectly. maybe I shouldchange that.
I am using a driver downloaded from nvidia. I have to do a sh driverfile.run to install it. It is not an RPM.
I am using STATIC IPs. Nothing is dynamic.
What I want to do, is be able to set the DNS server setting, and have it stick. Thats it.
Most likely while I was sertting up the PC I typed it in wrong. If I remember correctly, for some stupid reason the default setting for the DNS servers was 127.0.0.1. I probably forgot to change number 1 and only changed 2 and 3 thus leaving the incorrect 127 in there. This PC was always slow at bringing up webpages. I just noticed it now because I was only using it to store files. now I want to use it for a few other things and I need DNS working correctly.
 
Old 10-19-2004, 11:12 PM   #28
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by opjose
Exactly.

However somehow his resolv.conf file's first entry keeps getting changed back to the local host.

Since any attempts to browse the net cause the search to start via a non existant local server, he gets a slow response/timeout before it moves on to quering the router, which also appears to be slow at forwarding the resolution requests.

Once he changes /etc/resolv.conf to point to the ISP's DNS, everything is fine.

So, either he fixes his router to have the router dole out the ISP's DNS (but this does not overcome the 127.0.0.1 issue), he installs BIND locally with the namecaching server RPM's, so that his local 127.0.01 CAN answer queries, or he finds what is modifying resolv.conf by tracking down the startup scripts.

Given what he has been through, installing the bind RPM's and the namecaching server RPM's is probably the easiest solution.
I want to track down what is changing my resolf.conv.

Nothing in my internal network is dtnamic. everything is static.
No IP addys are being dished out by the router. So the router should be OK.
I just want to get these settings to stick.
 
Old 10-19-2004, 11:14 PM   #29
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
You don't have network Hotplugging turned on for the eth0 nic do you?
 
Old 10-19-2004, 11:18 PM   #30
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
Your router gets it's IP and DNS information dynamically from your ISP unless you payed for a static IP.

Two of us have already stated, your going to have to go and search through your startup scripts and find out where it is setting the 127.0.0.1.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
resolv.conf albundy Linux - Software 5 12-14-2004 03:12 PM
resolv.conf jmdlcar Slackware 9 05-15-2004 11:44 AM
resolv.conf ricemark20 Linux - Networking 12 11-11-2003 04:08 PM
resolv.conf dnsbum Linux - Networking 1 10-21-2003 12:00 PM
resolv.conf Culbert Linux - Networking 8 03-20-2003 04:11 PM


All times are GMT -5. The time now is 03:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration