LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 08-25-2003, 10:28 PM   #1
wasabi
Member
 
Registered: Aug 2003
Location: Charlotte, NC
Distribution: Fedora Core 3?
Posts: 95

Rep: Reputation: 15
Reading Files off of an NTFS drive


I have installed linux mandrake 9.1 and everything seems to be running fine (except this konquerer web browser seems a little slow). I do however want to be able to read files off of a backup hard drive I used. I installed it via IDE and it shows up on my desktop as unmounted and when I click it I am not able to view contents.

How would I go about this? I am sorry, I am a first day linux user.

BTW: Contents are all my digital images and video as well as some other personal documents.

Thanks for your help

 
Old 08-25-2003, 10:59 PM   #2
tmorton
Member
 
Registered: Jan 2003
Location: In front of my computer in Oregon, USA
Distribution: Slackware
Posts: 198

Rep: Reputation: 31
Make sure that the NTFS module is loaded. Type modprobe ntfs at a prompt (probably Konsole for you)...
--Taj
 
Old 08-25-2003, 11:49 PM   #3
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
The general idea is to create a mount point first in Mandrake then mount the filesystem from the partition on your back up drive to the mount point in Mandrake - you will then be able to see your files.

Linux sees IDE drives like this:

/dev/hda - drive on primary master channel
/dev/hdb - primary slave
/dev/hdc - secondary master
/dev/hdd - secondary slave

So - suppose your NTFS filesystem was on the first partition on your primary slave drive - Linux would see the partition as

/dev/hdb1

So you want to mount this filesystem to the mount point in Mandrake:

Open a shell and type :

su
Then type you root password then type :

mkdir /mnt/windows

Then - open /etc/fstab with:

kedit /etc/fstab

Then - put an entry at the bottom of your /etc/fstab file on a new line - (just substitute in the device name of your Partition in place of my example one)

/dev/hdb1 /mnt/windows ntfs auto,ro,umask=0222 0 0

Once youve made the changes to Fstab - save it and reboot - this is only an example - youll have to repost to give me more details on whicj IDE channel your drive is on and what the partitions are to take it further.

MAndrake can read NTFS out of the box, so dont worry - you cant write to NTFS though - dont try it.

Last edited by Skyline; 08-25-2003 at 11:55 PM.
 
Old 08-26-2003, 10:01 AM   #4
wasabi
Member
 
Registered: Aug 2003
Location: Charlotte, NC
Distribution: Fedora Core 3?
Posts: 95

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Skyline
.....this is only an example - youll have to repost to give me more details on whicj IDE channel your drive is on and what the partitions are to take it further......
wow thanks for the great response

the drive shows up on my desktop as

Hard Disc
(hdb1) (not
mounted)

I believe there is one partition on the drive and it is NTFS. This partition was set up using XP but is not a system drive (has no system files, only backup data).

Thankyou for your help

 
Old 08-26-2003, 12:03 PM   #5
wasabi
Member
 
Registered: Aug 2003
Location: Charlotte, NC
Distribution: Fedora Core 3?
Posts: 95

Original Poster
Rep: Reputation: 15
ok

I have found out some more info

/dev/hdb1 /mnt/hd auto user,iocharset=iso8859-1,kudzu,codepage=850,noauto,umask=0,exec 0 0

I have this line in my fstab

I want this obviously to recognize my NTFX partition, but I dont want it to damage or corrupt it. Any help would be great.
 
Old 08-26-2003, 12:18 PM   #6
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Personaly - I would just create it form scratch using the info Ive given - however since youve got a line already in fstab try this first - alter your line to this:

/dev/hdb1 /mnt/hd ntfs auto,ro,umask=0222 0 0

and save the file, reboot your computer and check to see if the files are mounted.

repost and let me know - you can always put kudzu etc etc back in later if it doesnt like it.


( Or if you didnt want to mess much to start with then try just changing the

noauto option into

auto

Also Ive changed the 3rd field to ntfs try this line first:

/dev/hdb1 /mnt/hd ntfs user,iocharset=iso8859-1,kudzu,codepage=850,auto,umask=0,exec 0 0

Last edited by Skyline; 08-26-2003 at 12:24 PM.
 
Old 08-26-2003, 12:37 PM   #7
wasabi
Member
 
Registered: Aug 2003
Location: Charlotte, NC
Distribution: Fedora Core 3?
Posts: 95

Original Poster
Rep: Reputation: 15
I am going to try this however when I do try I am not able to save it. I assume this is because I am logged in as my user name as opposed to root. How do I get into root access for this file. I went to permissions but was not allowed to change the settings.
 
Old 08-26-2003, 12:41 PM   #8
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Hi Was

Open a shell and type :

su
Then type you root password

open /etc/fstab with:

kedit /etc/fstab


Also - read my edit above - try this one first -

/dev/hdb1 /mnt/hd ntfs user,iocharset=iso8859-1,kudzu,codepage=850,auto,umask=0,exec 0 0

If you still need to try this one last

/dev/hdb1 /mnt/hd ntfs auto,ro,umask=0222 0 0

Last edited by Skyline; 08-26-2003 at 12:44 PM.
 
Old 08-26-2003, 12:48 PM   #9
wasabi
Member
 
Registered: Aug 2003
Location: Charlotte, NC
Distribution: Fedora Core 3?
Posts: 95

Original Poster
Rep: Reputation: 15
this is what I get

[j@clt88-151-086 j]$ su
Password:
[root@clt88-151-086 j]# kedit/etc/fstab
bash: kedit/etc/fstab: No such file or directory
[root@clt88-151-086 j]# cd etc/fstabb
bash: cd: etc/fstabb: No such file or directory
[root@clt88-151-086 j]# etc
bash: etc: command not found
[root@clt88-151-086 j]# dir
amsn_received Desktop Documents Mail msn tmp
[root@clt88-151-086 j]#
 
Old 08-26-2003, 12:48 PM   #10
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Hi Was

In general - you edit configuration files as root user by

Opening a command line shell

Type

su

Then type you root password

Then type

editor filename

in your case its

kedit /etc/fstab
 
Old 08-26-2003, 12:49 PM   #11
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Was you need a single space between

kedit

and

/etc/fstab
 
Old 08-26-2003, 12:50 PM   #12
wasabi
Member
 
Registered: Aug 2003
Location: Charlotte, NC
Distribution: Fedora Core 3?
Posts: 95

Original Poster
Rep: Reputation: 15
i did that and i got no such file found

^^see above post
 
Old 08-26-2003, 12:51 PM   #13
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Did you have a single space between

kedit

and

/etc/fstab

?
 
Old 08-26-2003, 12:53 PM   #14
wasabi
Member
 
Registered: Aug 2003
Location: Charlotte, NC
Distribution: Fedora Core 3?
Posts: 95

Original Poster
Rep: Reputation: 15
ok i got ya there

however

when I do this I get a blank window

I already have a wrong line in there I need to remove...
 
Old 08-26-2003, 12:55 PM   #15
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
So when you try to open /etc/fstab with kedit you get a blank window?

How did you get the fstab entry before which you posted?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Reading files with Fedora FC4 from XP[ntfs] itz2000 Fedora 4 08-24-2005 05:11 AM
reading ntfs files on fedora 3 lorry_driver Linux - Newbie 5 02-23-2005 05:17 AM
Reading from RAID 0 SATA NTFS Drive fizgigtiznalkie Linux - Hardware 5 08-29-2004 04:18 PM
reading ntfs files from external hard drive seedsgrow Linux - Hardware 1 05-01-2004 01:59 AM
Reading NTFS 2nd Hard Drive shwabob Linux - Hardware 1 06-09-2003 06:10 PM


All times are GMT -5. The time now is 06:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration