LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 02-24-2004, 08:38 PM   #1
subsys
LQ Newbie
 
Registered: Feb 2004
Posts: 11

Rep: Reputation: 0
random lock ups in mandrake 9.2


im getting a lot of random lock ups under mdk 9.2, they do seem to be totally random, it doesnt matter what im doing occasionally the system just stops working.

mouse curser is frozen i get a high pitched wine (at very high volume) if im using xmms or MPlayer at the time. num lock key still makes the light go on and off (the old acid hardware or software lock test, dont know if it applys to linux or just doze ) but the caps lock key does nothing.

the only way if found of getting the system back is to hit the reset button, ive tryed leaving it for up to an hour but nothing happens, i expect this sort of thing from win9x but i kinda thought nix was stable

does anyone know of a possible source for this problem or a way to get out of it other than a hard reset?

i wondered if it was possibly to do with exceeding memory/swap or perhaps the sata controller going tits up but i really havnt got a clue and any help or sugestions of possibilitys would really be appreciated.
 
Old 02-25-2004, 03:57 PM   #2
Redeye2
Member
 
Registered: Feb 2004
Posts: 489

Rep: Reputation: Disabled
Same thing happening to me here, and true, I expected that from Win9x... anyway, if anybody knows a way to helps us
I hope they fix it in mandrake 10.
 
Old 02-25-2004, 04:46 PM   #3
rokka
Member
 
Registered: Feb 2004
Location: .se
Distribution: Ubuntu, debian
Posts: 124

Rep: Reputation: 15
Just a wild guess - Could this be a hardware problem rather than a software problem? The reason I'm asking is that the only complete freezes that I've ever got in -any- os was due to either bad memory or over heating.

If not you could always take a note of the time of the crash and, after a reboot, check out /var/log/syslog and see if there is anything strange in there.
 
Old 02-25-2004, 05:05 PM   #4
subsys
LQ Newbie
 
Registered: Feb 2004
Posts: 11

Original Poster
Rep: Reputation: 0
could be but all of my hardware is suported by 9.2 without modification (apart from the mouse which needed some tweeking to get all the buttons to work). Also the systems arnt similar at all (other than ram ammount but 512mb is the standard minimum so you have to expect that ) so its not a specific hardware problem. still trying to find the problem atm but the fact that XP works without any issuses is keeping me out of nix atm, i can get more done in doze simply because it never crashes

it is definatly not heat, my temps sit around the 40c (processor) and 28c (system) at full load.
 
Old 02-25-2004, 05:15 PM   #5
subsys
LQ Newbie
 
Registered: Feb 2004
Posts: 11

Original Poster
Rep: Reputation: 0
sorry for the multiple posts but, scrub the mdk supports all my hardware bit from prev post

*eats some humble pie*

this line was in the syslog at the time of one of the locks

Feb 25 01:39:22 localhost kernel: hde: sata_error = 0x00000000, watchdog = 0, siimage_mmio_ide_dma_test_irq

anyone know what the hell that means? other than its a problem with my sata controller

the controller has my maxtor sata drive and my IBM deskstar on it, the ibm is an ide drive connected using an Abit SERILLEL2. the ibm is hde btw not the sata drive, i would swap it to an ide controller but i dont have a channel spare

edit : edited for spelling

Last edited by subsys; 02-25-2004 at 05:39 PM.
 
Old 02-25-2004, 11:18 PM   #6
subsys
LQ Newbie
 
Registered: Feb 2004
Posts: 11

Original Poster
Rep: Reputation: 0
now offically a tripple post but nm, this might help the other guy.

this seems to be a problem with mounted ntfs drives (in my case anyway) it would seem that mdk has a problem talking to my ntfs drives.

i have unmounted my two ntfs drives, havnt had a crash since i did that (had two between prev post and then).

if this does turn out to be the problem i will edit the fsab so that supermount doesnt touch them, hopefully that should sort it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random XWindows lock ups b0mb3r Slackware 7 05-25-2005 06:04 PM
Cedega + Warcraft equals random lock-ups zenith_zth Linux - Games 1 03-24-2005 12:11 PM
HELP! Q3 ( quake 3 ) random lock-ups... FatButtLarry Linux - Games 3 10-27-2004 07:44 PM
Random Lock ups syphr1ogic Linux - General 2 10-01-2003 03:54 PM
Random Lock ups during installation bkeating Linux - General 1 06-09-2002 05:45 PM


All times are GMT -5. The time now is 09:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration