LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   Problems with mandrake 10.1 CE a and Nvidia GeForce mx 440-se (http://www.linuxquestions.org/questions/mandriva-30/problems-with-mandrake-10-1-ce-a-and-nvidia-geforce-mx-440-se-242209/)

genghiskhano 10-13-2004 12:04 PM

Problems with mandrake 10.1 CE a and Nvidia GeForce mx 440-se
 
Hello,
I've been trying to install my Nvidia GeForce mx 440-se for the past three days after I installed Mandrake 10.1 CE worked fine except that whenever I restart or shutdown I get this flashing white squares and the computer never turns off so I thought installing the latest drives for nvidia would solve at least the flashing white squares problem.
When I tried to install the driver I get error "unable to build the nvidia driver module"
if I do sh NVIDIA-linux-x86-1.0-6111pkg1.run --add-this-kernel I get error "unable to load a preconpiled interface for the running kernel" . I don't know what I'm doing wrong maybe I need to uninstall the driver that madrake install for my card and the install them but I don't know how to do this :newbie:

this is what I've done so far:
install the kernel source
I typed urpmi kernel and it said "everything already installed" then I typed urpmi kernel-source and again it said "everything already installed" .When I checked the kernel version with uname -a I get this:
Linux localhost 2.6.8.1-10mdk #1 Wed Sep 8 17:00:52 CEST 2004 i686 AMD Athlon(tm) XP 2600+ unknown GNU/Linux.
I don't have an XF86Config-4 what I do I have is file:/etc/X11/XF86Config which is here :

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "/usr/X11R6/lib/modules/extensions/libglx.so"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "Dell D1226H"
HorizSync 30-95
VertRefresh 50-160

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# Dell D800 and few Inspiron (16/10) 1280x800
ModeLine "1280x800" 147.89 1280 1376 1512 1744 800 801 804 848

# Dell D800 and few Inspiron (16/10) 1680x1050
ModeLine "1680x1050" 214.51 1680 1800 1984 2288 1050 1051 1054 1103

# Dell D800 and few Inspiron (16/10) 1920x1200
ModeLine "1920x1200" 230 1920 1936 2096 2528 1200 1201 1204 1250 +HSync +VSync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corp."
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "DPMS"
Option "IgnoreEDID" "1"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection


and this is my Xorg.conf:


File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "/usr/X11R6/lib/modules/extensions/libglx.so"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "Dell D1226H"
HorizSync 30-95
VertRefresh 50-160

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# Dell D800 and few Inspiron (16/10) 1280x800
ModeLine "1280x800" 147.89 1280 1376 1512 1744 800 801 804 848

# Dell D800 and few Inspiron (16/10) 1680x1050
ModeLine "1680x1050" 214.51 1680 1800 1984 2288 1050 1051 1054 1103

# Dell D800 and few Inspiron (16/10) 1920x1200
ModeLine "1920x1200" 230 1920 1936 2096 2528 1200 1201 1204 1250 +HSync +VSync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corp."
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "DPMS"
Option "IgnoreEDID" "1"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection



thank you for your help

TheOracle 11-06-2004 01:03 AM

Hi

The same goes for me only this is my 1st installation of Linux...

Mandrake 10.1
Toshiba Portege M200
Nvidia gforce

I am trying to install:
graphics driver
Gnokii infra-red / nokia 5140 modem. This is my piority as i switch to windows each time
a snag is encountered which is often
USB stick (this i managed last night)

I don't believe the "Everything is installed" story.
The same as I do not believe the machine is "checking for new hardware" when it hangs at startup...

When checking for (kernel) files under /usr/src/ there are no files. I came to this conclusion when
ls -R
returned only directories.

So now I'm down to checking...
uname -a
urpmi -a kernal
urpmi kernel-source

Anyway, please let me know what I'm doing incorrect.
TheOracle


All times are GMT -5. The time now is 04:25 AM.