LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices



Reply
 
Search this Thread
Old 11-26-2003, 07:25 PM   #1
hfinger
LQ Newbie
 
Registered: Jul 2003
Location: Melbourne, Australia
Distribution: Mandrake 9.2
Posts: 14

Rep: Reputation: 0
Angry OpenOffice.org will not launch


I cannot start OpenOffice.org applications from the K menu. An entry appears in the task bar and the pointer becomes busy. Then, after a few moments, the task bar entry disappears and ... nothing.

I recently installed an application that came as several .tar.gz archives that had to be unpacked into specific directories. So that it would appear in $PATH and be available to all users, I created a symbolic link in /usr/bin:

# ln -s /opt/appInstall/bin/startApp startApp

Then, in a moment of stupidity, I executed

# chmod go-rw a+x startApp

on the just-created symbolic link.

The result:

AS ROOT

/usr/bin/startApp // no permission error
/opt/appInstall/bin/startApp // app starts

AS USER

/usr/bin/startApp // no permission error
/opt/appInstall/bin/startApp // no permission error

So what am I doing wrong. I may have to delete the sym link and reinstall unless there is an obvious mistake someone can spot.


Platform: Dell Optiplex GX260, Pentium 4 @ 2.4 GHz, 512 Mb RAM, Mandrake 9.1, KDE

Keywords: apps application applications program programs won't not start starting launch launching open opening hang on abort menu terminal command line
Code:
    # ln -s /opt/appInstall/bin/startApp startApp
Code:
Code:
    # chmod go-rw a+x startApp
Code:
Code:
    # ln -s /opt/appInstall/bin/startApp startApp
 
Old 11-27-2003, 04:02 AM   #2
scott_R
Member
 
Registered: Jul 2003
Location: Brighton, Michigan, USA
Distribution: Lots of distros in the past, now Linux Mint
Posts: 746

Rep: Reputation: 31
remove the link (rm -rf /usr/bin/startApp) That should remove that problem, but it might help to check the permissions on the original file (ls -l /dir/filename). chmod o is almost always a bad idea, no matter the situation. As you're going to delete the link, no biggy.

As for your execution problem with SO, are you running the staroffice program, or are you trying to run the "setup" as a user. I know it says staroffice in the menu, but you might want to try 'main menu--office--wordprocessors" (this is through gnome). That should give you the text editor and so on. SO isn't so much a "suite" as a group of linked programs, much like MS Office. In other words, you run the program, not start up a group and run the program from the group.
 
Old 11-30-2003, 05:47 PM   #3
hfinger
LQ Newbie
 
Registered: Jul 2003
Location: Melbourne, Australia
Distribution: Mandrake 9.2
Posts: 14

Original Poster
Rep: Reputation: 0
Using (symbolic?) links to start apps [was 'OpenOffice.org will not launch']

I did not emphasize clearly enough that I had TWO apparently related problems.

(1) I could not start OpenOffice.org Write, Calc, or anything else from either the command line or menu as a user but I could as root.

(2) I had installed another program supplied as a set of .tar.gz archives that had to be unpacked into various designated directories.

That said, I noticed that on MDK Linux it seems to be the rule that, rather than adding <app>/bin/ directories to $PATH, you add a symbolic link to the app startup script or executable to the /usr/bin directory. Since this is always in $PATH executing a command in any directory calls the symlink that calls the 'real' executable.

Since you wrote, I have discovered that symlinks always have lrwxrwxrwx permissions and executing chmod on them has no effect but MAY (in circumstances I can't fathom) affect the target file.

I the case of (1) OOo, the oowrite file in /user/bin is a symlink to the OOo executable. In the case of (2), I created the /usr/bin/startApp symlink to the startApp in the /usr/lib/App/bin; it turns out that the target startApp is itself a symlink to a .wrapper executable bash script that starts the app in earnest.

I have since read that OOo is not installed properly with the MDK 9.1 installation package and that you have to install it yourself in a two-step process:

(a) install OOo as root into its /usr/lib/whatever installation folder, then
(b) as user run setup to install prefs files, etc. in the /home/user directory.

Will try this and report back what happens. But this still won't explain I can't run case (2) as user when installed into /usr/lib/App -- only when installed into /home/user/lib/App.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenOffice 2.0 is very slow to launch tongliu8 Linux - Software 24 12-24-2010 01:13 PM
OpenOffice.org QuickStarter - installed it... how do I launch it? Stevetgn Linux - Software 4 09-28-2005 01:22 PM
OpenOffice.org big_syner Linux - Software 3 10-20-2004 02:52 AM
OpenOffice.org will not launch / start up hfinger Mandriva 2 09-15-2004 01:01 AM
Can't launch OpenOffice after installing graphic card bcarl314 Linux - Hardware 3 09-25-2003 06:27 AM


All times are GMT -5. The time now is 11:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration