LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 05-30-2004, 06:22 AM   #1
pugsley
Member
 
Registered: May 2004
Location: Brisbane Australia
Distribution: SUSE10.1
Posts: 46

Rep: Reputation: 15
Nvidia drivers causes corrupt display on shutdown


Hi
Installed the latest Nvidia drivers on 10.0 OK. Found that on shutdown that display was corrupted - also when screensaver blanked out display. Any ideas?

Pug
 
Old 05-30-2004, 06:36 AM   #2
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
what do you mean by corrupted? could you please post the following............

name of video card
which nvidia drivers you used (ia32, ia64, amd64, etc)
contents of your /etc/x11/xf86conf-4

otis
 
Old 05-30-2004, 06:55 AM   #3
ahh
Member
 
Registered: May 2004
Location: UK
Distribution: Gentoo
Posts: 293

Rep: Reputation: 31
I had a problem with nvidia drivers as well. Try adding the line

vga=normal

to your bootloader configuration. It worked for me!
 
Old 05-30-2004, 07:02 AM   #4
pugsley
Member
 
Registered: May 2004
Location: Brisbane Australia
Distribution: SUSE10.1
Posts: 46

Original Poster
Rep: Reputation: 15
By corrupted I mean that the display look out of sync - Like a text display running at a screwed up refresh rate. I think that when X shuts down during main shutdown that video card stays in a graphic mode.

The card is a Nvidia Gforce MX440 clone.

I download the latest Ndiai driver with 2.6 support 53.36.

X config file contents

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us_intl"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "Acer 54es"
HorizSync 31.0-54.0
VertRefresh 50.0-110.0

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

- appreciate an help - more a pain than anything - although the wakeup from screensaver sleep is a problem.

pug

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection
 
Old 05-30-2004, 07:37 AM   #5
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
try adding this line in the device section, directly under where it says Device "nvidia"

Option "NvAGP" "1"

restart X, or reboot.

that option will allow you to use nvidia's agp module. other options you could try would be change the "1" to one of the following

"0" (this disables agp support)
"2" (this uses the kernel agp module)
"3" (this will try to use the kernel module first, then if that fails it will try to use the nvidia module)

you also might want to look into your refresh rate settings? what is it currently set at? if it's set to high (even though your monitor may say it supports the setting) it can cause troubles. i find 70Hz suits my needs, but that's just me. your milage may vary.

otis
 
Old 05-30-2004, 09:13 AM   #6
HeyMull
LQ Newbie
 
Registered: Apr 2004
Location: Noo Yawk
Distribution: Linux Mint Debian 201109
Posts: 9

Rep: Reputation: 0
There is a known bug with Mandrake 10.0 "official" and NVIDIA video drivers. Try using 10.0 "download version" or the earlier release "Community download". They both work OK with my Nvidia FX5200 128 MB (AGP 8x).

10.0 Official CD set (cost me $70) was not able to successfully work with my video card, no matter what. The problem is the Official kernel 2.6.3-7mdk - at least that's what NVIDIA's install told me. On the other hand, a visitor to Mandrake Club says that the problem is in the XF86Config-4 file, and he offers a workaround. I have not tried that yet.

Hope this helps.

http://www.mandrakeclub.com << have a look

------------
5/1/2005: I found out that my motherboard was the cause of most of my problems with Mandrake, etc. It was a SOYO SY-K7MMP2, and I replaced it with a Giga-Byte GA-7N400-L. The motherboard was the ONLY thing I replaced so it was definetly the culprit.

Last edited by HeyMull; 05-01-2005 at 07:02 PM.
 
Old 06-13-2004, 12:06 AM   #7
pugsley
Member
 
Registered: May 2004
Location: Brisbane Australia
Distribution: SUSE10.1
Posts: 46

Original Poster
Rep: Reputation: 15
I found a solution at NV site

This is my new XF86Config-4 file for the device section:


Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "DPMS"
Option "IgnoreDisplayDevices" "DFP, TV"

The last option was suggested to fix the problem - works OK

Cheers
 
Old 07-05-2004, 09:38 PM   #8
pugsley
Member
 
Registered: May 2004
Location: Brisbane Australia
Distribution: SUSE10.1
Posts: 46

Original Poster
Rep: Reputation: 15
Tried the Option "IgnoreDisplayDevices" "DFP, TV" mod and it worked OK but occasionally X would lockup. In the end found that setting VGA= normal in LILO worked.

Thanks for the comments and help.

dave
 
Old 07-08-2004, 10:57 PM   #9
RMSe17
Member
 
Registered: Jul 2004
Posts: 31

Rep: Reputation: 15
Have same problem with Knoppix 3.4, when shutting down, display gets all screwed up, dots and lines instead of text..
On Dell Inspiron 8600 nVidia 5200FX Go
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia Drivers Working till Shutdown JayCnrs Linux - Laptop and Netbook 8 07-22-2005 02:19 PM
NVidia display drivers charnel Linux - Hardware 5 03-17-2005 10:07 PM
NVidia graphics drivers -> system crash on shutdown MiP Linux - Software 1 10-30-2004 06:39 PM
Installed nvidia drivers.. now screen looks like a meltdown on shutdown. guitarnix Linux - Hardware 0 11-19-2003 04:02 AM
NVIDIA Display drivers removal Frankablu Linux - Hardware 3 01-26-2003 04:28 PM


All times are GMT -5. The time now is 04:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration