LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 03-08-2005, 12:47 PM   #1
Jaqflash
LQ Newbie
 
Registered: Mar 2005
Location: Coventry UK
Distribution: Free Mandrake 10.1
Posts: 2

Rep: Reputation: 0
Not Enough File Handles


Probably a silly question, but I'm over my head and sinking fast.

I've installed Mandrake 10.1 Free edition on my PC and I'm trying to set a larger amount of open file handles.

It's defaulted to 1024, but this is not enough for me, I'm greedy.

I had some advice so I set a line in my limits.conf

* hard nofile 4096

but this seems to have had no effect. Is there something that I'm missing?

I also tried logging in and typing

ulimit -n 4096

this seems to work for that console session, but not for the whole system. My machine boots straight into KDE and auto logs in if that makes a difference.

I've looked in the pam.d folder and there are many files there, but most seem to refer to

session required pam_stack.so service=system-auth

and in system-auth is the following line

session required pam_limits.so

Help please?
 
Old 03-08-2005, 01:22 PM   #2
drj000
Member
 
Registered: Sep 2004
Location: Hagerstown, MD
Distribution: Ubuntu Natty Narwahl
Posts: 258

Rep: Reputation: 31
Re: Not Enough File Handles

Quote:
Originally posted by Jaqflash
I also tried logging in and typing

ulimit -n 4096

this seems to work for that console session, but not for the whole system.
I don't know anything about this, but I had one thought. Have you tried adding ulimit -n 4096 to a startup script? That may do it.
I'm not sure where they would be in Mandrake, though. I've never used it.
 
Old 03-08-2005, 03:05 PM   #3
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
If you want to use ulimit -n, you'll have to add it to /etc/profile, or change the existing entry there.
 
Old 03-08-2005, 05:27 PM   #4
Jaqflash
LQ Newbie
 
Registered: Mar 2005
Location: Coventry UK
Distribution: Free Mandrake 10.1
Posts: 2

Original Poster
Rep: Reputation: 0
All hail the amazing.

Thanks to DrJ for the Solution and thanks to OpJose for explaining where to put it, all is now much better in the land of my Mandrake.

I'm sure there should be a setting I can change somewhere to make it default, but as this works fine, I'm not going to argue.

Once again, thanks folks.
 
Old 03-08-2005, 05:30 PM   #5
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
/etc/profile makes it the default for any "session" so this encompasses anything which runs as a seperate process, user, login, job, etc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Open file handles - identifying locks KimVette Linux - General 2 09-24-2005 11:50 AM
Obtaining USB handles dynamically Glemu Programming 1 08-16-2005 12:55 PM
Remove Handles from Gnome Panel paco36 Linux - Software 2 01-26-2005 07:46 PM
how netfilter handles fragmented packets??? cranium2004 Linux - Networking 1 11-21-2004 12:47 PM
What system handles ACPi best out of the box? AhYup Linux - Laptop and Netbook 2 07-28-2004 04:02 AM


All times are GMT -5. The time now is 04:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration