LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   No Sound from Audigy card on 10.2 (http://www.linuxquestions.org/questions/mandriva-30/no-sound-from-audigy-card-on-10-2-a-367265/)

dbc001 09-26-2005 03:35 PM

No Sound from Audigy card on 10.2
 
I've just installed mandriva 2005 from DVD, I had the previous version installed before. Anyway I have no error messages but my sound card no longer works. It worked fine with the last version.

Mandrake Control Center says:

Vendor: ‎Creative Labs
Description: ‎SB0400 Audigy2 Value
...
Driver
Module: ‎snd-emu10k1
Alternative drivers: ‎audigy, emu10k1


Here's the relevant info from 'cat /proc/pci' :
Bus 0, device 12, function 0:
Class 0401: PCI device 1102:0008 (rev 0).
IRQ 5.
Master Capable. Latency=32. Min Gnt=2.Max Lat=20.
I/O at 0xb400 [0xb43f].


cat /etc/modprobe.conf
# This file is autogenerated from /etc/modules.conf using generate-modprobe.confcommand

alias eth0 tg3
remove snd-emu10k1 /sbin/modprobe -r snd-pcm-oss; /sbin/modprobe --first-time -r--ignore-remove snd-emu10k1
install snd-emu10k1 /sbin/modprobe --first-time --ignore-install snd-emu10k1 && { /sbin/modprobe snd-pcm-oss; /bin/true; }
install scsi_hostadapter /sbin/modprobe sata_promise; /bin/true
install usb-interface /sbin/modprobe uhci-hcd; /sbin/modprobe ehci-hcd; /bin/true
alias eth1 eth1394
alias ieee1394-controller ohci1394
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.8 ---
options snd device_mode=0666
alias sound-slot-0 snd-emu10k1
# --- END: Generated by ALSACONF, do not edit. ---

alias snd-0 snd-emu10k1


I have no idea how to troubleshoot this, would appreciate any help! Thanks!

SlackerLX 09-27-2005 08:03 AM

$ /sbin/lsmod | grep snd

See what it spits.

dbc001 09-27-2005 07:53 PM

Here goes (and thanks in advance):

Code:

snd-seq-dummy          2596  0
snd-seq-oss            31584  0
snd-seq-midi-event      6208  1 snd-seq-oss
snd-seq                47472  5 snd-seq-dummy,snd-seq-oss,snd-seq-midi-event
snd-pcm-oss            49056  0
snd-mixer-oss          17248  1 snd-pcm-oss
snd-emu10k1          109092  3
snd-rawmidi            19648  1 snd-emu10k1
snd-seq-device          6796  5 snd-seq-dummy,snd-seq-oss,snd-seq,snd-emu10k1,snd-rawmidi
snd-ac97-codec        75256  1 snd-emu10k1
snd-pcm                80776  4 snd-pcm-oss,snd-emu10k1,snd-ac97-codec
snd-timer              20324  3 snd-seq,snd-emu10k1,snd-pcm
snd-page-alloc          7588  2 snd-emu10k1,snd-pcm
snd-util-mem            3264  1 snd-emu10k1
snd-hwdep              6880  1 snd-emu10k1
snd                    46980  16 snd-seq-oss,snd-seq,snd-pcm-oss,snd-mixer-oss,snd-emu10k1,snd-rawmidi,snd-seq-device,snd-ac97-codec,snd-pcm,snd-timer,snd-hwdep
soundcore              7104  1 snd


SlackerLX 09-27-2005 10:27 PM

In this case do the following:
Open console=>
If you want to set your sound perfectly (in case of 5.1) then do this one:
$ su -
# alsamixer
Configure bars with arrows, enable or disable service with "m" key.
wave, wave center, wave surround, center, surround, PCM=> All the way UP
AC97=> Down, down, down. and stay down
ALL LFE=> Down, down, down. and stay down
Master=> 75% Up (check if it's ON)
When done ESC
#alsactl store
Logout
Login
P.S. If you have 5.1 speaker system, be sure that LFE channels bars are all way down and [off]. LFE channel is to generate 5.1 emulation matrix on 4 speaker systems.
;)

After running this command (alsactl store) your custom swill be stored in alsa configuration and restarted automaticly every reboot.

Tormented 09-28-2005 08:42 AM

Quote:

Originally posted by SlackerLX
LFE channel is to generate 5.1 emulation matrix on 4 speaker systems.

This is incorrect. LFE stands for "Low Frequency Effects" and is the channel that controls your subwoofer.
On a 5.1 system only turn this off if you don't want any bass at all.

SlackerLX 09-28-2005 09:39 AM

Quote:

Originally posted by Tormented
This is incorrect. LFE stands for "Low Frequency Effects" and is the channel that controls your subwoofer.
On a 5.1 system only turn this off if you don't want any bass at all.

It's correct according to Asus E1292 User's Manual
(sorry can't support the scan of it s)

dbc001 09-28-2005 08:42 PM

In alsamixer, there are only a few levels that aren't about 75%:
Looks like the problem was the IEC Optical Raw (It was Off). Thanks for all the help though!

So to recap, I wasted lots of time but I should have just tried everything in alsamixer I guess... anyway thanks again!


All times are GMT -5. The time now is 07:07 AM.