LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 03-20-2005, 02:55 PM   #1
A_Linux_Newbie
LQ Newbie
 
Registered: Mar 2005
Posts: 3

Rep: Reputation: 0
Question No shut down option


I'm a total Linux newbie, so I'm trying to get my head around somrthing other that Windows. I've installed Mandrake 10.1 on my spare machine, but there's no option for shut down - just log off.

What am I missing?
 
Old 03-20-2005, 03:11 PM   #2
Thoreau
Senior Member
 
Registered: May 2003
Location: /var/log/cabin
Distribution: All
Posts: 1,167

Rep: Reputation: 45
By default users can't shutdown the machine. You have to be root, unless you give users permission to do so. At command as a user, type "su". Enter the root password. shutdown -h now(shuts it down). shutodwn -r now(reboots).
 
Old 03-20-2005, 04:34 PM   #3
Lakota
Member
 
Registered: Oct 2003
Location: London, ON, Canada
Distribution: Mandriva 2007 Free
Posts: 507

Rep: Reputation: 30
my mandrake default installs always allow everybody to shutdown, others like Slack only allow root by default.

If you use kde, to enable anyone to shutdown simply click on your menu>system>configuration>Kde>system>login manager
select the "shutdown" tab and in the "allow shutdown" box, change it from root to everybody.

the command "halt" will do the same as "shutdown -h now" if you are lazy at typing like me.
 
Old 03-21-2005, 03:15 AM   #4
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
I believe that the differences are due to the initial security level selected during the installation.
 
Old 03-21-2005, 04:08 AM   #5
Lakota
Member
 
Registered: Oct 2003
Location: London, ON, Canada
Distribution: Mandriva 2007 Free
Posts: 507

Rep: Reputation: 30
That would make some sense Opjose, I always leave security level at "standard" for my installs of Mandrake.
http://www.linuxloader.com/modules.p...&pid=18&page=4
In that case, if it is simply a home pc we are talking about, maybe better solution would be changing to "standard" on the "basic" tab of "levels and checks" window in the "Mandrake Control Center". I will assume if security setting is higher than need be user acct's may loose permission for mounting devices etc.
 
Old 03-21-2005, 03:17 PM   #6
A_Linux_Newbie
LQ Newbie
 
Registered: Mar 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks, now another one

Thanks everyone - the shut down is available now, however....

When KDE starts, I don't have any mouse movement. I have to use the keyboard to get into 'Configure your computer', enter the root password, go onto Hardware, then mouse. KDE always sets my mouse to 'Universal - Any PS/2 & USB mice'. I have to change this to 'PS/2 - Standard', then logoff / logon and the mouse works. (It's a bog standard PS/2 mouse by the way).

If this was Windows, I'd say Plug and play is messing up - what's Linux / Mandrake / KDE doing, and more importantly - how do I stop it?

Thanks in advance
 
Old 03-21-2005, 04:04 PM   #7
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Look in /etc/sysconfig

Usually the problem is that the /etc/X11/XF86Config file and the files in /etc/sysconfig do not point to the same devices.

/etc/sysconfig determines the machine's initial settings at startup.
 
Old 03-23-2005, 03:23 PM   #8
A_Linux_Newbie
LQ Newbie
 
Registered: Mar 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Question Mouse probs

Right, I've had a look at the 2 files, but I'm none the wiser. Here's the contents...

The file /etc/sysconfig/mouse has the following lines:-

MOUSETYPE=ps/2
XMOUSETYPE=PS/2
FULLNAME='"PS/2|STANDARD"'
XEMU3=yes
WHEEL=no
device=psaux

the file /etc/X11/XF86Config has the following lines:-

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/mouse"
Option "Emulate3Buttons"
Option "Emulate3Timeout" "50"
EndSection

Any clues?
 
Old 03-23-2005, 04:05 PM   #9
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Type

ls -l /dev/mouse

And post the results...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
lost shut down option overproof Mandriva 3 11-14-2005 03:58 PM
RH9, Sony Vaio, Want 'Sleep' option (not full shut down) monke Linux - Laptop and Netbook 2 11-15-2004 08:00 AM
shut down won't shut system down taoweijia Linux - General 3 03-03-2004 06:05 PM
Gnome log out option only, no shut down hindenbergbaby Linux - Software 4 10-29-2003 08:27 PM
Give users the option to shut down in Gnome's logout oot Linux - General 4 05-12-2003 06:15 PM


All times are GMT -5. The time now is 09:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration