LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 10-12-2008, 11:02 AM   #1
dickgregory
Member
 
Registered: Oct 2002
Location: Houston
Distribution: Arch, PCLinuxOS, Mint
Posts: 257

Rep: Reputation: 34
NFS entries in /etc/fstab fail to mount on bootup in Mandriva 2009


I did a clean install this morning. I have 2 nfs shared folders on my server box. I copied the fstab entries from a Mandriva 2008 box. When I boot up, they are not mounted. When I do "mount -a", they mount ok.

This is my wife's computer. She is techie illiterate, and just uses the computer for stuff like web browsing. I have her set up with a directory on the server that I have trained her to save her stuff to. I do not want her to have to go through CLI process every time.

Here is my fstab
Code:
# Entry for /dev/sda1 :
UUID=06786758-d020-41aa-9005-b4cc72cd6957 / ext3 relatime 1 1
# Entry for /dev/sda8 :
UUID=9c88e1f6-bb8c-402d-9649-345db1233410 /home ext3 relatime 1 2
none /proc proc defaults 0 0
# Entry for /dev/sda6 :
UUID=7734d16e-807a-4067-8e11-e5c0711c70ab /usr ext3 relatime 1 2
# Entry for /dev/sda7 :
UUID=46d7e142-ca73-4b1e-afd6-1cffccf21b3d /var ext3 relatime 1 2
# Entry for /dev/sda5 :
UUID=4c43ce5c-be5a-430c-ba3e-205afc051819 swap swap defaults 0 0
192.168.3.11:/home/files /files nfs rsize=8192,wsize=8192,nosuid 0 0
192.168.3.11:/var/www /www nfs rsize=8192,wsize=8192,nosuid 0 0
Can someone point me to what I need to know to get this to work?

Thank you
 
Old 10-14-2008, 10:21 AM   #2
jkerr82508
Member
 
Registered: Dec 2006
Location: Fife, Scotland
Posts: 245

Rep: Reputation: 65
I haven't experienced this myself, but I suppose that it's possible that the system is trying to mount the shares before the network connection is fully established. A couple of work-arounds that may be worth trying:

1. Add the nopinit boot option in menu.lst (this will slow down the boot process a little)

or

2. Add the noauto option to the fstab entries, and put the mount commands in /etc/rc.d/rc.local

Jim
 
Old 10-14-2008, 06:36 PM   #3
dickgregory
Member
 
Registered: Oct 2002
Location: Houston
Distribution: Arch, PCLinuxOS, Mint
Posts: 257

Original Poster
Rep: Reputation: 34
Thanks Jim

It appears that you were right that it was trying to mount before networking was fully started. I inserted "sleep 1" as the first line in the start section of the netfs script, and now it comes up normally. My computer is not really fast (1.8GHz) so I'm suprised some faster folks haven't run into this.
 
Old 10-14-2008, 07:11 PM   #4
jkerr82508
Member
 
Registered: Dec 2006
Location: Fife, Scotland
Posts: 245

Rep: Reputation: 65
Now that you've mentioned "sleep", I think I recall seeing a report somewhere from someone who did have the same problem and "sleep" was the solution that they used.

Jim
 
Old 10-14-2008, 07:48 PM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
There is also the _netdev mount option which defers mounting network shares until the network is ready.

If you also use "noauto", then then need to be mounted later. The command "sudo mount -a -o _netdev" will mount all of the shares with the _netdev option.

If you also use the "user" option and the directory being shared is owned by a particular user, there could be a line in the users .profile (or .bash_profile or .bash_login) script to mount the share. You might want to do this if you want to keep /home/<username>/Documents or some similar share mounted when a user logs in.

There are often several ways of doing things.

Last edited by jschiwal; 10-14-2008 at 07:53 PM.
 
Old 10-16-2008, 08:14 AM   #6
courtrrb
Member
 
Registered: Sep 2003
Location: Iowa, US
Distribution: MDK Since V6.5
Posts: 569

Rep: Reputation: 30
I ran into this back with 2008.0 thats when I made the switch to auto-mount. Because the system wouldn't mount the other systems until needed

Setting up auto-mount is really easy and prevented a lot of problems.

When my wife system would shut down my system locked up.
By changing to auto-mount my system no longer locks up because of the nfs share went missing. If you need a quick tutorial I can help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS entries in /etc/fstab not mounting on boot jwolter0 Linux - Server 11 02-27-2012 01:28 PM
YIKES ! fstab on Mandriva 2009 RC1 !! explorer Mandriva 9 09-08-2008 09:47 PM
Network fstab entries don't mount at boot tisource Linux - Networking 7 12-29-2005 06:54 PM
fail to mount nfs fs... tekion Linux - Networking 5 04-05-2005 08:40 PM
fail to mount nfs fs... tekion Linux - Networking 1 04-01-2005 07:40 AM


All times are GMT -5. The time now is 10:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration