LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-20-2005, 06:11 AM   #1
gamito
LQ Newbie
 
Registered: Aug 2003
Posts: 2

Rep: Reputation: 0
Mandriva LE 2005 hangs on boot up


Hi,

I've just installed Mandriva LE 2005 in my laptop - an HP Omnibook XE3.

I've never had problems with Mandrake since i own this laptop.

Now, Mandriva starts, but it hangs just after a few (a dozen or so) boot line messages.

No error, no nothing. I can't give you any aditional info
Just hangs.

Has anyone around here had this problem (whatever the machine) ?

Any help would be apreciated.

Warm Regards,
Mário Gamito
 
Old 04-21-2005, 03:21 AM   #2
dominik81
Member
 
Registered: Sep 2003
Location: Germany
Distribution: Ubuntu 7.10
Posts: 54

Rep: Reputation: 15
I'm having the same problem. I hangs right after "activating swap partitions" here. On my box the digital TV card (Twinhan VisionDTV) is causing the problem. When I take this card out, Mandriva boots just fine. This probably won't apply to you but I've read bits an pieces about hotplug detecting my card wrongly thus hanging the system. Other Linux distros with the 2.6.11 kernel, like Knoppix don't work either though.
 
Old 04-21-2005, 07:10 AM   #3
dexter11
Member
 
Registered: Apr 2005
Distribution: Mandriva
Posts: 197

Rep: Reputation: 30
Quote:
Originally posted by dominik81
I'm having the same problem. I hangs right after "activating swap partitions" here. On my box the digital TV card (Twinhan VisionDTV) is causing the problem. When I take this card out, Mandriva boots just fine. This probably won't apply to you but I've read bits an pieces about hotplug detecting my card wrongly thus hanging the system. Other Linux distros with the 2.6.11 kernel, like Knoppix don't work either though.
If this is the cause then you can boot in to failsafe mode, which skips most hardware detection, and select not to start hotpluging in the mcc (system tab services icon I think).
 
Old 04-21-2005, 07:12 AM   #4
dexter11
Member
 
Registered: Apr 2005
Distribution: Mandriva
Posts: 197

Rep: Reputation: 30
Re: Mandriva LE 2005 hangs on boot up

Quote:
Originally posted by gamito
Hi,

I've just installed Mandriva LE 2005 in my laptop - an HP Omnibook XE3.

I've never had problems with Mandrake since i own this laptop.

Now, Mandriva starts, but it hangs just after a few (a dozen or so) boot line messages.

No error, no nothing. I can't give you any aditional info
Just hangs.

Has anyone around here had this problem (whatever the machine) ?

Any help would be apreciated.

Warm Regards,
Mário Gamito
Which is the last bootline message?
 
Old 05-12-2005, 05:36 AM   #5
jrg
LQ Newbie
 
Registered: Apr 2004
Location: London, UK
Distribution: Mandriva 2006
Posts: 9

Rep: Reputation: 0
I'm having what sounds like the same problem: I've upgraded from Mandrake 10.1 to Mandriva LE2005 (although the boot message says Mandrake 10.2 :-) and although the installation went without a hitch, during bootup it hangs after reporting that ALSA 1.0.6 has been successfully started. That's it.

Booting into failsafe and looking at /var/log/messages just shows the success of ALSA starting up and nothing more.

I can boot with the previous kernel (2.6.3); it seems to be the default 2.6.8 kernel (2.6.8.1-12mdk?) that's grinding to a halt. But I get odd problems using the 2.6.3 kernel (JPEG previews in Nautilus don't work for example).

I've got to rebuild the kernel to try to get it working with Bluetooth anyway, so I'll see what happens....
 
Old 05-13-2005, 03:47 AM   #6
jrg
LQ Newbie
 
Registered: Apr 2004
Location: London, UK
Distribution: Mandriva 2006
Posts: 9

Rep: Reputation: 0
Okay, now I'm confused. Although after the installation the 2.6.8 kernel was the default, there's a 2.6.11 kernel lurking there too! So I tried that, and it got as far as the login screen, before hanging after I'd entered my password.

After a bit of fiddling around in tty1 I discovered that /dev/null was permissioned "rw-rw----" ! I fixed that and now I can log in, but there are several odd things going on:

1. No terminals work :-( They all give an error something like "couldn't start child process"
2. I can't use the Mandrake control centre because after asking for the root password it says it can't find su - but this is only in KDE; it works in Gnome
3. I can run zsh inside XEmacs, but can't su because "stdin is not attached to a tty". $PATH looks fine.

I think that my next step is a full installation instead of just an upgrade. Here's where I find out whether or not my backups are any good...
 
Old 05-13-2005, 12:57 PM   #7
webterractive
Member
 
Registered: Apr 2004
Location: Richmond, Canada
Distribution: Mandriva 2006/XPSP2
Posts: 265

Rep: Reputation: 30
yeah the 2.6.8 kernel will halt at alsa it happend to me because i used the 10.1 mini-install to intall 2005, the solution is to go failsafe, and urpmi kernel 2.6.11 its the only way, or other use drakxservices and check off alsa. after don't forget to edit your /etc/lilo.conf and then change the linux= to the 2.6.11 image and initrd or else you will just have 2.6.8 again. After making the changes make sure you type in lilo -t and lilo -t to make it official.

Last edited by webterractive; 05-13-2005 at 12:59 PM.
 
Old 05-17-2005, 08:50 AM   #8
jrg
LQ Newbie
 
Registered: Apr 2004
Location: London, UK
Distribution: Mandriva 2006
Posts: 9

Rep: Reputation: 0
Thanks webterractive.

At about the time you were posting that, I was doing a full installation ;-)

I was using grub up until this upgrade, for reasons I can't fully remember but probably because I'm using hdc3 as the root partition due to an existing Windows installation. The installation process set up LILO and it's working. I need to clean up my partitioning....

Mandriva LE2005 is at least booting correctly now. I haven't had a chance to check everything, but once Samba is set up and I've recompiled my WinModem driver I'll be all set.

I think that the konsole and gnome-terminal problems related to having installed the neep-alt font set for 10.1, and it going missing during LE2005 installation.
 
Old 05-18-2005, 09:09 AM   #9
UBERSKiB
LQ Newbie
 
Registered: May 2005
Location: Melbourne, Australia
Distribution: Suse 9.1 & Mandriva 2005 LE
Posts: 8

Rep: Reputation: 0
I have the same problem. Installed my VisionPlus DTV TV Tuner today, and sure enough Mandrake hangs after activating swap partitions. Even in failsafe boot.

Is there a fix? I'm unable to remove the card, but can one change settings immediately after the install?
 
Old 05-21-2005, 01:19 AM   #10
raysr
Member
 
Registered: Nov 2003
Location: WA State
Distribution: Ubuntu 13.04
Posts: 723

Rep: Reputation: 31
Angry

WTF is the deal with Mandrake above 9.2 and the boot issue? I tried 2 sets of discs on 2 different drives and 10.1 hung on boot. I just ordered a Mandriva LE2005 hoping to escape this problem. I used 9.2 for 2 years and it always booted flawlessly. If Mandriva 2005 hangs I'm gonna just..........well, you know!
 
Old 05-28-2005, 04:24 AM   #11
jaagut
LQ Newbie
 
Registered: May 2005
Posts: 2

Rep: Reputation: 0
same problem here.

just download LE2005 3 iso images. md5sums are all ok.

but booting hangs up. it just show the boot splash screen and nothing then.
could you please teach me what to do? i'm a newbie here.

tks n advance.
 
Old 05-28-2005, 05:45 AM   #12
dominedi
LQ Newbie
 
Registered: Mar 2005
Location: italy
Distribution: mandrake 10
Posts: 26

Rep: Reputation: 15
I think that we should merge those discussions :

Not booting with TV card (LE 2005)
http://www.linuxquestions.org/questi...hreadid=314192

Hang after enabling swap space
http://www.linuxquestions.org/questi...hreadid=186192
 
Old 05-28-2005, 04:37 PM   #13
webterractive
Member
 
Registered: Apr 2004
Location: Richmond, Canada
Distribution: Mandriva 2006/XPSP2
Posts: 265

Rep: Reputation: 30
WTF

I don't get what you guys are posting about. I have installed Mandriva LE2005 from a 10.1 Mini-install CD, and I have had no boot problems. Why don't you guys post what the hell the message says, and then your setup. Ie. kernel, hardware, and running services. Heres something to keep in mind: FOR MANDRIVA MAKE SURE THAT YOU ARE USING THE 2.6.10+ KERNEL. IF YOU USE THE 2.6.8 ONE IT WILL HANG ON ALSA. IF THAT HAPPENS MAKE SURE YOU ENTER THE INTERACTIVE MODE AND DON'T LOAD ALSA OR USE THE FAILSAFE AND USE URPMI TO INSTALL THE NEWER KERNEL. I INSTALLED MANDRIVA 2005 ON A PII 350MHZ MACHINE, AND I HAD NO PROBLEMS WITH BOOTING EXECPT FOR THAT TIME AFTER I FORGOT TO UPDATE THE KERNEL BEFORE REBOOTIING. OTHER THEN THAT IT WAS SLOW, BUT WHAT YOU DO YOU EXPECT FROM A 350MHZ PII? THOUGH THE DESKTOP WAS VERY GOOD.
 
Old 05-28-2005, 04:49 PM   #14
dominedi
LQ Newbie
 
Registered: Mar 2005
Location: italy
Distribution: mandrake 10
Posts: 26

Rep: Reputation: 15
Because you didn't got any problems this doesn't mean other had some.

I got mandriva working at the first instal on a laptop.
but not lucky enough to make boot at all a pc with a pinnacle pctv sat card in it
 
Old 05-29-2005, 02:01 AM   #15
UBERSKiB
LQ Newbie
 
Registered: May 2005
Location: Melbourne, Australia
Distribution: Suse 9.1 & Mandriva 2005 LE
Posts: 8

Rep: Reputation: 0
Re: WTF

Quote:
Originally posted by webterractive
I don't get what you guys are posting about. I have installed Mandriva LE2005 from a 10.1 Mini-install CD, and I have had no boot problems. Why don't you guys post what the hell the message says, and then your setup. Ie. kernel, hardware, and running services. Heres something to keep in mind: FOR MANDRIVA MAKE SURE THAT YOU ARE USING THE 2.6.10+ KERNEL. IF YOU USE THE 2.6.8 ONE IT WILL HANG ON ALSA. IF THAT HAPPENS MAKE SURE YOU ENTER THE INTERACTIVE MODE AND DON'T LOAD ALSA OR USE THE FAILSAFE AND USE URPMI TO INSTALL THE NEWER KERNEL. I INSTALLED MANDRIVA 2005 ON A PII 350MHZ MACHINE, AND I HAD NO PROBLEMS WITH BOOTING EXECPT FOR THAT TIME AFTER I FORGOT TO UPDATE THE KERNEL BEFORE REBOOTIING. OTHER THEN THAT IT WAS SLOW, BUT WHAT YOU DO YOU EXPECT FROM A 350MHZ PII? THOUGH THE DESKTOP WAS VERY GOOD.
Why don't you look at the people actually posting the cry's for help. Most of us are newbies. I have no idea how to tell you what running services I have.

I know for myself the kernel 2.6.10 or 2.6.11 or what ever the standard is with 2005 LE has a bug up it's arse about some DTV Tuner Cards. Failsafe startup for me doesn't even work, still locks up at the same place (after activating swap partitions).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandriva 2005 LE Boot Install Problems Jbernoski Mandriva 2 10-24-2005 01:17 PM
Mandriva LE 2005 hangs on install on Laptop 1kyle Mandriva 2 09-14-2005 02:38 AM
mandriva le 2005 boot tty1 chil326 Mandriva 5 08-11-2005 01:05 PM
Mandriva 2005 freezing at boot Imerion Linux - Software 0 05-04-2005 09:32 AM
Mandriva LE 2005 hangs on startup after upgrade ragnar86 Mandriva 1 04-23-2005 10:40 PM


All times are GMT -5. The time now is 08:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration