LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   Mandriva Flash, KDE desktop - problem getting removable media icons to appear . (http://www.linuxquestions.org/questions/mandriva-30/mandriva-flash-kde-desktop-problem-getting-removable-media-icons-to-appear-594489/)

WSCC 10-25-2007 08:21 AM

Mandriva Flash, KDE desktop - problem getting removable media icons to appear .
 
This problem relates to Mandriva Flash.
Double clicking My Computer on the desktop fails to show icons for either the floppy drive or the EIDE Iomega Zip drive. Going to Control Panel > Hardware and clicking the button "Look at and configure the hardware" the Zip drive is shown as detected (as hdd4) but the floppy drive is not listed at all.
By doing various things at the command line and in Control Panel I can get both devices to appear as icons in My Computer, and can mount/unmount them from there, but they disappear again at shut down and do not reappear at the subsequent re-boot. If it will help, I can supply details of what I have to do to get the icons into My Computer, but what I really need to know is why they are not there in the first place and how to keep them there permanently.
I would be grateful for suggestions. Lines for the two devices are present in /etc/fstab and seem to be correct, the devices fd0 and fdd4 are present in the /dev directory, and the mount points /media/floppy and /mnt/zip do exist.

{BBI}Nexus{BBI} 10-26-2007 11:58 PM

I don't know if the Mandriva-Flash operates the same as a regular Mandriva install, but you should be able to right click your desktop and select Configure Desktop then go to Behaviour then put a checkmark in Show icons on desktop then select the Device Icons tab and put a checkmark in Show device icons. You can then uncheck the devices that you don't want to appear on your desktop.

Another way is to add the Storage Device applet to your panel, then all devices like usb-sticks, drives and mounted cd/dvd roms will appear in the panel. You can then left click on them and choose safely remove (or eject for cd/dvd's) when you're done using them. To choose what devices appear in the panel, just right click on any device and click configure. I hope this helps.

WSCC 10-29-2007 12:20 AM

Removable media icons in KDE
 
Thanks for the suggestion, which I tried. When I got to the Show Device Icons dialogue window, most of the boxes were already ticked, including mounted floppy, unmounted floppy, mounted removable medium, unmounted removable medium, and mounted Zip disk. (There doesn't seem to be a check box for unmounted Zip disk.) But despite the boxes being ticked, icons for the floppy and the Zip are still absent from the desktop, nor do they appear when I double click the Devices icon on the desktop. I can get the floppy icon to show up by doing the following: System > Configure your computer > (Enter password) > Linux Control Centre > Mount Points > Set Where Your Floppy Disk is Mounted. This puts the floppy ikon on the Desktop and also in the window produced by double clicking the Devices icon. But it stays there only for that session - I have to go through the whole procedure again at the next bootup. Furthermore, this doesn't work for the Zip disk. Going to "Set Where your Zip Disk is Mounted" produces the error message "The file or folder media:/hdd4 does not exist". It's not wrong - I can find a folder "media" but not a folder "media:". I don't know the significance of the colon. Getting removable media to appear on the desktop was a lot easier than this in Mandrake 8.1 which I used to use some years ago!


All times are GMT -5. The time now is 05:30 AM.