LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 10-09-2005, 03:45 PM   #1
crxssi
Member
 
Registered: Apr 2005
Location: USA
Distribution: Mageia
Posts: 84

Rep: Reputation: 15
Mandriva 2006.0 Clock Drift


There is some kind of problem in Mandriva Linux 2006.0 that causes my software clock to run very fast.... it is gaining over two minutes every hour.

This is the first time I have run 2006.0 64bit SMP on this machine, previously I had LE 2005 (10.2) 32bit SMP running on it and there was no clock drift. Thus far, everything else seems to be running smoothly.

Asus A8N-SLI Deluxe, Athlon 64 X2 4200+, 1GB RAM, SCSI 2940, IDE, NVidia FX

2.6.12-12mdksmp #1 SMP Fri Sep 9 17:20:34 CEST 2005 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ unknown GNU/Linux

I cannot post a bug on bugzilla because there is no 2006.0 product listed. I cannot post the information on forums because the club forum page is not available. I did email it to qa@mandriva.com
 
Old 10-10-2005, 11:33 AM   #2
sshoemaker
LQ Newbie
 
Registered: Aug 2005
Location: Pennsylvania
Distribution: FC4
Posts: 14

Rep: Reputation: 0
clock drift

Have you tried running ntp as a daemon or ntpdate? these will update your clock with a timeserver (be sure to find one of the round-robin dns time servers so that no single time server is overloaded).
In your ntp configuration file just put the following:
driftfile /var/lib/ntp/ntp.drift

server 0.pool.ntp.org
server 1.pool.ntp.org
server 2.pool.ntp.org

that will allow their dns to rotate through different time servers --helping to conserve bandwidth.

You can also update it manually by using ntpdate pool.ntp.org -- and you can run this in a cron job such as

0 * * * * (ntpdate pool.ntp.org)

You can configure these to run as often as needed (just beware that transaction processing programs such as Oracle do not like time shifts -- if you insert something at a date that is "before" the current time, it will mess it up).
 
Old 10-10-2005, 05:21 PM   #3
crxssi
Member
 
Registered: Apr 2005
Location: USA
Distribution: Mageia
Posts: 84

Original Poster
Rep: Reputation: 15
Yes, I am (was) already running ntpd. The sw clock is so fast that ntpd will not keep it updated; besides- that doesn't fix the problem, just put a bandage on it. Since it is a home system, the time jumps aren't critical so...

For now I just put this in crontab:

0 6 * * * /sbin/clock --hctosys ; /usr/sbin/ntpdate pool.ntp.org ; /sbin/clock --systohc
15,45 * * * * /sbin/clock --hctosys

Which is working reasonably well until the reason is found for the clock running so fast.
 
Old 10-13-2005, 12:02 AM   #4
troyrock
LQ Newbie
 
Registered: Oct 2005
Location: SoCal
Posts: 3

Rep: Reputation: 0
Same problem here

I am also running Mandriva 2006 SMP on an AMD 65 X2 with exactly the same problem. When I come home in the evening, it's off by about 30 min from when I left in the morning.
 
Old 10-13-2005, 06:33 AM   #5
crxssi
Member
 
Registered: Apr 2005
Location: USA
Distribution: Mageia
Posts: 84

Original Poster
Rep: Reputation: 15
Well, it is nice to know that it is repeatable. Thanks for posting.
 
Old 10-13-2005, 07:37 AM   #6
sshoemaker
LQ Newbie
 
Registered: Aug 2005
Location: Pennsylvania
Distribution: FC4
Posts: 14

Rep: Reputation: 0
clock drift

sound like there's an issue with the internal clock in the cpu. does the time go way off if your computer is off?? -- in that there's an issue with the motherboards' time keeping.
 
Old 10-13-2005, 04:58 PM   #7
crxssi
Member
 
Registered: Apr 2005
Location: USA
Distribution: Mageia
Posts: 84

Original Poster
Rep: Reputation: 15
Taken from my original posting: There is some kind of problem in Mandriva Linux 2006.0 that causes my software clock to run very fast

It is the software clock. There is nothing wrong with the RTC. And there was nothing wrong with the software clock in 10.2. Has to be something going strange in the kernel.
 
Old 10-15-2005, 08:28 AM   #8
crxssi
Member
 
Registered: Apr 2005
Location: USA
Distribution: Mageia
Posts: 84

Original Poster
Rep: Reputation: 15
troyrock: Someone on Mandriva bugzilla has also reported it, so that is three systems now. http://qa.mandriva.com/show_bug.cgi?id=19250

It is important that you please provide the exact harware you are using- motherboard brand/model and graphics card type/model. Thanks!
 
Old 10-21-2005, 09:16 PM   #9
crxssi
Member
 
Registered: Apr 2005
Location: USA
Distribution: Mageia
Posts: 84

Original Poster
Rep: Reputation: 15
It gets worse. I don't know if this is part of the same bug or not, but now, every day when I get home from work to use this home computer the keyboard stutters badly and I have to restart the Xserver to regain control. About every other key I press results in anywhere from 2 to 12 of that key being sent. Ug.
 
Old 10-22-2005, 09:33 AM   #10
crxssi
Member
 
Registered: Apr 2005
Location: USA
Distribution: Mageia
Posts: 84

Original Poster
Rep: Reputation: 15
Solution!

It *is* a problem in the kernel and it is documented here: http://bugzilla.kernel.org/show_bug.cgi?id=5105 It took forever for me to stumble across the answer. I have cross posted it to qa.mandriva

This is the summary based on my research and observations.... there is a problem in the 2.6.12 kernel that causes the kernel to make an incorrect assumption about the type/use of the clocks on an AMD 64 X2 dual core system. The problems it causes seems amplified by high/continuous CPU usage. You can tell if you are bitten because you will see one or more of three symptoms:

1) Your software clock will run too fast- gaining sometimes minutes per hour
2) At some point the keyrepeat under X will go haywire and cause keyboard stuttering
3) You will see messages like this "warning: many lost ticks." in /var/log/messages

The workaround is to boot the kernel with the "notsc" option. This will force the kernel to not use tsc. There is a patch to the kernel, also, that supposedly fixed the problem properly. When it makes it into the official tree, I don't know.

This is a serious enough kernel problem to warrant Mandriva posting Errata about the issue, since it will affect [probably] all people using 2006.0 with an AMD X2 processor and possibly issusing a new 64 bit kernel. Of course, this will affect all distributions, since it is a kernel issue.
 
Old 10-22-2005, 09:40 AM   #11
chemdawg
Member
 
Registered: Jan 2005
Distribution: Mandriva
Posts: 206

Rep: Reputation: 30
Quote:
Originally posted by crxssi
This is a serious enough kernel problem to warrant Mandriva posting Errata about the issue, since it will affect [probably] all people using 2006.0 with an AMD X2 processor and possibly issusing a new 64 bit kernel. Of course, this will affect all distributions, since it is a kernel issue.
I was using 2006 and noticed this problem with my 3.0GHz x86 processor, so it may be more widespread than just AMD and 64 bit kernel. Mine gained about 2 minutes per day, give or take a few nanoseconds!
 
Old 11-06-2005, 12:41 AM   #12
purelithium
Member
 
Registered: Oct 2005
Location: Canada
Distribution: Mandriva 2006.0
Posts: 390

Rep: Reputation: 30
From the Bugzilla bug report comment thread:

Quote:
The workaround is to boot the kernel with the "notsc" option. This will force
the kernel to not use tsc. There is a patch to the kernel, also, that
supposedly fixed the problem properly. When it makes it into the official
tree, I don't know.
So therre's the workaround, but I'm not sure where to input this option.
 
Old 11-09-2005, 08:57 AM   #13
jeanmm
LQ Newbie
 
Registered: Nov 2005
Location: France - Versailles
Distribution: Mandriva 2007
Posts: 24

Rep: Reputation: 15
Hello,

I found several cases with the same problem. Try to add following options to the kernel at startup : "noapic nolapic". Mandriva's doc warns not to use apic and lapic if the PC is not a multi-processor.

You may modify these options for lilo or grub to make them permanent.


 
Old 11-22-2005, 05:12 AM   #14
DataFusions
LQ Newbie
 
Registered: Nov 2005
Posts: 2

Rep: Reputation: 0
Hello,

I seem to be having the same problem but with an AMD Sempron 3000+
The time is flying past almost at double speed... other than that everything seems fine. (except he keyboard struttering but easily fixed by slowing the repeat rate)

I tried the 'notsc' option but that changed nothing..

What were the other options again
 
Old 11-22-2005, 05:55 AM   #15
DataFusions
LQ Newbie
 
Registered: Nov 2005
Posts: 2

Rep: Reputation: 0
Seemed to have fixed it by using apic and lapic...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandriva 10.1 or Mandriva 2006 RC1 ronlon Mandriva 17 04-17-2006 02:24 AM
Clock Drift with Gnome Battery Applet? Matir Linux - Software 1 09-09-2005 02:56 PM
Multiple questions - System clock drift, e17 Emericanadian Linux - General 1 08-25-2005 11:23 PM
How to fix severe clock drift in FC3? rylan76 Linux - Software 1 07-03-2005 11:37 AM
Clock Drift, Any Ideas ? audie Linux - General 5 04-30-2004 03:35 AM


All times are GMT -5. The time now is 12:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration