LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 03-16-2004, 08:47 AM   #1
dancro
LQ Newbie
 
Registered: Oct 2003
Location: Carlsbad, California
Distribution: Ubuntu 8.04 server: mythbuntu 8.04
Posts: 15

Rep: Reputation: 0
Smile Mandrake 9.2 does not turn off power at shutdown


I just installed Mandrake 9.2 using download CD version and it went in flawlessly, recognized my LAN and cable modem and connected to web without incident. Very impressed. It also recognized my Promise ATA 100 controller and 80GB drive, much to my delight.

However, this little nit has arisen, Logged in as user with Gnome and when I shut down, the PC does not get powered off. I hear something in the box shut off, maybe hard drive, but power does not go off.

When I run Windoze 2K, shut down does power off the PC.

Can anyone suggest anything?

Thank you in advance for your help or suggestions.
Dan
 
Old 03-16-2004, 08:55 AM   #2
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Enable power management: APM or ACPI. You can check if APM is supported on your computer and/or supported in the kernel by running 'apmd'. At most you will have to recompile your kernel, but Mandrake probably has APM or ACPI in a kernel module someplace, eliminating the need for that.
 
Old 03-16-2004, 10:13 AM   #3
kyrian
LQ Newbie
 
Registered: Feb 2004
Location: CA, USA
Distribution: Mandrake
Posts: 8

Rep: Reputation: 0
yup, power management.
however, as long as your shutdown actually cuts power to everything, its ok to turn off the computer once it finishes its shutdown routine. my laptop won't work with 9.2's power management anymore, at all, so i shutdown in the terminal and then hit the power button when i am done.
shutdown -h now
has to be done as root tho. easier to avoid than deal with, methinks.
 
Old 03-16-2004, 10:42 AM   #4
soloist
LQ Newbie
 
Registered: Jul 2003
Distribution: RH9 MDK9.2+10.0
Posts: 24

Rep: Reputation: 15
I had a similar problem in MDK 9.2 and 10.0 Community.
Mine was fixed in 10.0 by selecting a checkbox for ACPI somewhere in the Mandrake Control Center (boot?).
But I think the ability to do that so easily might relate to kernel 2.6 being "plug and play" (PnP) whereas 2.4 is not. Which is to say, this option might not be available in 9.2 which has 2.4 kernel. Take the advice of others on how to activate ACPI in 9.2; I have no experience with that.

Best of luck.
 
Old 03-16-2004, 10:46 AM   #5
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Quote:
Mine was fixed in 10.0 by selecting a checkbox for ACPI somewhere in the Mandrake Control Center (boot?).
Enable acpi w/ drakboot in Control Center.
 
Old 03-16-2004, 05:11 PM   #6
dancro
LQ Newbie
 
Registered: Oct 2003
Location: Carlsbad, California
Distribution: Ubuntu 8.04 server: mythbuntu 8.04
Posts: 15

Original Poster
Rep: Reputation: 0
Smile

Thank you all for your responses. Indeed, I did find Enable APCI in the boot section of Mandrake Control and clicked it.

Alas, it made no difference.

At a prompt I typed apmd and got back command not found. So I SU'd and tried again and got back
It appears that an instance of apmd is already running as process 1812.
If in reality no instance of apmd is running, remove /var/run/apmd.pid.

I looked at installed software and could not find a listing for apm, so I suppose it is present as another name or as part of something else. But it is apparently there, and running.

Any other ideas?

Thanks again for your help.
Dan
 
Old 03-16-2004, 06:15 PM   #7
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Run 'ps -A', and look for apmd. If it is not running, then remove the file.
 
Old 03-16-2004, 07:44 PM   #8
dancro
LQ Newbie
 
Registered: Oct 2003
Location: Carlsbad, California
Distribution: Ubuntu 8.04 server: mythbuntu 8.04
Posts: 15

Original Poster
Rep: Reputation: 0
aaa,
Ran ps -A and found apmd 1808 ? 00:00:00 apmd
( I have shutdown since the last time I looked)
 
Old 03-17-2004, 08:03 AM   #9
dancro
LQ Newbie
 
Registered: Oct 2003
Location: Carlsbad, California
Distribution: Ubuntu 8.04 server: mythbuntu 8.04
Posts: 15

Original Poster
Rep: Reputation: 0
Another update. In setup, I set Plug n Play to NO, it made no difference, so I set it back on. Then I set Power Management to DISABLED, and it also had no effect.

Thanks again for your help.
Dan
 
Old 03-17-2004, 11:08 AM   #10
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
You your computer appears to not use ACPI. Since apmd is running, your computer uses it and it is enabled in the kernel.
See these:
esp. this: http://www.togaware.com/linux/survivor/APM_Power.html
http://tuxmobil.org/apm_linux.html

To try out the lilo.conf settings, you can type them in manually before you boot, before permanenetly putting the setting in lilo.conf . Remember, to apply changes in lilo.conf you have to run 'lilo'.
 
Old 03-18-2004, 08:03 PM   #11
dancro
LQ Newbie
 
Registered: Oct 2003
Location: Carlsbad, California
Distribution: Ubuntu 8.04 server: mythbuntu 8.04
Posts: 15

Original Poster
Rep: Reputation: 0
Problem solved.

I checked out the links you suggested. TuxMobile told me about command dmesg which I ran as root and learned that ACPI was disabled because my BIOS was from 1999, and that I could enable it with acpi=force.

Added acpi=force to the lilo configuration using control center/DrakBoot/configure lilo/grub mode to add it in the append field to the values already there.

And now shutdown powers off the machine. All is good.

Thanks again for all your support, you led me to find the answer.
Dan

Last edited by dancro; 03-18-2004 at 08:05 PM.
 
Old 03-19-2004, 03:27 AM   #12
marking
LQ Newbie
 
Registered: Mar 2004
Location: new zealand
Distribution: suse8.2
Posts: 3

Rep: Reputation: 0
I have the same problem with a ECS Notebook laptop I have just bought.
at the end of the shutdown it just hangs.Until I can find out how to fix it I select reboot and when the reboot starts I press the power off switch.
Hope this helps
 
Old 03-19-2004, 07:41 AM   #13
dancro
LQ Newbie
 
Registered: Oct 2003
Location: Carlsbad, California
Distribution: Ubuntu 8.04 server: mythbuntu 8.04
Posts: 15

Original Poster
Rep: Reputation: 0
marking

Two points. First of all, you can choose shut down, and after it has hung for several seconds (maybe 30), it is safe to just push the power switch and shut off the machine. In my case, I could hear the hard drive stop, but the case fan remained on.

Second, if you change your boot by adding acpi=force to the boot command, it may resolve your situation.

I gather from your posting that you are running SuSe with which I am not familiar, but there must be something similar to the Mandrake control center.

Here are some details of my adventure. In my case, the machine is almost six years old (see below for particulars) and the output from running dmesg (see post by aaa for link to tuxmobile) as root in a shell told me that acpi was disabled and could be enabled by adding "acpi=force".

In Mandrake control center, in DrakBoot, in lilo configure there is a place to append this command to the startup string. First I created a new "test" entry and used only that command.

Then on boot I selected my "test" boot and it came up with some error messages about devices being removed, which I ignored. (These devices were apparently handled by some other appended commands that are present in my default boot, but not in my "test" boot).

Anyway, the system shut down completely when I logged off so I added the acpi=force to the already existing commands in my default boot and now everything is cool, and the machine shuts down, clean and complete.

Hardware: Dell Dimension XPS R450 (Pentium II 450 Mhz) upgraded to a Pentium III Slot 1, 1Ghz cpu, with a BIOS upgrade when I installed Win2K; 384MB RAM; 80MB Western Digital ATA 100 on a Promise ATA 100 controller; and audio that is not yet working)

Sorry if I rambled on a bit here, but I did want you to know that I have solved the problem with acpi=force.

Dan

Last edited by dancro; 03-19-2004 at 07:44 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Wont turn off automatically marigb Linux - Hardware 5 11-16-2005 09:08 PM
turn off doesn't really turn and power off pcandpc Mandriva 11 05-30-2005 04:22 PM
No power down after shutdown (Mandrake) JohnA Linux - Hardware 14 02-24-2005 02:47 AM
Can not turn off power with Slackware 10 caovankhanhvn Linux - Laptop and Netbook 6 08-13-2004 08:49 PM
Turn on power through network? trees Linux - Networking 6 01-21-2004 02:25 AM


All times are GMT -5. The time now is 06:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration