LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 05-21-2004, 02:55 AM   #1
AngelicCharon
LQ Newbie
 
Registered: May 2004
Posts: 8

Rep: Reputation: 0
Mandrake 10 + VMWare Workstation 4 help!


Okay, yes I'm new to the forums, and yes, I'm relatively new to Linux, so please bear with me....I do appreciate any and all help in advance.

I'm using Mandrake 10, and have the 2.6.3-7 kernel as far as I know. Trying to install VMWare Workstation 4 (might be 4.5), and well...not getting very far. It has no trouble until it gets to the config and wants to put together the VMMON module.

The error starts as the following :
CC [M] /root/tmp/vmware-config3/vmmon-only/common/task.o/
gcc: installation error, cannot exec 'cc1plus'; no such file or directory
make[2]: ***[/root/tmp/vmware-config3/vmmon-only/common/task.o/] error 1
make[1]: ***[/root/tmp/vmware-config3/vmmon-only/common/] error 2
make[1]: leaving directory '/usr/src/linux-2.6.3-7mdk'
make: *** [vmmon.ko] error 2
make: leaving directory '/root/tmp/vmware-config3/vmmon-only/'
Unable to build the vmmon module.

I really have no idea how to fix this so it'll work, so as I said earlier, any and all help would be greatly appreciated. Thanks in advance.
 
Old 05-21-2004, 03:03 AM   #2
Redeye2
Member
 
Registered: Feb 2004
Posts: 489

Rep: Reputation: Disabled
It seems like you don't have the gcc compiler installed. Go to Install Software and install it.
 
Old 05-21-2004, 06:06 AM   #3
Ajarn
Member
 
Registered: Aug 2003
Location: Thailand
Distribution: Mandiva2005
Posts: 86

Rep: Reputation: 15
Hi,
It is all well to say, just install it.
Can you please tell us which packages excactly ?
When I tried, it told me it is 103 Mb alltogether
and that is no fun on a 56K dialup

Install 100Mb for getting a 5Mb package to work
 
Old 05-21-2004, 03:18 PM   #4
AngelicCharon
LQ Newbie
 
Registered: May 2004
Posts: 8

Original Poster
Rep: Reputation: 0
I have the GCC compiler installed actually....in fact, had compiled a few programs and drivers without trouble, unless there's a specific software/module I need to have installed, like the C++ module for GCC...or some such.
For instance...I had no trouble compiling and installing the NVIDIA driver...so, anywho, looking forward to further assistance.
 
Old 09-17-2004, 03:45 PM   #5
totalbender
LQ Newbie
 
Registered: Sep 2004
Posts: 1

Rep: Reputation: 0
It installed ok for me, but it will not run. The error message is:

/usr/lib/vmware/bin/vmware: relocation error: /usr/lib/gdk-pixbuf/loaders/libpixbufloader-xpm.so: undefined symbol: g_try_malloc

kernel: 2.6.3.7
mandrake 10
nvidia video card
 
Old 09-17-2004, 04:08 PM   #6
Comrade_SpuD
LQ Newbie
 
Registered: Sep 2004
Location: England. Where there's Gold, and Lasers!
Distribution: Mandrake 10
Posts: 2

Rep: Reputation: 0
Mine's bettter! :p

My error's better!

"Kernel Panic: No Init Found. Try passing init= option to kernel"

I've only just this evening started on Linux. I'm a complete newbie to it. Raised on Windows, I'm afraid :/

I went for mandrake on a couple of recommendations, and the sire propaganda

It's probably something I haven't installed right.

I run one 40Gb HDD for Linux, and one 80Gb for Win XP. the Mandrake drive is partitioned with 3 partitions, done in the mandrake 10 installer. One 10Gb swap partition, one 10gb (maroon/burgundy, sorry, forgot the real name, gah) partition, and one red 17gb partition. I'm useless with remembering names, but colours are simple. Bit of a pain really. I tried booting from all available options (from the Mandrage GUI - linux, linux smp, linux nonfb, 2425-2 smp, 263-7, 2425-2, failsafe) only to get the same error. Apart from in failsafe, where I got "Kernel Panic: VFS: Unable to mount root fs on hdb5"

Anyone got any ideas? It would be a help. I posted it here, as I'd feel guilty about starting a new topic on something that's probably really obvious. And I'm strange
 
Old 09-17-2004, 04:16 PM   #7
eqxro
Member
 
Registered: Apr 2004
Location: Outer space :D
Distribution: Gentoo 2005.0 amd64 2.6.14-dfx3
Posts: 203

Rep: Reputation: 30
What filesystem did you install on? I got this error too when i installed my MDK on a reiserfs partition. Before the panic, did you get errors like Cannot mount root partition, and the ext3 driver returning errors a few lines before?
 
Old 09-17-2004, 04:21 PM   #8
Comrade_SpuD
LQ Newbie
 
Registered: Sep 2004
Location: England. Where there's Gold, and Lasers!
Distribution: Mandrake 10
Posts: 2

Rep: Reputation: 0
Filesystem?

EDIT:

Wahey, I made it work, with the power of obvious!

Bleh.

Last edited by Comrade_SpuD; 09-18-2004 at 08:20 AM.
 
Old 09-18-2004, 01:37 AM   #9
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,025

Rep: Reputation: 34
Re: Mandrake 10 + VMWare Workstation 4 help!

I am at a loss for where you are at. I assume you installed the RPM package version of VmWare, did you configure it inside your Konsole first?

d-1













Quote:
Originally posted by AngelicCharon
Okay, yes I'm new to the forums, and yes, I'm relatively new to Linux, so please bear with me....I do appreciate any and all help in advance.

I'm using Mandrake 10, and have the 2.6.3-7 kernel as far as I know. Trying to install VMWare Workstation 4 (might be 4.5), and well...not getting very far. It has no trouble until it gets to the config and wants to put together the VMMON module.

The error starts as the following :
CC [M] /root/tmp/vmware-config3/vmmon-only/common/task.o/
gcc: installation error, cannot exec 'cc1plus'; no such file or directory
make[2]: ***[/root/tmp/vmware-config3/vmmon-only/common/task.o/] error 1
make[1]: ***[/root/tmp/vmware-config3/vmmon-only/common/] error 2
make[1]: leaving directory '/usr/src/linux-2.6.3-7mdk'
make: *** [vmmon.ko] error 2
make: leaving directory '/root/tmp/vmware-config3/vmmon-only/'
Unable to build the vmmon module.

I really have no idea how to fix this so it'll work, so as I said earlier, any and all help would be greatly appreciated. Thanks in advance.
 
Old 05-08-2005, 07:15 AM   #10
manf0001
LQ Newbie
 
Registered: Nov 2004
Location: Canada
Posts: 15

Rep: Reputation: 0
Hey I would suggest upgrading to VMWare Workstation 5. Version 4 /4.5 is not supported very well on Mandrake 10.

When I used ver 4 on 10.1 everytime I rebooted the computer and launched Vmware the Reg code would dissapear and all the Virtual Machines also dissappear.

Ver 5 is designed for Mandrake 10 and is much better and the set up is very simple as well not hard at all. and your VM machines won't dissappear.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vmware workstation 4.5.1 install on linux mandrake soft 10 problem joes17 Linux - Software 3 07-09-2004 08:38 PM
Mandrake 10 error in VMWare Workstation Tryxl Linux - Software 1 03-23-2004 10:28 AM
VMware Workstation and rehat 9 TheShadow Linux - Hardware 9 09-18-2003 08:35 AM
vmware workstation zetsui Linux - Software 2 07-01-2003 10:59 PM
Using VMWare 3.0 Workstation asb12973 Linux - General 2 06-08-2002 01:05 AM


All times are GMT -5. The time now is 09:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration