LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 06-16-2004, 04:08 PM   #1
SafeTechs
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10.0
Posts: 5

Rep: Reputation: 0
Mandrake 10 Internet very slow (<1kb/sec) while windows got 50k/sec


I have installed and reinstalled mandrake 10.0 (public distribution, 3-cd set dl) and each time I have had the exact same problem, this being that the internet would run very slow.
When I launch Konqueror and start to load a site, it will begin loading as high as only 3KB/Sec. It then will progressively drop down to 100b/sec, and then stall. Sometimes at that point, if you wait awhile, it will once again jump to 3kb/sec, and then repeat itself. After a few times, it simply times out.
Although I have not extensively used Mozilla, it did do the same problem when I did use it.
I have researched this and found that I should make sure my DNS servers are present in /etc/resolv.conf and to put the line alias net-pf-10 off in the /etc/modprobe.conf file.
Using Konsole in a root session I have opened the file in emacs (typing sudo emacs modprobe.conf or sudo emacs resolv.conf, after typing cd /etc/ at first) and put those lines in there. It did help, but it didn't fix, the problem. Before entering those lines, I never got nearly as fast a speed, and it took much much longer to resolve the host. However, with or without those lines, it still will take a long time for pages to load, running at the aformentioned speed(s).
Here is what I have is /etc/modprobe.conf:

alias eth0 tulip
alias sound-slot-0 snd-es1938
install snd-es1938 /sbin/modprobe --first-time --ignore-install snd-es1938 && { /sbin/modprobe snd-pcm-oss; /bin/true; }
install usb-interface /sbin/modprobe usb--ohci; /bin/true
remove snd-es1938 {/sbin/modprobe -r snd-pcm-oss; } ; /sbin/modprobe
alias net-pf-10 off

I am having trouble with the DNS servers-it keeps on changing them on me. Still, I should be getting better then a changing speed that is never more then 2k.
Anyway, here is what /etc/resolv.conf reads:

search earthlink.net local

# search earthlink.net earthlink.net earthlink.net earthlink.net

nameserver 127.0.0.1
nameserver 207.69.188.185
nameserver 207.69.188.186
nameserver 172.16.0.254

#

I have opened this up several times as I do not want 127.0.0.1 listed as a name server-the server #1 should be 207.69.188.185 #2 should be what is #3 there and then #3 should be 172.16.0.254-however 127.0.0.1 is one of the servers windows uses, which does make me wonder.....

I get anywhere from 20k/sec to 100k/sec dl and page load speed on windows; on Mandrake I cannot even download anything, as it times out almost immediately (stalls and never comes back)

This occured with both a Netgear FA311TX 10/100 (natsemi driver) and with the current SMC 10/100 (lite-on driver) card. I belive I also tried a Netgear FA310TX which also gave me the same problem.

I have an Earthlink aDSL with a Netopia 3341 UHP modem, hooked into a Linksys BEFSR11 router. There it networks to the hub and to the computers.
On all of the other computers, I get a fast dl speed.
I did have the same problem using DHCP, I have it set up at the moment to a static IP so that I can maintain port forwarding.
I did have a small problem for awhile that the search domain would go to dyndns.org, I presume because I had the hostname set to safetechs.dyndns.org, my dyndns account domain name. Once I manually replaced it with the proper search domain (earthlink.net) using the emacs text editor it would only switch itself back when I reinstalled Madrake.

Thanks for all your help.
 
Old 06-16-2004, 04:57 PM   #2
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
Try adding the following line to your /etc/modprobe.conf file under the last line that starts with "alias":

alias net-pf-10 off

That should disable IPv6 and speed things back up.

save the file, reboot, try to connect. if it does no good (though it should) simply remove the line from that file & reboot again.

post back with results...........

otis
 
Old 06-16-2004, 05:48 PM   #3
SafeTechs
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10.0
Posts: 5

Original Poster
Rep: Reputation: 0
If you read entirely through my post above, I have already done that, and although it seems to help slightly in DNS lookup times (it doesn't take as long to be "resolving server" or whatever it says) the connection still runs at that slow speed.
It did NOT speed up the connection with any of the adapters.
Oh and a small correction on one thing I said earlier-Right now I have the Netgear FA310TX network card (natsemi driver) in the computer, not the SMC.
 
Old 06-16-2004, 06:10 PM   #4
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
sorry for not noticing that in your post. we all space now & then...........

have you gotten all the MDK updates/bug fixes/etc.? there was a problem with 10.0 & connection speeds with the kernel & something in drakxtools, i believe. if you've done that already, then i'll have to pass on this one. no problems here with ADSL & linksys 10/100 eth0.

otis
 
Old 06-17-2004, 08:00 AM   #5
zakoukou
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Rep: Reputation: 0
plz i have installed mandrake 10.0 (3 cd) but it did not detect my bcm v.92 56k modem
can u tell me what shall i do
knowing that iam a stupid newbie
waiting for ur help
 
Old 06-17-2004, 11:12 AM   #6
SafeTechs
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10.0
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by otish1000c
sorry for not noticing that in your post. we all space now & then...........

have you gotten all the MDK updates/bug fixes/etc.? there was a problem with 10.0 & connection speeds with the kernel & something in drakxtools, i believe. if you've done that already, then i'll have to pass on this one. no problems here with ADSL & linksys 10/100 eth0.

otis
No problem. I can't get the MDK updates & bug fixes because the internet times out. Can anyone direct me to somewhere I could download them and burn them to a CD? I downloaded the MDK 3 cds not too long ago (maybe 10 days or so) but I can't get the updates, and the problem does seem to be there if I try and update using the installer as well.
Any simple RPM I can dl anywhere to get the latest patches on?
Thanks
 
Old 06-17-2004, 11:49 AM   #7
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
ok............ to get the updates is gonna be a little round about without direct internet access in MDK10.0. but here's what you can do...........

go here to the Mandrake FTP Mirrors list. choose a mirror that gets the best speed for you. when you find one, navigate the site to get to the ........./distributions/Mandrakelinux/official/updates/10.0/RPMS/ directory. that has all the updates in rpm format. now, if you have a dual boot with a good working internet connection, you can just download the updates to a directory on your harddrvie, then use MCC->software updates & set that directory up as a temporary update source. or, if that scenerio doesn't work, then you'll have to dload them & burn them to CD & then set that CD up as a temporary update source via MCC.

unfortunately, there isn't just one rpm i can suggest as a "magic fix". due to dependency issues, you're best off getting all the updates available. for instance, drakxtools has several depends itself & i can't remember all of them. i think the grand total for all updates is somewhere around 450 megs worth. if it's more than that, it isn't gonna be a whole lot more & they will all still fit on one 700meg CD if necessary.

if you need help with setting up a temporary update source once you choose with method you're using, please post back & i'll guide you through it.

otis
 
Old 06-17-2004, 11:08 PM   #8
SafeTechs
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10.0
Posts: 5

Original Poster
Rep: Reputation: 0
Ok I have dl'd and copied the updates onto the computer, now what?
 
Old 06-18-2004, 07:45 PM   #9
nemoswitch
LQ Newbie
 
Registered: Jun 2004
Posts: 15

Rep: Reputation: 0
hi, well if it is like my ADSL. Then you may have the same problem I had and have. Mandrake seems to set your RWIN way too big for adsl connections. That is your receive window. If it is the same problem I have had here then this may be it. Linux has your RWIN set to 65000+ and this will cause delay or timeout problems. now if your RWIN is set to the amout a dial up should use. YOU will also ping out and have other problems too. slow speeds and so on. Off hand I forget what the command is to see your RWIN. RWIN stands for receive window. Now if it is like I always had mandrake set it as default. then it is at 65000+ I forget the exact number. ADSL. if it is the standard 1.5 down and 512 up connection. Then your RWIN should be at or close to 32575. if not. you will get dropped packets or you will get a huge bottleneck. I have the bottleneck problem. Mandrake 10 seems to tell me when issueing the commands to view the RWIN. it gives me permission denied. so I will have to work around that later. But. if your rwin is too low. you will not connect to the internet well and you will ping out lots. People don't usually talk about RWIN. but I do know that linux has it set too big or too small if not configured right. 32575 is a nice number and works very well. if I get the commands to view the window before you . I will post em. I forget em off hand.
 
Old 06-19-2004, 06:45 AM   #10
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
Quote:
Originally posted by SafeTechs
Ok I have dl'd and copied the updates onto the computer, now what?
before you do what i suggest to install the updates, give what nemoswitch is suggesting a try to solve your original connection problem. i never heard of the rwin trick before, but it might be worth a shot & then the following info will be moot.

to install the updates, you have to set up the download location on your hard drive as a source. to do so, do the following.........

open MCC->software management->software media manager. click "add". choose the "local files" button. give it a name in the "name" box. in the "path" box type.........

file://path/to/your/downloads

(IE: here's what my local rpm source looks like........ file://home/otis/downloads/rpms)

leave the "relative path to synthesis/hdlist" box unchecked & blank

click "ok"

it will now add the source & build the neccessary info for you. when it's done, uncheck all other sources you have listed, leaving only the new local source you have made checked.

click "ok" on the main "configure media" dialogue box.

now, open a terminal as root & type.........

urpmi.update -a (enter)

this will update your sources so it's only going to look at the new source you made. don't worry about "cannot find........" errors pertaining to the sources you unchecked. that's what we want. you can go back a recheck them when you're done with this. when it's done updating, then type........

urpmi --auto --auto-select (enter)

this will tell urpmi to automatically look for anything in your sources directories that is a newer version of what you have installed. if it asks you any questions concerning dependencies, just answer "yes". let it finish. you'll now have all the updates. reboot, then try internet.

to get all your old sources back, go to the same place in MCC & first remove the local update source you made. then, start with your CD sources to add them back. do them one at a time, first inserting the corresponding CD to the CD source, then click "update" so it can re-add the CD sources. when they're done, choose "add" click the "security updates" option, choose a mirror & let it add that. finally, if you have any other sources set up (contribs, cooker, etc.) check them one at a time & update each. click "ok" when done.

please post back with successes or failures.

otis

Last edited by otish1000c; 06-22-2004 at 04:16 AM.
 
Old 06-19-2004, 12:53 PM   #11
nemoswitch
LQ Newbie
 
Registered: Jun 2004
Posts: 15

Rep: Reputation: 0
k, lets see if this will work. It is always worth a try.

Become root or su.
cd into /etc/rc.d
nano, pico, emac, vi. or whatever editor you like to use. Open rc.local

scroll to the bottom of that file. and add below. touch /var/lock/subsys/local

add these lines.

echo 1 > /proc/sys/net/ipv4/tcp_timestamps
echo 1 > /proc/sys/net/ipv4/tcp_window_scaling
echo 1 > /proc/sys/net/ipv4/tcp_sack

echo 8388608 > /proc/sys/net/core/wmem_max
echo 8388608 > /proc/sys/net/core/rmem_max
echo "4096 54419 4194304" > /proc/sys/net/ipv4/tcp_rmem
echo "4096 32575 4194304" > /proc/sys/net/ipv4/tcp_wmem

this works well on the basic adsl. this will give you a RWIN of 39096. 32575 would be better. still 39096 is better then teh default 65536 or what you may have default set. Try it out and post your results

hope it works or helps
 
Old 07-08-2004, 01:31 AM   #12
brabbit
LQ Newbie
 
Registered: Jul 2004
Posts: 12

Rep: Reputation: 0
Mandrake 10 Net Slow

Try adding the following line to your /etc/modprobe.conf file under the last line that starts with "alias":

alias net-pf-10 off

That should disable IPv6 and speed things back up.

save the file, reboot, try to connect. if it does no good (though it should) simply remove the line from that file & reboot again.

post back with results...........

otis




Otis Thank you Worked like a charm!

-brabbit
 
Old 07-14-2004, 04:59 PM   #13
SafeTechs
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10.0
Posts: 5

Original Poster
Rep: Reputation: 0
Ok guys, sorry havn't been messing with the system a whole lot, kinda took a break, but here's the deal.

Still have the problem, added the lines does not help.
I belive that it is automatically detecting the wrong DNS servers, since 127.0.0.1 goes in as the top DNS server, whereas that should not be present. Is there any way to FORCE it to use a particular DNS server? I have edited it out of the resolv.conf (and resolv.conf~) yet it returns upon reboot.
Also, if I connect using the aDSL modem directly and not the router, I cannot even connect to the internet at all (setting up a new connection with DHCP not using same old settings)
WITH the router installed there is little difference over static IP and settings and using DHCP.
Interestingly, computer to computer speeds (if I run built in web sharing on another local network comp) are VERY fast. Figure about 200k/sec.
So here's that fact, proven again:
Other network comp accessed via local ip: 200k/sec dls fast works very well, does not time out
Accessed via dyndns account (internet) exact same file: less then 3k/sec dropping drastically until it times out. (3k, 2k, 1k, 800b, 400b, all the way down to 10b and then timing out)
Both of above though work perfectly fine on Mac OS 9, Mac OS 7, Windows 98SE, and other comps I have here.
What's going on here?!?
 
Old 09-01-2006, 04:07 PM   #14
Gordog
LQ Newbie
 
Registered: Jun 2006
Location: Invercargill, New Zealand
Distribution: Mepis 7.0 i386, Mandriva, Ubuntu 9.04, All windows OS's
Posts: 19

Rep: Reputation: 0
SLow ADSL in Mandriva.

I had exactly the same problem with Mandrake and then with Mandriva. The solution is obviously not easy so I took the easy way out and changed distributions. I now use Mepis 6.0. Although not fault free it is definitely better (in my humble opinion) than any version of Mandrake (I go back to version 8.0) that I have used. The ADSL connection works at full speed and the tools for setting up printing and generally configuring the distribution are excellent. I found these non-intuitive in Mandrake and kept upgrading hoping they would get better. Before Mepis 6.0 I used Mepis 3.4.3 and this was virtually as good as 6.0. 3.4.3 is free to download. I downloaded 6.0 with a one month subscription to http://www.mepis.org/ The whole distribution comes on one CD. Give it a try.
Personally I think the slow ADSL problem in Mandrake is a huge one but after persisitng with it for 5 or so years this problem kept me from migrating from Windows. With Mepis I have crossed over and do all my internet and email from the Linux platform.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows XP box losing connection to Linux box after 30 sec. NeoZeus Linux - Networking 3 07-21-2005 12:02 AM
Windows 98 sec the best? Mannyakatheman General 24 11-19-2003 07:03 PM
CD burner very slow (7kb sec) w/SuSE 8.2 ywoodland Linux - Software 8 08-04-2003 03:56 PM
IP Sec Redhat 9 martini_drinker Linux - Security 2 07-25-2003 02:57 PM
hdparm 64MB in 19.68 sec=3.25 MB/sec illtbagu Linux - General 11 06-26-2003 07:03 PM


All times are GMT -5. The time now is 07:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration