LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 03-02-2005, 01:37 PM   #1
357mag
Member
 
Registered: Feb 2005
Posts: 95

Rep: Reputation: 15
Making a desktop icon work


After doing some monkeying around I've been able to access the contents of my zip drive and my USB drive through the console window. Now what I really want is to put an icon on the desktop representing each drive and so when I click the icon I can graphically view the contents of the zip or USB drive.

Last night after successfully accessing my USB drive by typing mount -t auto /dev/sda /mnt/usb I right clicked on an empty portion of the desktop and chose Create New Device and I chose a hard drive icon. After doing that I went in the Devices Tab and saw this list:

/dev/sda1
/dev/hdc(cdrom)
/dev/hdd(cdrom2)
/dev/fdo(/mnt/floppy)
/dev/hda1(/mnt/win_c)
/dev/sda1(/mnt/win _c2)

Well I chose the /dev/sda1 cuz it seemed the logical choice, but when I tried clicking on the desktop icon I got:

Could not enter folder /mnt/usb

And in the location box at the top of the window it did show file: /mnt/usb. One question I have is why sda1 was listed when I actually typed sda in the mount command. And why would Mandrake refer to my D partition as sda1? I'm assuming that its doing that when I saw the win_c2 there, but I don't know. Also my D partition is not formatted yet, maybe that has something to do with it.

But I don't know how to make the desktop icon work or what went wrong. The whole point of this is to be able to access all my drives by clicking on a desktop icon like in Windows.
 
Old 03-02-2005, 02:59 PM   #2
junme
Member
 
Registered: Oct 2004
Location: ~/.au
Distribution: Mepis Kanotix SUSE
Posts: 189

Rep: Reputation: 31
you should have seen a blank space where you can put what u want
or make an entry in fstab above # Dynamic entries then it will be in the list
 
Old 03-02-2005, 03:33 PM   #3
justintime32
Member
 
Registered: Sep 2004
Distribution: SimplyMepis 3.3 (Debian testing/unstable)
Posts: 123

Rep: Reputation: 15
You mean Konqueror can't enter /mnt/usb?
I would personally create an application link (Right click on desktop > New > File > Link to application), and enter "konqueror /mnt/usb" as the command.
 
Old 03-02-2005, 08:13 PM   #4
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Eh, how about turning on "desktop/devices" in the configuration to enable viewing of unmounted and mounted devices.
 
Old 03-03-2005, 09:11 PM   #5
357mag
Member
 
Registered: Feb 2005
Posts: 95

Original Poster
Rep: Reputation: 15
I tried everybody's suggestion. First I opened the fstab file using the editor KWrite and it merely listed the drives with a bunch of other stuff. There was no line at the top that said "Dynamic Entries". I have seen this line in other Linux distros but it wasn't there in Mandrake. And I really don't know what to type anyway, but I tried typing this:

/dev/sda /usb vfat noauto,rw,user,nosuid,sync

And then tried saving it but another error came up saying "The document could not be saved because it was not possible to write to file:/etc/fstab. Check that you have write access to this file or that enough disk space is available."

Second, I created an application link as you suggested and entered in the command line "konqueror /mnt/usb" and then tried clicking on the icon but got an error message saying "unable to enter file:/mnt/usb. You do not have access rights to this location."

Third I right clicked on the desktop and went into "Configure Desktop" but did not see anything that said "desktop/devices". Did he mean to go somewhere else? He merely said "go in the configuration and turn on desktop/devices."

So please advise on what I can try next.

Last edited by 357mag; 03-03-2005 at 09:18 PM.
 
Old 03-04-2005, 03:08 AM   #6
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Delete any entries related to your removable device(s) from /etc/fstab.

Be VERY carefull NOT to remove anything pertinent to mounted drives or to the OS and/or swap partitions. LEAVE THESE LINES ALONE!

Next make sure that your device appears in the MCC and is properly mounted via the MCC.

Add a mount point and name as required and mount it.

Then in the KDE desktop right click on the desktop and select

Configure Desktop/Behaviour/Device Icons/

Check off "Show device icons".

Now turn on EVERYTHING in the window below which reads "device types to display".

Hit apply below and then OK.

Log out and log back in.

Done.
 
Old 03-04-2005, 11:56 PM   #7
357mag
Member
 
Registered: Feb 2005
Posts: 95

Original Poster
Rep: Reputation: 15
Well here is the deal. I went into fstab and deleted the line that said /dev/sda... but I can't save it cuz I get an error message saying "The file could not be saved as it is not possible to write to /etc/fstab... Check to make sure you have access permissions or that you have enough disk space." Don't know what to do about that and I am logged in as root too.

I looked in Mandrake Control Center and it showed this:
Disk
hda
sda

When I highlight sda in the right pane it says "Old device file: /dev/sda Iomega desktop hard drive."

So as far as I know my USB hard drive appears to be listed there.

I clicked on the "Mount Points" icon in Mandrake Control Center and looked to see if my Iomega USB hard drive was listed but it's not.

At this point I kind of figured it wasn't going to work but I followed the rest of your steps anyway. I went into Configure Desktop/Behavior/Device Icons and the box next to "Show device icons" is already checked. I went into Device Types to Display and checked everything hit apply and then went into Log Out and chose "End Current Session." When I got back to the desktop I opened up a new terminal window and logged in as root. I then clicked on the Link to Application icon but got "Unable to enter file: /mnt/usb. You do not have access rights to this location."

So that's what happened. Maybe the problem is that in "Mount Points" my USB drive is not in there. I don't know. I'll try any further suggestions you have though.
 
Old 03-05-2005, 04:41 AM   #8
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
As I mentioned DELETE the existing drive.

You haven't done so yet.

Do not touch the other OS drives.

Exit the MCC, then go back into it and add the drive again.

After you have recreated a mount point for it, go to the options and set the drive NOT to automatically mount at startup, and then USER mountable.

Then do as indicated.

As it is, you are sort of working against what Mandrake is trying to do vis-a-vis the desktop icons.
 
Old 03-05-2005, 10:48 PM   #9
357mag
Member
 
Registered: Feb 2005
Posts: 95

Original Poster
Rep: Reputation: 15
Well it does not appear that I can delete it. Cuz when I use Kwrite the text editor to open the fstab file, and use the backspace key to wipe out the entire /dev/sda line, I can do that, but when I try to save the file I keep getting the message "The document could not be saved as it was not possible to write to /etc/fstab." I imagine that's what you want me to do right? Wipe out the /dev/sda line entirely and then save the file? And I'm logged in as root too so I don't know why I can't save the file with the changes. And when I look in the Mandrake Control Center it still says:
Disk
hda
sda

I'll try any suggestions you have. Maybe I have to actually have Mandrake installed on my hard drive in order to do some things, I don't know.
 
Old 03-06-2005, 02:53 AM   #10
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Edit /etc/fstab as root from a console.

Use any text (not gui) editor you may know to do this.

Also what do you mean that you do not have Mandrake installed to the HDD?!?!?!?!?
 
Old 03-06-2005, 11:11 PM   #11
357mag
Member
 
Registered: Feb 2005
Posts: 95

Original Poster
Rep: Reputation: 15
I don't have the OS installed on my hard drive. I'm just running the Live CD. What I did now was to reboot my computer loading up the Mandrake Move disc. I opened up a terminal window and typed cat /etc/fstab to see what was listed:

/dev/hdc
/dev/hdd
/dev/hda1
/dev/hda5

There was nothing referring to sda so I thought okay. I then opened up MCC and looked to see what was there. Under Mount Points it listed:

Partitions
CD-ROM
CD/DVD
Floppy Drive
Zip Drive

... and some other stuff like Local Disk Sharing, NFS Mount Points etc. But nothing referring to my USB drive(don't know if that's okay or not). I clicked on Partitions to see what was in there:

hda sda

Under the sda tab the mount point listed was /mnt/win_c2. I figured that was wrong so I changed it to /mnt/sda1.

I also went into Options and unchecked the box next to supermount and checked the box next to user. I then right clicked on the desktop and made a new icon and under the Device tab chose the one that said /mnt/sda1.

Then I tried opening up my USB drive by clicking on the icon but got:

Could not mount device. Only root can mount none on /mnt/sda1.

As I said earlier I don't actually have Linux installed on my computer. I was hoping to see how far I could go getting everything to work just by running the Live CD first. Then if I could get everything to work I would choose to install Mandrake. But maybe there are some things that you just can't do running from the Live CD.
 
Old 03-07-2005, 03:11 AM   #12
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
I guess it would have been appropriate to START with this little tidbit of information.

All bets are off with the LiveCD version of Mandrake Move.

Not only that, but the download edition is purposely crippled so it cannot save configuration information thru a reboot.

Yes you'll need to install it.
 
Old 03-07-2005, 05:03 PM   #13
357mag
Member
 
Registered: Feb 2005
Posts: 95

Original Poster
Rep: Reputation: 15
Well maybe once I can successfully boot from my hard drive where I got Win 2000 installed, I'll download the retail version and install it on my hard drive. I've been experiencing difficulties booting from my hard drive ever since I had a power surge in my apartment 3 weeks ago. I keep getting an error message saying "Windows 2000 can not start because such and such a file is missing or corrupt." What is weird is every time I bring my machine down to the local shop and start it and then keep rebooting it it starts just fine. No problems at all. No error messages. So I'm going to have an electrician come in and make sure the outlet is okay.

Something else I was wondering is if it's possible to change the look of the taskbar. Like for instance can you change the default star(the start button) to something else? And those icons next to the start button, can those be changed also?
 
Old 03-08-2005, 06:41 AM   #14
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Is your computer plugged into a power strip?

The filtering capacitors used in surge supressors, have a finite lifespan.

Usually on the order of NO MORE than 1.5 years (yes they must be replaced that often...)

I've seen strips that were shunting current to ground causing all sorts of problems for the attached devices.

If your drive is not receiving sufficient power, the drive may indeed appear to be failing when it is not.
 
Old 03-08-2005, 08:54 AM   #15
357mag
Member
 
Registered: Feb 2005
Posts: 95

Original Poster
Rep: Reputation: 15
Yes I'm using a surge protector, but it's brand new cuz the old one got fried.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CD-icon on desktop does not work jesper54 Linux - Newbie 2 10-11-2004 12:41 PM
help for making a icon managing s/w dakoo Linux - General 4 07-10-2004 02:33 AM
Making the Trash icon disappear? (forever?) diam0nd Linux - General 5 04-13-2004 11:38 AM
Making a shortcut to GAIM: How do I change the icon? killswitch1968 Linux - Newbie 1 03-11-2004 03:22 AM
up creek, no paddle: giFT install, making mozilla FB icon intrepidtrefz Linux - Software 1 12-31-2003 09:18 AM


All times are GMT -5. The time now is 12:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration