LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 06-16-2004, 06:10 AM   #1
Kadett
LQ Newbie
 
Registered: Jun 2004
Location: Canada
Distribution: Started on Red Hat 5.1 now on Mandrake 10.0
Posts: 21

Rep: Reputation: 15
Major Headaches with Mandrake 9.0 and Nvidia Card


Hi all,

Well pretty much I'm what you would call a total Linux noob, but here goes:

I installed Mandrake 9.0 on my machine some time ago (everything worked fine!) but for a number of reasons I removed it and then updated some hardware on my machine, more RAM and a new video card (GeForce 4 MX440 with 64 MB Ram).

Anyhow recently I decided that I wanted to return to Linux and get better aquinted with it, so I installed the system and all went fine, as before with no problems, except that now when it tries to boot into X it won't work, the monitor flashes several times as the system tries to set up the video and then just goes to the text mode.

So, being a noob I ran XFDrake from the command line like it says and basically every GeForce driver I select and then test it gives a message like (EE) no devices found, which is not the case as I obviously have the card in my system and it runs fine in Windows. Also the Mandrake install is totally graphical and that all worked fine.

I've run some searches on the internet about Nvidia problems in Mandrake and how you should reinstall the drivers, but being so unfamiliar with text commands in Linux, doing RPMS or patching the kernel, I dont seem to have had much success.

I've heard that I can force the system to work by changing the line:

Driver: "nvidia" to "nv"

in the something called the XF86Config-4 file. But I'm unclear how to edit this file. Can someone point me in the right direction as to how I can edit this file.

Mainly at this point I just want to get some kind of graphical interface working so that I can then play around and learn about the text command in a more comfortable environment, and then hopefully sort out the drivers so that I can get full graphics acceleration.

The only other solution I can think of is to install Mandrake 10.0 and hope that this problem will go away, but I'd like to sort it out now as I suppose it must be possible. The Mandrake 9.0 box does say it supports GeForce cards.

The rest of my system is:

AMD Duron 890 mhz
System Ram: 640 MB
Harddrive: 28 GB
Sound: Soundblaster
Network: SiS 900 Ethernet

Any help/ advice would be much appreciated.
 
Old 06-16-2004, 07:25 AM   #2
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
the non-official, updated periodically, should work if you follow these instructions, Nvidia drivers install "how to"..........

last updated 12-14-04 to include "modprobe.preload" info.

--------------------------------------------------------------------------------------
first, to see how much improvement these drivers will get you, before doing any of the following, open a terminal as root & type glxgears (hit enter). a small box with coloured gears spinning will appear on your screen. let it run for 30 seconds to a minute, then close the box. you will see output on your terminal screen showing how many FPS (Frames Per Second) your card is getting you. after you install the drivers, run glxgears again & compare the results. now, on with the show..............

--------------------------------------------------------------------------------------

first, you need to install the nvidia drivers. you can get them HERE .

on the above linked page choose "graphics driver" in box 1, pick your board type in box 2, choose your platform in box three, click "go". if you have a normal AMD or Intel CPU, use the IA32 drivers. if you have AMD64=AMD64 drivers, Intel64=IA64 drivers.

download the file called NVIDIA-Linux-x86-1.0-XXXX-pkg1.run & save it to your hardrive somewhere, then follow the instructions below to install............ (XXXX=current version number)

PLEASE NOTE:you must have the kernel-source installed that matches your kernel in order for the nvidia drivers to function! in terminal as root type uname -a to get current kernel version. then, in terminal as root do urpmi kernel-source-(same kernel number here).

1. start the computer & choose the "failsafe" option to boot from. (this will boot you into text mode & dump you at a login prompt)

1b.NOTE: the above boot from "failsafe" mode isn't neccessary if you already have GUI access. this only comes in handy if you're having trouble starting X. if you have GUI access, then ignore the "failsafe" method, open a terminal as root & type init 3 (hit enter). this will kill X & dump you at command line. login as root, then proceed to step 4.

2. at the login prompt, type your user name (enter) password (enter)

3. type su (enter) password (enter) this will put you in root mode. then type...... init 3 (hit enter) to kill xserver. relogin as root.

4. navigate to the directory where you have the nvidia installer script.

5. type ls (enter) that will list the contents of the directory (in case you have more than one file on there. you're going to need to know the install script file name, in full.)

6. type the following. this is CapSenSItIve....... sh NVIDIA-LINUX-x86-1.0-XXXX-pkg1.run (XXXX=current version number)

6b.NOTE: there are some issues with the Nvidia 6111 driver & certain kernels. if the driver install errors out using the 6111 drivers, run the install command as follows....... sh NVIDIA-LINUX-x86-1.0-XXXX-pkg1.run --add-this-kernel ........it will then compile a new script for your kernel in the same directory called NVIDIA-Linux-x86-1.0-XXXX-pkg1-custom.run. you would then install the drivers using that (-custom) script.

7. accept the agreement, then answer yes to the prompts. it will load the drivers & when it's done it will dump you back at the prompt.

7b.NOTE: if you get a warning during the install about rivafb being a kernel module, blah, blah, blah, ignore it & proceed with the install. this pertains to riva chipsets. the module will not interfere with the Nvidia drivers unless you have a riva chipset, in which case you need to disable the module from loading.

8. we're going to use VIM to edit your xf86config (or xorg.conf......see 9b.) file. follow the steps exactly as i type them. again, it's CapSensiTIve.

9. type vim /etc/X11/XF86Config-4 (enter)

9b. with the advent of xorg becoming the default X server on many distros, if you are using xorg, then the edit command would be....... vim /etc/X11/xorg.conf (enter)

10. type i (this is for insert mode so you can isert the proper driver line)

11. use your arrow keys & scroll to the section where it says Section "Module". under that, make sure there's a line that says Load "glx" # 3d layer . if there isn't, add it as the last line, then hit esc .

12. if it says either or both of the following under the "Module" section (Load "DRI" Load "Glcore"), remove them by typing i & using the arrow keys to navigate to them & the space or backspace bar(s) to remove them. hit esc .

13. type i & use your arrow keys to navigate to where it says Section "Device". navigate to where it says Driver "nv" or Driver "vesa" & make it read Driver "nvidia" .........that's Driver(space)(quotes)nvidia(quotes)

14. hit the esc key.

15. type :wq (enter) ..........that's (colon)wq then hit the enter key.

15b. if you think you did something horribly wrong while editing & just want to exit without saving the changes so you can start over, after hitting the esc key type :q! (enter) ........that's (colon)q(exclamation mark) then hit the enter key.

16. type reboot

16b. there appears to be a bug/glitch/compatability issue in MDK10.1 with udev & Nvidia drivers. if after rebooting you find that X won't start, do the following....... from a terminal prompt as root, use vim (or vi) to edit the /etc/modprobe.preload file. simply add a line under the header of that file saying nvidia. save it, then reboot (or startx) again.

you're computer will now reboot, choose linux from lilo as you normally would. if all went well (& it should have) you'll see a nvidia splash screen just before your GUI login.

also, one note. sometimes the nvidia drivers can cause random lockups. if you find that happening, use your favourite text editor, open that same XF86Config-4 (or xorg.conf) file, & directly under where you changed Driver "nvidia", add the follwoing line..........

Option "NvAGP" "3" (that's Option(space)(quotes)NvAGP(quotes)(space)(quotes)3(quotes).

that will try to use the kernel agp drivers first, then nvidia agp if the kernel drivers don't work. other numerical options you can use with that are........

"0" (uses no agp support)
"1" (uses nvidia agpart only)
"2" (tries kernel agpart only)

save it, then restart X or reboot. smoke 'em if ya got 'em. you'll see the Nvidia splash screen before you get to your login screen. if you decide the splash screen is oogly & you want to disable the it, use a text editor to open XF86Config-4 (or xorg.conf) & under the "device" section, add the following line.........

Option "NoLogo" "1

another Nvidia feature that many don't know about......... in a terminal as root type nvidia-settings (hit enter). you'll get a nice GUI panel where you can tweak/fine tune various video/monitor settings & an explanation for what each setting does.

otis

Last edited by otish1000c; 12-14-2004 at 07:14 AM.
 
Old 06-17-2004, 05:36 AM   #3
Kadett
LQ Newbie
 
Registered: Jun 2004
Location: Canada
Distribution: Started on Red Hat 5.1 now on Mandrake 10.0
Posts: 21

Original Poster
Rep: Reputation: 15
Otis

First off thanks for the detailed reply, at least a solution appears possible.

BUT......now I have looked into the Kernel - Source issue and in my system the /usr/src (which is where I read the kernel is mean't to be!) only contains the directory RPM. Now I've been reading and I understand it that if the kernel source is actually installed there should be a directory there called /linux.

Anyway I've been using an old laptop as a testbed to try things out and so yesterday I looked through the Mandrake 9.0 CD's (I bought the boxed set) and there was this CD named 'Installation Sources' so I explored that and there was a directory named SRPMS.

In that CD I found an RPM named: kernel-2.4.19.16mdk-1-1.mdk.src.rpm.

This kernel is mine according to the bootloader!

So I'm figuring this is the kernel source. Right?

Anyhoo I decided to install this on the laptop to see what happens and it created new directories in /usr/src but these were named SOURCES and SPECS. So it didn't create a directory named 'Linux'. So I'm not sure I'm on the right lines here. Inside the new SOURCES directory there are a number of files on of which is 'linux-2.4.19.16.tar.bz2'. Am I supposed to bzcat this file?

Basically am I on the right lines here, how does one go about installing the kernel source?

Any thanks
 
Old 06-17-2004, 06:57 AM   #4
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
you really don't need the kernel or source, per se, to be able to boot. as long as there is a kernel image in the /boot partition, you're good to go. but, you do need the kernel & source installed for nvidia drivers & other things. to get the kernel & source, do the following..........

in terminal, as root, type..........

urmpi kernel (hit enter)

it will list the kernel(s) it found & ask if you wish to install. answer yes. if it gives you a message "everything already installed", then proceed to do...........

urpmi kernel-source (hit enter)

it will ask you if you wish to install, answer yes.

once they are installed, then proceed with the nvidia instructions.

otis
 
Old 06-17-2004, 06:21 PM   #5
Kadett
LQ Newbie
 
Registered: Jun 2004
Location: Canada
Distribution: Started on Red Hat 5.1 now on Mandrake 10.0
Posts: 21

Original Poster
Rep: Reputation: 15
Ok, so heres what happened so far:

(Logged in as root in FAILSAFE mode)

When I type the command urmpi kernel, I get the response

bash: urmpi: command not found

and the same response when I type urmpi kernel-source


So moving on from there I tried the NVIDIa driver package install to see what would happen.

So I run the command: sh NVIDIA-LINUX-x86-1.0-5336-pkg1.run and the installer starts to work but then comes up with this message:

ERROR:- Unable to find the system utility 'ld'; Please make sure you have the package 'binutils' installed. If you do have binutils installed then please check that 'ld' is in your PATH.


So at this point I pretty sure that I have no kernel source installed and perhaps this is why I'm getting the error message from the NVIDIA installer. Why the urmpi command does not work I am clueless.

Also I ran the command: rpm -qa | grep kernel and it produced the following results:

kernel-2.4.19.16mdk-1-1mdk
NVIDIA_kernel-2.4.19-16mdk-1.0-3123.1mdk


So it would appear that the mandrake installer did put in some kind of older NVIDIA kernel patch.
 
Old 06-17-2004, 06:24 PM   #6
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
i'm so sorry.............. i made a typo on the first set of instructions.

it's urpmi, not urmpi

try it agin as i said but use urpmi.

my appologies.

otis
 
Old 06-17-2004, 06:38 PM   #7
Kadett
LQ Newbie
 
Registered: Jun 2004
Location: Canada
Distribution: Started on Red Hat 5.1 now on Mandrake 10.0
Posts: 21

Original Poster
Rep: Reputation: 15
LOL.......sorry I just worked that out now.

So when typing

urpmi kernel

I got the message everything installed

and for urpmi kernel-sources

it went through the install process asking for the CDs as required.

I installed the NVIDIA package and all went fine.

So now I just have to use vim to change the XF86Config-4 file. So I'll post back after that!


Thanks
 
Old 06-18-2004, 03:56 AM   #8
Kadett
LQ Newbie
 
Registered: Jun 2004
Location: Canada
Distribution: Started on Red Hat 5.1 now on Mandrake 10.0
Posts: 21

Original Poster
Rep: Reputation: 15
Ok well the kernel source is in and the Nvidia Package ran fine.

I edited the XF86Config-4 file to add the changes earlier posted. Now whats happening is at the bootloader screen, if you select the 'linux' option then it wont start X. You get bounced to the command line so typing startx brings up this error message:

(EE) NVIDIA (O): Failed to initialize the NVIDIA kernel module.

(EE) NVIDIA ***Aborting***
(EE) Screen (s) found but none have a usable configuration.


Whats new now is that if you select failsafe you get presented with a graphical 'Linux Config 1.28 Operation Mode'. From that you can opt to select the Graphics and Network.

When I do this X starts up with the NVIDIA boot screen displayed and KDE starts. The only problem is that the graphical interface hangs up alot. It freezes so that <ctrl> <alt> <backspace>
doesn't work you often have to press the computers reset button to get out. But there is no pattern to the hang-up it sometimes works fine for a few hours and you can use everything. I ran glxgears at the fps was a 1000 so the card must be working, I presume?

I don't know why X would work in failsafe, but not through the linux selection from the bootloader screen.

My XF86Config-4 file reads like this:

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "/usr/X11R6/lib/modules/extensions/libglx.so"
Load "glx" # 3d layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/usbmouse"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "NEC"
ModelName "NEC MultiSync E750"
HorizSync 31.0-92.0
VertRefresh 55.0-160.0

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "NvAGP" "1"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

I tried to add the items as per the instructions, but I don't know if there is some mistake in this file, or something else which should be there. But the Nvidia card must be working if I am getting the Nvidia screen and X loading in failsafe mode.

PS. My monitor is an NEC MultiSync E750. Pretty bog standard from 1998, I dont know how it would relate to this if at all?

Any ideas?
 
Old 06-18-2004, 05:02 AM   #9
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
hmmmm............

ok, 2 things i want you to do. first, if you can still get to a GUI, just open the XF86Config-4 file with a text editor of your choice (you don't need to use vim to do this, but you can if you want). you'll need to be root to edit it, so open a terminal, su to root, then type konqueror & hit enter. that will open konqueror in superuser mode. go the following section & make it look like this...........

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "/usr/X11R6/lib/modules/extensions/libglx.so"
#Load "glx" # 3d layer
EndSection

notice, i put i hash mark # in front of the "glx" line. that will tell that line not to load. save the file, then reboot & try your normal linux selection to boot, not failsafe.

if that doesn't work, open the xf86 file again, uncomment that line & comment out the Load "/usr/****" line, like this............

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
#Load "/usr/X11R6/lib/modules/extensions/libglx.so"
Load "glx" # 3d layer
EndSection

save, reboot again, try normal linux start.

what i think is happening is for some reason there's now 2 references to glx & it doesn't know where to load them from. if none of those things work, please post back with your lilo.conf file. it's in /etc/lilo.conf.

there's also a few more nvidia options we can play with to test things out. don't worry, all is not lost.

otis

Last edited by otish1000c; 06-18-2004 at 05:05 AM.
 
Old 06-18-2004, 07:36 AM   #10
Kadett
LQ Newbie
 
Registered: Jun 2004
Location: Canada
Distribution: Started on Red Hat 5.1 now on Mandrake 10.0
Posts: 21

Original Poster
Rep: Reputation: 15
Again many thanks for all the help

So I tried both of the above variants and they didn't seem to work
I edited the XF86Config-4 file in vim because basically although I can always get X to start up in failsafe, its pretty prone to freezing.


Anyway my lilo.conf looks like this:

boot=/dev/hda
map=/boot/map
default=linux
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
ignore-table
image=/boot/vmlinuz
label=linux
root=/dev/hda5
initrd=/boot/initrd.img
append="devfs=mount hdd=ide-scsi quiet"
vga=788
read-only
image=/boot/vmlinuz
label=linux-nonfb
root=/dev/hda5
initrd=/boot/initrd.img
append="devfs=mount hdd=ide-scsi"
read-only
image=/boot/vmlinuz
label=failsafe
root=/dev/hda5
initrd=/boot/initrd.img
append="devfs=nomount hdd=ide-scsi failsafe"
read-only
other=/dev/hda1
label=windows
table=/dev/hda
other=/dev/fd0
label=floppy
unsafe

Clearly the drivers installed work in some way because before they were installed startx simply did not work even in 'failsafe' mode. Also the Nvidia boot screen would appear to confirm they are present and working with the card.
 
Old 06-18-2004, 07:56 AM   #11
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
hmmmm...........

lilo looks good. i'm hitting a wall here as to why you can get a GUI in failsafe, but not normal boot mode.

some more suggestions if you're still willing to play.........

look up to my nvidia install instructions. look at the very bottom where i give other options for the "NvAGP" option. leaving the Load "glx" uncommented out & comment out (#) the Load "/usr/X11R6........" section first, then try different numerical options, starting with "0" first to test no agp suppost. if that works, then try "2" . if that works, play for a while & see if you get any freezes. if "2" don't work, then go to "3". try the numericla options also with the Load "glx" commented out & the Load "/usr/X11R6..........." uncommented. i know it's a PITA, but you just gotta find a sweet spot to get things working.

gotta get some work done now. post back with comments/results, i'll get back to you when i can.

otis
 
Old 06-19-2004, 03:48 AM   #12
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
This

Code:
 Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection
may need to read

Code:
 Subsection "Display"
Depth 16
Modes "1024x480" "800x600" "640x480"
EndSubsection
If that does not work, find out exactly what resolutions that monitor recognizes. I think I read this is a laptop, they are 'pickier' about those settings.

You may have to change the other Depth levels too, not sure.

Post back what you get.

Later

 
Old 06-19-2004, 07:15 AM   #13
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
hmmmm...........

dalek, you may be on to something there. i was wearing nvidia blinders & not thinking about screen size & display settings. but, wouldn't 1024x480 be a bit skewed, size wise?

Kadett, if you're still having problems & reading this, if you can get to a GUI, try setting your screen resolution in MCC->hardware->XFdrake. if you can't get to a GUI, as root from command prompt, type XFdrake.

otis
 
Old 06-19-2004, 05:51 PM   #14
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
I actually found that res in the config that was generated during the install. It does seem strange but if he/she can find out exacyly what res it supports, just fill in the right one. It did say "no usable screens found". I have seen that before. I had hooked up a old 15" where my 19" used to be. Needless to say, the 15" doesn't support the high res's the 19" does.

Hope that helps though. Linux is better with a GUI.

Later

 
Old 06-20-2004, 05:16 PM   #15
Kadett
LQ Newbie
 
Registered: Jun 2004
Location: Canada
Distribution: Started on Red Hat 5.1 now on Mandrake 10.0
Posts: 21

Original Poster
Rep: Reputation: 15
Otis sent you an email about this and the "solution" well pretty much at least!

Thanks all
 
  


Reply

Tags
hardware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia Install headaches galliar Suse/Novell 4 12-31-2005 08:31 PM
NVIDIA headaches..............sigh dcdbutler Slackware 8 03-07-2005 06:21 PM
Mandrake 10.1 Headaches crash_zero Mandriva 12 02-11-2005 09:29 AM
Mandrake+Nvidia=Headaches webterractive Linux - Hardware 10 12-10-2004 02:18 PM
RH8.0 & Netgear MA401 card headaches kurtisw Linux - Networking 6 05-01-2003 08:45 PM


All times are GMT -5. The time now is 10:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration