LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices



Reply
 
Search this Thread
Old 02-02-2004, 11:10 AM   #1
doggod
LQ Newbie
 
Registered: Jan 2004
Posts: 10

Rep: Reputation: 0
Lilo & win disk


Please read and help if you can
Was reinstalling mdk 9.2, I have 2 hard drives, win2k booting on drive 1 and mdk on drive 2. Made the mistake of not loading lilo on beginning of drive 2 and nothing would boot, just had a lilo error. Put in linux cd 1, selected recovery and tried to recover windows MBR. No luck, so I installed mdk again (correctly) on disk 2 and linux works great, but win2k is GONE!
The HD is recognized by bios, but nothing else. Cannot access it with win2k install floppys or cdrom, cannot access it through fdisk from win98 boot floppy (probably because its NTFS). Thought I could do a format /mbr to restore the boot record but the drive just isnt there....
I will try to get it to mount in linux tonight with the info I found here but have many doubts if this will work. Linux tried to mount it to /mnt/windows but didnt work. I really need this drive to boot though.
Any other Ideas??? Has anyone had this problem???
 
Old 02-03-2004, 11:45 AM   #2
elluva
Member
 
Registered: Aug 2003
Location: Belguim, Ostend and Ghent
Distribution: Ubuntu
Posts: 600

Rep: Reputation: 30
win2k is gone? what do you mean with the partition is gone? Can you mount the partition? If you want to be sure, it is still their, run diskdrake (if I remeber well that will give you your partition table) else cfdisk will do as well (in a terminal). Write down where your w2k is on the disk (e.g. /dev/hda1) and the edit /etc/lilo.conf:

* Add an entry:
other = <WhatYouWroteDown>
label = Win2k
table = /dev/hda
* Run lilo as root
>If you do not get an error, this means you can reboot, else you will have to check out what is wrong,
>or just post it here

Last edited by elluva; 02-03-2004 at 11:47 AM.
 
Old 02-03-2004, 11:52 AM   #3
equinox
Member
 
Registered: Dec 2003
Location: Johannesburg, South Africa
Posts: 846

Rep: Reputation: 30
I can try help you fix your win2k problems...

Either disconnect or in the bios disable ur hdd with mdk 9.2 on it, therefore only leave the win2k hdd connected or accessible.

Insert your win2k cd, let it load all the blue screen stuff till it gets to the setup welcome screen, press r for recovery console, select windows path and give your admin password.

then at the prompt run the commands: fixboot
and then: fixmbr

Then reboot and see if it helps, if it is successfull, then reconnect your mdk hdd or through the bios, boot up from that hdd and configure grub/lilo whatever you use.

ciao
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SWL & WIN on 1 HDD with no Boot disk for SW! HELP!!!!!! :( GR33NF00T Linux - Newbie 8 12-31-2004 03:05 AM
need <free> disk partitioner win & linux square_eyes Linux - Software 1 04-25-2004 08:44 AM
Lilo: Dual boot Debian & Win 2000 mudelf Linux - General 3 11-12-2003 02:55 AM
Install Issue - Boot Disk, Lilo & Kernel Swampy Slackware 5 02-07-2003 08:03 AM
Lilo troubles - RedHat Linux & Win XP *Please help mgroyal Linux - Software 18 04-03-2002 03:52 AM


All times are GMT -5. The time now is 01:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration