LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   krdc (http://www.linuxquestions.org/questions/mandriva-30/krdc-489500/)

paul62 10-04-2006 06:00 PM

krdc
 
I have two computers one is a mandriva 2006 and the other one is running windows xp. When I use krdc to do a remote desktop connection from the windos xp computer icon indide of devices in the mandriva 2006 I get the message "cannot connect to remote server". I would appreciate help with this.

bulliver 10-04-2006 06:35 PM

Sounds like a firewall or Xwindows forwarding permissions problem but this is just conjecture because I can barely understand your post and you have given hardly any details.

paul62 10-04-2006 07:33 PM

I'm sorry, I have two computers on a home network conected by a router and I am using dhcp for my configuration of tcp/ip. The router is a usrobotics 8004,connected to my dsl. I am running samba on the linux box, I would appreciate any more insight

bulliver 10-05-2006 01:37 AM

You are still not providing much info...

Are you sure samba is up and running?
Have you set up your shares?
Have you put your windows box in "hosts allow = " in smb.conf?
Have you set up authentication? Which type?
Have you run 'testparm' to ensure your config is valid?
Have you checked the logs for hints?
Is your firewall (if you have one) allowing access?

I do suggest you read the configuration docs and make sure your samba server is configured correctly for how you intend to use it: http://us3.samba.org/samba/docs/man/...tion/type.html

paul62 10-05-2006 11:29 PM

This is the output of testparm

Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[print$]"
Processing section "[pdf-gen]"
Processing section "[Unnamed]"
Loaded services file OK.
Warning: Service printers defines a print command, but print command parameter is ignored when using CUPS libraries.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
workgroup = MSHOME
server string = Samba Server %v
map to guest = Bad User
guest account = paul
log file = /var/log/samba/%m.log
max log size = 50
server signing = auto
paranoid server security = No
socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192
printcap cache time = 60
printcap name = cups
preferred master = No
domain master = No
dns proxy = No
ldap ssl = no
guest ok = Yes

[homes]
comment = Home Directories
read only = No
hosts allow = pc2
case sensitive = No
msdfs proxy = no

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
printable = Yes
print command = lpr-cups -P %p -o raw %s -r # using client side printer drivers.
use client driver = Yes
browseable = No

[print$]
path = /var/lib/samba/printers
write list = @adm, root
inherit permissions = Yes

[pdf-gen]
comment = PDF Generator (only valid users)
path = /var/tmp
printable = Yes
printing = bsd
print command = /usr/share/samba/scripts/print-pdf "%s" "%H" "//%L/%u" "%m" "%I" "%J" &
lpq command = /bin/true
lprm command = lprm -P'%p' %j

[Unnamed]
path = /root
hosts allow = 192.168.0.3, 192.168.0.4, 192.168.0.5
case sensitive = No
msdfs proxy = no
[root@mybox ~]#
Is there anyway to jsut turn off the password feature?


All times are GMT -5. The time now is 05:43 PM.