Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.


  Search this Thread
Old 03-12-2005, 09:18 AM   #1
Registered: Dec 2003
Location: Washington, DC
Distribution: Ubuntu 7.04
Posts: 73

Rep: Reputation: 15
k3b won't start: "undefined symbol" error

I recently upgraded from Mandrake 10.0 to 10.1, and I'm trying to run k3b but I keep getting the same error:

k3b: symbol lookup error: /usr/lib/ undefined symbol: _ZTv0_n32_N4Arts16SynthModule_stub11autoSuspendEv

I've dried reinstalling k3b and installing different versions of k3b (older and newer). But I always get the same error.

I've looked into reinstalling libkdecore4 which contains, but I get some conflicts.

Any ideas?

Thanks in advance.
Old 03-12-2005, 10:42 AM   #2
Senior Member
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Because you performed an upgrade install of a clean install, often symlinks to older version libraries are left laying around...

In your case points to the OLD libartskde library but K3B wants the newer version.

Either manually fix this, or avoid the "upgrade" route and perform a clean install.

Know that the former is typical as the installer scripts can't figure out what to do.
Old 03-12-2005, 10:49 AM   #3
Registered: Dec 2003
Location: Washington, DC
Distribution: Ubuntu 7.04
Posts: 73

Original Poster
Rep: Reputation: 15
OK. That gives me something to go on. Thanks much.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP5 + Apache 2.x : /usr/local/modules/ Undefined symbol "apr_table_set" Ephracis Linux - Software 6 10-01-2010 12:26 PM
k3b: "error decoding audio tracks" and "could not unlock cd driver" lefty.crupps Linux - Software 7 10-13-2005 11:29 AM
firefox and "undefined symbol:" deadkenny666 Linux - Newbie 0 02-14-2005 04:53 AM
"undefined symbol" when trying to compile c? SciYro Programming 6 11-25-2004 02:08 AM
rpm error only says"rpm: relocation error: rpm: undefined symbol: poptAliasOptions" dlrsims Linux - Newbie 2 11-14-2003 09:22 PM

All times are GMT -5. The time now is 09:50 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration