LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 02-28-2005, 05:25 PM   #1
TheCowboy
Member
 
Registered: Dec 2004
Location: Calgary Alberta
Distribution: Debian Sarge 3.1 rc4
Posts: 40

Rep: Reputation: 15
Issues with glib, "cannot find glib".. Mandrake 10.1... Please Help!~


Howdy, It seems every day brings a new problem. I have freshly installed mandrake 10.1 on my system, and as I went to install "xchat" from a tar archive I recived an error... In the configuration... I wonder what could be the problem, And unfortunatly I do not know a whole lot about glib....

Here is the error...

checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.0.3... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: "Cannot find glib"
[root@localhost xchat-2.4.1]#

I was wondering if maybe I have to play a bit with the configuration file for it may not know where my glib is... Or if there is acually a problem with my glib... Someone please help. I know you cant go far in linux without a compiler.....

If you need any further information from me to help... please just ask. I will get it for you.....

Thank you in advance!
 
Old 03-01-2005, 02:24 AM   #2
bunnadik
Member
 
Registered: Jan 2005
Location: Ívik, Sweden
Distribution: MDK 10.1
Posts: 450

Rep: Reputation: 30
You need the -devel packages if you want to compile yourself: 'urpmi libglib2.0_0-devel'

- Peder
 
Old 03-01-2005, 04:49 AM   #3
frank28_nfls
LQ Newbie
 
Registered: Feb 2005
Location: TLS
Distribution: Mandrake 10.1/FreeBSD 5.3
Posts: 4

Rep: Reputation: 0
I had almost the same problem as you, so I advise you to do as follow:
http://www.linuxquestions.org/questi...hreadid=203939

and check motub's response
I solve my problem and i hope the same to you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shell Script: Find "Word" Run "Command" granatica Linux - Software 5 07-25-2007 07:42 AM
Installing xmms on FC4 -> "glib-config not found"... gletare Linux - Software 11 10-06-2006 01:32 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
Can't install "glibmm" library. "configure" script can't find "sigc++-2.0&q kornerr Linux - General 4 05-10-2005 02:32 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM


All times are GMT -5. The time now is 06:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration