LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 03-15-2004, 10:33 AM   #1
Rundi
Member
 
Registered: Jun 2003
Location: USA
Distribution: Ubuntu
Posts: 169

Rep: Reputation: 30
Exclamation Internet connection lost in sleep mode


I am running Mandrake 9.1 and access the internet through my local LAN. My problem is that I have discovered that Linux loses its internet connection when it goes into standby/sleep mode. So, if I get up from browsing the internet and go away for 20 min and come back and bring the computer back up my internet connection no longer works. I must reboot the system for Mandrake to pick the connection back up. This is frustrating.

I am on a cable connection. If I boot to Win98 instead of Linux I don't have this problem. None of the other windows computers on my LAN have this problem.

Is this somehow related to a bug in the screen saver software?

I thought I saw someone else who had this problem on the forum before, but now that I search for it I can't find it.

Thanks to anyone who can be of help.
 
Old 03-15-2004, 10:56 AM   #2
LinNut
LQ Newbie
 
Registered: Mar 2004
Distribution: Mandrake 9.1 (2.4.21-0.13mdk)
Posts: 3

Rep: Reputation: 0
I think if you link your /dev/ttysm0 to /dev/modem you should not loose your modem connection.

try

ln -s /dev/ttysm0/ /dev/modem
 
Old 03-15-2004, 05:20 PM   #3
Rundi
Member
 
Registered: Jun 2003
Location: USA
Distribution: Ubuntu
Posts: 169

Original Poster
Rep: Reputation: 30
Ethernet?

What about a connection through an ethernet card?

I'm connected to cable.
 
Old 03-17-2004, 07:34 AM   #4
xvelocity
LQ Newbie
 
Registered: Mar 2004
Location: Cairo, Egypt
Distribution: SuSE 9.0
Posts: 1

Rep: Reputation: 0
I am using SuSE 9.0 and i have the same problem but I tried the linking procedure it didnt work either.
I am connected to the internet through Office Lan which uses a DSL connection. I've installed SuSE 9.0 cause I though the first installation (Redhat 9.0) was the prolem but this didnt help whenever I leave the machine unattended I loose the connection. I even tried Overnet file sharing to try to keep the connection alive but the connection works fine for a while and then disconnects again and I have to restart then.
Yeah and 1 more thing that I tried I disabled the screen power saving mode and the screen saver but that didnt work either.

Thanks to anyone who can help me solve this thing

Best Regards

A Nabeel
 
Old 03-18-2004, 11:32 AM   #5
Rundi
Member
 
Registered: Jun 2003
Location: USA
Distribution: Ubuntu
Posts: 169

Original Poster
Rep: Reputation: 30
Still trying to resolve

xvelocity -

I am still trying to resolve the issue myself so I don't know if I can be of any help to you but on the off chance that I manage to figure out a fix, could you give me a little more information on what you have/what you've done?

I mean, you are running SUSE but with which desktop? KDE or Gnome or something else?

When you said you tried to turn off the screen power saving mode and the screen saver you said that didn't work . . . do you mean it didn't turn off the power saving feature or that even with the power saving feature turned off you still lost your connection?

I also tried to adjust my power saving features from Gnome and it seemed all to no effect. I think (but I haven't tested this conclusively) that the reason my Gnome settings weren't taking effect was because Linux was taking it's setting from the KDE power manager. (I have multipule desktop managers installed.) For example, I set my Gnome power manager way up on the number of minutes before sleep mode would turn on, but Linux still seemed to go into sleep mode after five minutes. I went and checked my KDE settings and they were for five minutes. Ah! So I changed the settings on KDE. I will let you know if this solves my problem.
 
Old 03-18-2004, 01:30 PM   #6
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
The greatest likelyhood is that sleep mode etc are set up in the system BIOS. You may have to make changes there. If you start the computer using GNOME, the KDE settings should be irrelevant. The only time the KDE settings should come into play would be when you are using KDE, and then IIRC, KDE will read the settings from the BIOS.

HTH,
 
Old 03-18-2004, 02:52 PM   #7
Rundi
Member
 
Registered: Jun 2003
Location: USA
Distribution: Ubuntu
Posts: 169

Original Poster
Rep: Reputation: 30
Maybe

You could be right. Certainly there are settings in the bios and the idea has crossed my mind. But the fact that my Windows boot and my Linux boot went into sleep mode at different times indicated to me that at least one of them was probably not working from the setting in the bios.

To my casual observation Win 98 would go into sleep mode after about 15 min whereas linux would go into sleep mode after around 5 min. The bios setting was higher than 5 min, which inclines me to think at least Gnome, if not linux as a whole, doesn't get it's sleepy settings from t he bios. Also even when I set the required time way up in Gnome settings it didn't seem to effect when the computer went into sleep mode.

However, when I went into KDE and shut off sleep mode entirely, the computer went for a complete half hour without going into sleep mode. I haven't tested it for longer than that, but the feature may be truly shut off.

It does seem stupid that KDE could be effecting the sleepy mode in Gnome and I'm too ignorant to offer a good answer. All I know is that it seems to work. My best guess (and it is a guess) is that since I'm using some KDE thingy as my login manager it somehow gets to control the screen saver times for both desktops.

. . . Or else the Gnome sleepy mode manger is plain defunctive. I haven't switched back to the KDE desktop to see if my changes that work on KDE also work in Gnome. I guess that would be the real proof.
 
Old 03-18-2004, 07:18 PM   #8
Rundi
Member
 
Registered: Jun 2003
Location: USA
Distribution: Ubuntu
Posts: 169

Original Poster
Rep: Reputation: 30
Update

Well, here is an update. Gnome is certainly not taking the settings from KDE as far as sleep mode is concerned. KDE has sleep turned off and Gnome still went to sleep.

Now I need to find some way of figuring out conclusively if anyone is getting their setting from the bios.
 
Old 03-18-2004, 08:50 PM   #9
Rundi
Member
 
Registered: Jun 2003
Location: USA
Distribution: Ubuntu
Posts: 169

Original Poster
Rep: Reputation: 30
Further Update

Posting this further update on the chance that it will help someone else . . .

For me turning off sleepy mode in KDE did indeed turn off sleepy mode "in" Linux. The trick here is that there seems to be two layers of sleepy mode . . . the bios enabled and that which resides in Linux. With sleepy mode turned off in KDE my bios enable sleepy mode still kicks on . . . but the bios sleepy mode doesn't kill my internet connection like the KDE and Gnome based sleepy modes do, so I am very happy. I still have sleepy mode via the bios, but I don't lose my internet connection.

Still haven't figured out how to completely turn off the Gnome based screen saver/sleepy mode. I don't know why it couldn't have a nice check box like KDE . . . maybe I'm just missing seeing it.

Anyhow, KDE is "fixed" so I'm pretty happy.
 
Old 03-18-2004, 11:35 PM   #10
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
Happy to see things worked out ok. I do not use Gnome Desktop, so I can not help you there. I started with KDE in Mandrake 6.x, and have never felt the need to use another. I have experimented with Icewm, blackbox, and a few others, but I still use KDE as my 'default' desktop - guess it just feels like home to me
 
Old 03-19-2004, 10:39 AM   #11
Rundi
Member
 
Registered: Jun 2003
Location: USA
Distribution: Ubuntu
Posts: 169

Original Poster
Rep: Reputation: 30
Yes.

I haven't settled on which Desktop manager I like best. Gnome feels more newbie friendly, but I like the greater options in KDE.

BTW, I did figure out how to turn off the screen saver in Gnome. It was just a drop down menu instead of a check box. Makes me feel kind of stupid that I didn't realize it earlier
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost internet connection after reboot linux_shminux Linux - Newbie 2 09-18-2005 02:11 PM
Lost internet connection RonCum Linux - Networking 4 04-30-2005 08:53 PM
Can't reconnect internet when connection has lost Mikessu *BSD 1 06-18-2004 07:37 PM
HELP!!! Internet connection LOST FNC Linux - Networking 9 07-12-2002 01:02 PM
Network Connection in Sleep/Standby Mode ucdstudent Linux - Newbie 1 01-16-2002 07:25 PM


All times are GMT -5. The time now is 05:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration