LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 04-03-2005, 05:10 PM   #1
Dr. Doerke
Member
 
Registered: Nov 2004
Location: Charlottetown, Canada
Distribution: SuSE 9.2
Posts: 30

Rep: Reputation: 15
install problem - unsatisfied devel(libz)


I'm trying to install libmysql112-4.0.20-3.3.101mdk.i586rpm, under Mandrake 101OE. The software install does not allow me to select it to install or update. I downloaded the rpm from another site and when I tried to install it, got the "unsatisfied devel(libz)" error. I can't get beyond this. What do I do to climb out of this dependency hell?
 
Old 04-03-2005, 05:20 PM   #2
Dr. Doerke
Member
 
Registered: Nov 2004
Location: Charlottetown, Canada
Distribution: SuSE 9.2
Posts: 30

Original Poster
Rep: Reputation: 15
Sorry, that's libmysql12-devel-4.0.20-3.3.101mdk.i586.rpm that I'm trying to install.
 
Old 04-04-2005, 09:03 PM   #3
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,305

Rep: Reputation: 205Reputation: 205Reputation: 205
Try: urpmi libmysql12-devel-4.0.20-3.3.101mdk.i586.rpm that will hopefully install any missing dependencies as well :-)
 
Old 04-05-2005, 02:21 AM   #4
bunnadik
Member
 
Registered: Jan 2005
Location: Ívik, Sweden
Distribution: MDK 10.1
Posts: 450

Rep: Reputation: 30
I think you have to run 'urpmi libmysql12-devel' to get the autodependency working.

- Peder
 
Old 04-06-2005, 10:11 AM   #5
Dr. Doerke
Member
 
Registered: Nov 2004
Location: Charlottetown, Canada
Distribution: SuSE 9.2
Posts: 30

Original Poster
Rep: Reputation: 15
I tried urpmi and the program hung. My CPU usage went to 100% and the install never completed. I've tried the mysql-devl rpm from different sources and have the same problem.
 
Old 04-06-2005, 11:25 AM   #6
CragStar
Senior Member
 
Registered: Oct 2000
Location: UK - Frome
Distribution: Ubuntu
Posts: 1,081

Rep: Reputation: 45
Just out of curiosty, where did you download the other RPM from? Is it a Mandrake RPM for your distribution?

It also sounds like you need to add more urpmi sources, or add a different one, as usually urpmi works extremely well and will download all dependant rpm's when they are needed. The only times it hasn't installed some software for me is when it doesn't know where to locate the RPM's or they are not available - so I have added more sources and it seems to work.

One of the things I have noticed about the mirrors is that they are not always in sync with each other.

See this post for more information:
http://www.linuxquestions.org/questions/history/301178
 
Old 04-06-2005, 11:53 AM   #7
Dr. Doerke
Member
 
Registered: Nov 2004
Location: Charlottetown, Canada
Distribution: SuSE 9.2
Posts: 30

Original Poster
Rep: Reputation: 15
I downloaded one of the libmysql-devel rpms from rpmfind or rpmnet. I can't remember. The other was sent to me by the developer of the product I'm trying to install (Knoda). I did go to the Mandrake site. That was the first thing I tried. When I tried to click (select) the libmysql rpm, I got this message: Some packages can't be installed -- Sorry, the following package(s) can't be selected: libmysql12-devel-4.0-20.3.2.-101mdk.i586 (due to unsatisfied devel(libz))"
 
Old 04-06-2005, 01:12 PM   #8
CragStar
Senior Member
 
Registered: Oct 2000
Location: UK - Frome
Distribution: Ubuntu
Posts: 1,081

Rep: Reputation: 45
If the rpm was not for a mandrake distribution then I'd be cautious (that's an understatement! I wouldn't use it).

It does sound like you need to add some more sources though. I think the file it is complaining about is zlib1-devel which contains the file libz.so

Try running
Code:
urpmq zlib1-devel
and if it can't find that then you need to add a source which contains it.

I know for a fact that the file should be here:
ftp://ftp.club-internet.fr/pub/unix/...86/media/main/

But thinking about it, it should also be part of the main installation media?
 
Old 04-07-2005, 08:01 AM   #9
Dr. Doerke
Member
 
Registered: Nov 2004
Location: Charlottetown, Canada
Distribution: SuSE 9.2
Posts: 30

Original Poster
Rep: Reputation: 15
Thanks. It wasn't on my system. I downloaded libz from your suggested ftp site and then was able to go back to Mandrake and get the libmsql-devel with no problem. Much appreciated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant install unsatisfied /usr/local/bin/python/ Fredstar Linux - Newbie 1 02-02-2005 02:12 AM
Package fam-devel needs libselinux-devel belkins Linux - Newbie 2 10-18-2004 04:02 PM
rpm problem - unsatisfied libXinerama.so.1 dbc001 Linux - Software 4 03-29-2004 05:12 PM
cvs install error... due to unsatisfied krb5-devel joseph_k Linux - Software 1 02-29-2004 12:59 PM
mplayer and gtk-devel and libpng-devel ... purpleburple Linux - Software 1 03-16-2003 04:57 AM


All times are GMT -5. The time now is 08:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration