LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 04-04-2004, 01:35 PM   #1
nooky59
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Rep: Reputation: 0
How to set Gtk fonts apps running on KDE ?


Hi,

I've changed the default setup of my KDE apps cause I don't like the antialiasing fonts.

So, I've import the Windows fonts, setup Tahoma evrywhere for KDE in the KDE control center and I have uncheck "Use anti-aliasing for fonts".

So, I've a nice desktop and all KDE apps looks great !

But, all GTK apps (Totem, Mandrake Control Center, Totem..) continues to use anti-aliased fonts and don't use fonts I've setup for KDE.

I've installed especially to try al the Gnome environment to have the gnome control center. I've setup the Gnome Fonts to Tahoma too.

Now, the apps looks how I want them to when I'm logged on Gnome, but the setting still doesn't apply when I launch the apps under KDE.

I've too tried to launch the gnome theme manager or the gnome fonts properties under KDE to do the settings.

Then the GTK apps looks as I want under KDE but when I reboot my computer, the setting are losts. I must launch the gnome-font-properties under KDE every time I reboot my computer or restart X Windows.

And when I do this, there is a little problem too. If I launch the gnome-font-properties under KDE, when I launch new Qt apps after, my KDE fonts become a little bigger !!!

Does someone know how to choose precisely the fonts for GTK apps under KDE, persistantly (not sure of this term ;o))??? and without interacting with my KDE fonts ?
 
Old 04-08-2004, 12:03 PM   #2
Spasmolytic
Member
 
Registered: Sep 2003
Location: Chicago, IL
Distribution: Slackware 10
Posts: 72

Rep: Reputation: 15
<bump>

If anyone can be of help, we'd both appreciate it! I'm having this problem as well
 
Old 04-08-2004, 03:14 PM   #3
nooky59
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Argh, I thought it was a solution answer ;o)

I've noticed that some GTK apps like The Gimp or Grisbi uses the same font as KDE (or non anti-aliased beautifull fonts ;o)).

If I'm right, The Gimp & Grisbi use GTK 2, so the issue is for GTK 1 apps (Mozilla, Totem, ...)

Still no idea ?
 
Old 04-09-2004, 10:12 AM   #4
matze
Member
 
Registered: Oct 2003
Posts: 50

Rep: Reputation: 15
If you want to have your gtk fonts set up right every time you start X you should add the gnome-settings-daemon to the directory .kde/Autostart. Either create a shortcut or add it to a script. Dunno about the changing kde-fonts.

Cheers,
matze
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GTK 1 apps Fonts problems on KDE tpe Suse/Novell 0 05-11-2005 01:41 PM
Non-readable fonts in GTK apps Clojster Debian 2 12-05-2004 05:11 AM
How to set various fonts for GTK2 apps? welson_sun Linux - Software 0 06-22-2004 04:40 AM
changing the font-size of menus of GTK 2 apps running under KDE 3.1 melquiades Linux - Software 1 07-05-2003 02:17 PM
GTK apps fonts size too big in Debian hstang Linux - General 0 05-13-2003 11:34 PM


All times are GMT -5. The time now is 11:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration