LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 06-11-2004, 08:39 PM   #1
kaega2
Member
 
Registered: Sep 2003
Location: Ontario, Canada
Distribution: Gentoo 2004.3
Posts: 195

Rep: Reputation: 30
How to install codecs in mplayer


Hey everyone.

I just have a quick question. How do you install extra codecs for mplayer when installing mplayer from a rpm? I've got the codec packages off of mplayers website, but it says that the codecs must be in the /usr/local/lib/codecs folder before mplayer is compiled. I'm not compiling it and that directory doesn't exist.

If someone could tell me how it's done, that would save me some time.

Thanks
 
Old 06-11-2004, 08:55 PM   #2
doug_s
Member
 
Registered: Apr 2004
Posts: 82

Rep: Reputation: 15
if you install mplayer from the plf rpm using urpmi it should install all the codecs you need as dependencies.

You might have to go to www.urpmi.org/easyurpmi first to set up all your sources to do this. You want to specify both plf and contrib as additional sources. Then just use the install gui (rpmdrake).
 
Old 06-11-2004, 10:49 PM   #3
S.D.Willie
Member
 
Registered: Jan 2003
Location: NY
Distribution: Mandrake 9.2/Fedora Core 1
Posts: 63

Rep: Reputation: 15
best way?????????????? honestly??????????? in mandrake???????????? is to compile yourself. trust me.........you will be glad you did.................heres how you do it.

as root: urpmi mplayer


this will get all dependencies needed, and just say yes to install them. then do:

as root: urpme mplayer

this will remove JUST mplayer but will leave all the files you needed before, installed.

download the source from mplayers site. also, download at least one skin, one set of fonts, and the "all in one" package of codecs. before anything, put all the codecs into /usr/lib/win32 (make the directory)

now enter the mplayer folder afer you extracted it and do this:

./configure (you can add the gui option and codec directory like this which i like to do)

./configure --enable-gui --with-codecsdir=/usr/lib/win32


this will run and find the codecs directory. believe me ive had mandrake and compiling was the best way to get all the codecs working properly.

after the ./configure just run " make " then as root: "make install"

from the command line as a user(not root) run "mplayer"
this will create the .mplayer directory. you can then make a "Skin" directory and "font" directory like so:

you@localhost: mkdir .mplayer/font
you@localhost: mkdir .mplayer/Skin (notice the capital "S")

extract the skin of choice into .Skin and rename that folder to "default"
open the font folder and it will tell you to extract it to .font and the right command.
you can actually copy "codecs.conf" from the mplayer tarball to ~/.mplayer

after all that is done you can just run "gmplayer" from the command line and you will get the gui. good luck.

Last edited by S.D.Willie; 06-11-2004 at 10:53 PM.
 
Old 06-12-2004, 06:18 AM   #4
Riley
Member
 
Registered: Feb 2003
Location: SC, USA
Distribution: Mandrake 10.0 Powerpack
Posts: 178

Rep: Reputation: 30
as of MPlayer 1.0 all codecs should be in
/usr/local/lib/codecs
otherwise follow above instructions. MPlayer RPM in mandrake 10 seems to be better but I'm still compiling.
 
Old 06-12-2004, 07:47 AM   #5
Daliz
Member
 
Registered: Feb 2004
Distribution: Mandrake 10.1, Ubuntu 5.04
Posts: 75

Rep: Reputation: 15
I just did a 'urpmi mplayer' and everything works perfectly. Maybe I'm just lucky
 
Old 06-12-2004, 10:06 AM   #6
S.D.Willie
Member
 
Registered: Jan 2003
Location: NY
Distribution: Mandrake 9.2/Fedora Core 1
Posts: 63

Rep: Reputation: 15
Quote:
I just did a 'urpmi mplayer' and everything works perfectly. Maybe I'm just lucky
nah, not lucky, thats the way it SHOULD be. but ive run into problems with codecs from not compiling but maybe youll have better luck.
 
Old 06-12-2004, 10:38 AM   #7
kaega2
Member
 
Registered: Sep 2003
Location: Ontario, Canada
Distribution: Gentoo 2004.3
Posts: 195

Original Poster
Rep: Reputation: 30
Yeah, I doing what you suggested Willie, and I run into the problem that I always run into.

When I compile from source (this has happened since upgrading to mandrake 10.0) The sound on mpeg files sounds bubbly. Like some peopel are talking underwater and instruments aren't tuned properly. It work fine when I use the urpmi command (which I imagine this was something which was fixed in the package to make it work). I've seen other people have this problem too.

And doug, you're eventually going to have the same problem I'm having right now. Some WMV files won't work or will work without sound as well as some quicktime files. Most video files work just fine (which I'm thankful for) but I have some quicktime video that was rendered with final cut pro or just plain quicktime on a mac, and those video's won't play properly. As well as some WMV's I recorded in Windows awhile ago.

These files aren't a big deal, I just want to see them. So it would be nice if I could get it working with Perfect sound. Does anybody else have any other suggestions?

PS: I actually haven't tried the easy urpmi site yet doug, I looked over it but didn't have time to continue. I'll let you know if that does it

Last edited by kaega2; 06-12-2004 at 10:39 AM.
 
Old 06-12-2004, 10:54 AM   #8
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
as doug_s mentioned in an earlier post, use EasyUrpmi to set up PLF & contrib sources. get all the PLF mplayer stuff.......... mplayer, gmplayer, mplayerskins, & all codecs. it will all install & set up for you automatically & will play any type of media file. does for me, at least.......... mpg, avi, wmv, mov, etc. they all work, video & sound. the only thin you might have to do yourself is go to mplayer preferences & pick the audio & video drivers that work best for you.

otis
 
Old 06-12-2004, 10:05 PM   #9
kaega2
Member
 
Registered: Sep 2003
Location: Ontario, Canada
Distribution: Gentoo 2004.3
Posts: 195

Original Poster
Rep: Reputation: 30
Ok, I have to admit, when it started download software from mirrors after running urpmi... I was impressed. so I want to make sure that I have this straight

are you saying that by updating my information by following the steps given by doug, then I just do urpmi mplayer again and it should get my codecs? Also I noticed that there's something now here called kmplayer. What's that?

I'm still testing this out, so I don't know how it's working yet. I'll let you know.
 
Old 06-13-2004, 06:11 AM   #10
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
Kmplayer is a (sorta) mplayer clone designed to integrate with KDE (hence the K). it is not the same as mplayer, though. they are 2 different apps.

the mplayer packages you'll need to install are as follows........

(all of these will be followed by their particular version numbers. this list is just the main name of each package)

mplayer (plf)
mplayer-gui (plf)
mplayerplug-in
mplayer-skins
real-codecs (plf)
win32-codecs (plf)
xanim-codecs (plf)

a bit about urpmi............

when you type urmpi mplayer, it will search your various sources for anything with the name mplayer. if you have more than one mplayer choice, choose the plf version. it will probably tell you it also needs some dependencies. if so, install those too. just make sure you get all of the above packages for it to work properly.

you should also periodically update your various sources. the easiest way to to this is in terminal as root (you need to be root for urpmi for all installations, by the way) type....... urpmi.update -a
that will update any source you have installed if it needs it. occasionally one (or more) of your source sites might be down or inaccessable. if so, it will tell you that it failed to update. if that's the case, you can either just wait & try again later, or use EasyUrpmi to add a different source. for all types of tricks & commands to use with urpmi check out the man pages for it (man urpmi in terminal as root).

finally, while urpmi is good to get acquainted with, if you want to use the GUI front end to it, simply open MCC (Mandrake Control Center)->software management. from there you can install, uninstall, update, & add/remove packages/sources. for instance, to install the above mplayer packages, use the "install software packages" (rpmdrake) function. type the name (or partial name) of the app in the search box & click "search". it will bring up any apps that match the search. since it's the GUI front end for urpmi, it will also tell you if you need any dependencies, etc. do the same to uninstall packages using the "remove software packages" function.

otis
 
Old 08-12-2004, 09:56 AM   #11
mooreted
Member
 
Registered: May 2003
Posts: 598

Rep: Reputation: 30
"from the command line as a user(not root) run "mplayer"
this will create the .mplayer directory. you can then make a "Skin" directory and "font" directory like so:"

Typing 'mplayer' did not create a .mplayer directory, so I created one myself. Now when I run 'gmplayer' I get this:

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/mooreted/.mplayer/config
[cfg] read config file: /home/mooreted/.mplayer/gui.conf
Reading config file /home/mooreted/.mplayer/gui.conf
Warning unknown option vo_dxr3_device at line 6
vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local display)
Reading /home/mooreted/.mplayer/codecs.conf: Can't open '/home/mooreted/.mplayer /codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /home/mooreted/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/mooreted/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/home/mooreted/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
[skin] file ( /usr/local/share/mplayer/Skin/default/skin ) not found.
Skin not found (default).

I have the 'Blue' skin copied to the .mplayer/Skin directory.
 
Old 08-12-2004, 11:11 AM   #12
kaega2
Member
 
Registered: Sep 2003
Location: Ontario, Canada
Distribution: Gentoo 2004.3
Posts: 195

Original Poster
Rep: Reputation: 30
Strange

Well the error you're seeing right there basially says that the files it's looking for in the .Mplayer folder aren't there. What did it say before you created the .mplayer folder yourself?
 
Old 08-12-2004, 01:01 PM   #13
mooreted
Member
 
Registered: May 2003
Posts: 598

Rep: Reputation: 30
It gave me basically the same errors except that it also could not find the .mplayer directory.
 
Old 08-25-2004, 08:48 AM   #14
Rathann
Member
 
Registered: Jul 2004
Location: Poland
Distribution: RedHat 7.3/8.0/9, Fedora Core 1/2/3/4
Posts: 35

Rep: Reputation: 15
Quote:
Originally posted by mooreted
"from the command line as a user(not root) run "mplayer"
this will create the .mplayer directory. you can then make a "Skin" directory and "font" directory like so:"

Typing 'mplayer' did not create a .mplayer directory, so I created one myself. Now when I run 'gmplayer' I get this:

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/mooreted/.mplayer/config
[cfg] read config file: /home/mooreted/.mplayer/gui.conf
Reading config file /home/mooreted/.mplayer/gui.conf
Warning unknown option vo_dxr3_device at line 6
You could remove line 6 to get rid of this warning.
Quote:

vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local display)
Reading /home/mooreted/.mplayer/codecs.conf: Can't open '/home/mooreted/.mplayer /codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /home/mooreted/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
You could do as it suggests, i.e. add that line to - for example - /etc/rc.d/rc.local.
Quote:

Using usleep() timing
Can't open input config file /home/mooreted/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/home/mooreted/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
[skin] file ( /usr/local/share/mplayer/Skin/default/skin ) not found.
Skin not found (default).

I have the 'Blue' skin copied to the .mplayer/Skin directory.
You don't have to worry about apparently missing config files, MPlayer has built-in default configs
and the files can be set up there to change these defaults. It's not enough, however, to simply put any skin in ~/.mplayer/Skin/. You need to have at least one skin named "default". You may of course make it a link to any skin of your choice, i.e.
Code:
ln -s Blue default
.
 
Old 08-25-2004, 08:58 AM   #15
mooreted
Member
 
Registered: May 2003
Posts: 598

Rep: Reputation: 30
Thanks for all the help. I have been using Linux for about 3 years now and in that time I have only had Mplayer working sporadically. I have switched to Xine. It's easy to install and plays everything.

I do appreciate your respose though.

Have a good day.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
codecs for mplayer post install dr_zayus69 Linux - Software 2 12-08-2004 11:22 AM
How can I install mplayer, xine and codecs? kjp_72 Linux - Newbie 6 05-27-2004 03:25 PM
mplayer codecs after install true_atlantis Linux - Software 3 05-01-2004 05:06 PM
install mplayer codecs JROCK1980 Linux - Software 1 04-08-2004 11:53 PM
how to install codecs in mplayer? niton Linux - Software 4 02-06-2004 08:13 PM


All times are GMT -5. The time now is 12:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration